Update to 4.0.1
- Drop upstream texinfo patch
This commit is contained in:
parent
f8eb2026e1
commit
a4990edc1a
1
.gitignore
vendored
1
.gitignore
vendored
@ -21,3 +21,4 @@ octave-3.2.4.tar.bz2
|
|||||||
/octave-3.8.2-rc2.tar.gz
|
/octave-3.8.2-rc2.tar.gz
|
||||||
/octave-3.8.2.tar.bz2
|
/octave-3.8.2.tar.bz2
|
||||||
/octave-4.0.0.tar.xz
|
/octave-4.0.0.tar.xz
|
||||||
|
/octave-4.0.1.tar.xz
|
||||||
|
@ -1,48 +0,0 @@
|
|||||||
diff -up octave-4.0.0/doc/liboctave/Makefile.in.texinfo6 octave-4.0.0/doc/liboctave/Makefile.in
|
|
||||||
--- octave-4.0.0/doc/liboctave/Makefile.in.texinfo6 2015-05-26 10:21:42.000000000 -0600
|
|
||||||
+++ octave-4.0.0/doc/liboctave/Makefile.in 2015-07-14 10:40:50.131788830 -0600
|
|
||||||
@@ -1854,7 +1854,6 @@ localstartupfiledir = ${localfcnfiledir}
|
|
||||||
# The separator used for elements of the LD_PRELOAD variable (might be
|
|
||||||
# a space, so protect with $(null))
|
|
||||||
null =
|
|
||||||
-TEXINFO_TEX = ../texinfo.tex
|
|
||||||
info_TEXINFOS = liboctave.texi
|
|
||||||
liboctave_TEXINFOS = \
|
|
||||||
array.texi \
|
|
||||||
diff -up octave-4.0.0/libinterp/corefcn/utils.cc.texinfo6 octave-4.0.0/libinterp/corefcn/utils.cc
|
|
||||||
--- octave-4.0.0/libinterp/corefcn/utils.cc.texinfo6 2015-05-23 08:21:53.000000000 -0600
|
|
||||||
+++ octave-4.0.0/libinterp/corefcn/utils.cc 2015-07-14 09:46:17.300468145 -0600
|
|
||||||
@@ -22,7 +22,7 @@ along with Octave; see the file COPYING.
|
|
||||||
*/
|
|
||||||
|
|
||||||
#ifdef HAVE_CONFIG_H
|
|
||||||
-#include <config.h>
|
|
||||||
+#include "config.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#include <cerrno>
|
|
||||||
@@ -1379,7 +1379,7 @@ indexing using @var{ind} will not perfor
|
|
||||||
\n\
|
|
||||||
Implementation Note: Strings are first converted to double values before the\n\
|
|
||||||
checks for valid indices are made. Unless a string contains the NULL\n\
|
|
||||||
-character @nospell{\"\\0\"}, it will always be a valid index.\n\
|
|
||||||
+character @nospell{\"@xbackslashchar{}0\"}, it will always be a valid index.\n\
|
|
||||||
@end deftypefn")
|
|
||||||
{
|
|
||||||
octave_value retval;
|
|
||||||
diff -up octave-4.0.0/scripts/io/beep.m.texinfo6 octave-4.0.0/scripts/io/beep.m
|
|
||||||
--- octave-4.0.0/scripts/io/beep.m.texinfo6 2015-05-23 08:21:53.000000000 -0600
|
|
||||||
+++ octave-4.0.0/scripts/io/beep.m 2015-07-14 09:46:16.894469886 -0600
|
|
||||||
@@ -20,9 +20,9 @@
|
|
||||||
## @deftypefn {Function File} {} beep ()
|
|
||||||
## Produce a beep from the speaker (or visual bell).
|
|
||||||
##
|
|
||||||
-## This function sends the alarm character @qcode{"\a"} to the terminal.
|
|
||||||
-## Depending on the user's configuration this may produce an audible beep,
|
|
||||||
-## a visual bell, or nothing at all.
|
|
||||||
+## This function sends the alarm character @qcode{"@xbackslashchar{}a"} to
|
|
||||||
+## the terminal. Depending on the user's configuration this may produce an
|
|
||||||
+## audible beep, a visual bell, or nothing at all.
|
|
||||||
## @seealso{puts, fputs, printf, fprintf}
|
|
||||||
## @end deftypefn
|
|
||||||
|
|
15
octave.spec
15
octave.spec
@ -19,8 +19,8 @@
|
|||||||
|
|
||||||
Name: octave
|
Name: octave
|
||||||
Epoch: 6
|
Epoch: 6
|
||||||
Version: 4.0.0
|
Version: 4.0.1
|
||||||
Release: 14%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A high-level language for numerical computations
|
Summary: A high-level language for numerical computations
|
||||||
Group: Applications/Engineering
|
Group: Applications/Engineering
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
@ -37,9 +37,6 @@ Source2: xorg.conf
|
|||||||
# Fix to allow pkg build to use a directory
|
# Fix to allow pkg build to use a directory
|
||||||
# https://savannah.gnu.org/bugs/?func=detailitem&item_id=32839
|
# https://savannah.gnu.org/bugs/?func=detailitem&item_id=32839
|
||||||
Patch0: octave-pkgbuilddir.patch
|
Patch0: octave-pkgbuilddir.patch
|
||||||
# Upstream patch to fix texinfo6 doc builds
|
|
||||||
# http://hg.savannah.gnu.org/hgweb/octave/rev/2ec049e50ed8
|
|
||||||
Patch1: octave-texinfo6-2ec049e50ed8.patch
|
|
||||||
# Remove project_group from appdata.xml file
|
# Remove project_group from appdata.xml file
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1293561
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1293561
|
||||||
Patch2: octave-appdata.patch
|
Patch2: octave-appdata.patch
|
||||||
@ -167,10 +164,6 @@ This package contains documentation for Octave.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}%{?rctag}
|
%setup -q -n %{name}-%{version}%{?rctag}
|
||||||
%patch0 -p1 -b .pkgbuilddir
|
%patch0 -p1 -b .pkgbuilddir
|
||||||
%if %{builddocs}
|
|
||||||
%patch1 -p1 -b .texinfo6
|
|
||||||
rm doc/texinfo.tex
|
|
||||||
%endif
|
|
||||||
%patch2 -p1 -b .appdata
|
%patch2 -p1 -b .appdata
|
||||||
%patch3 -p1 -b .signbit
|
%patch3 -p1 -b .signbit
|
||||||
%patch4 -p1 -b .gnulib
|
%patch4 -p1 -b .gnulib
|
||||||
@ -410,6 +403,10 @@ fi
|
|||||||
%{_pkgdocdir}/refcard*.pdf
|
%{_pkgdocdir}/refcard*.pdf
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 22 2016 Orion Poplawski <orion@cora.nwra.com> - 6:4.0.1-1
|
||||||
|
- Update to 4.0.1
|
||||||
|
- Drop upstream texinfo patch
|
||||||
|
|
||||||
* Fri Mar 11 2016 Orion Poplawski <orion@cora.nwra.com> - 6:4.0.0-14
|
* Fri Mar 11 2016 Orion Poplawski <orion@cora.nwra.com> - 6:4.0.0-14
|
||||||
- Rebuild for glpk 4.59
|
- Rebuild for glpk 4.59
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user