Adding files missed in failed package creation.
This commit is contained in:
parent
f65de7dbb7
commit
951b68c2cd
@ -1,5 +1 @@
|
||||
octave-2.1.70.tar.bz2
|
||||
octave-2.1.70-glob.patch
|
||||
octave-2.1.70-libs.patch
|
||||
octave-2.1.70-toplev.patch
|
||||
octave.spec
|
||||
|
13
octave-2.1.70-glob.patch
Normal file
13
octave-2.1.70-glob.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- liboctave/Makefile.in.~1~ 2005-03-04 10:13:57.000000000 -0600
|
||||
+++ liboctave/Makefile.in 2005-05-06 12:53:58.324716584 -0500
|
||||
@@ -19,8 +19,8 @@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
|
||||
LINK_DEPS = \
|
||||
- -L../libcruft -L../glob -L. $(RLD_FLAG) \
|
||||
- $(LIBCRUFT) $(BLAS_LIBS) $(FFTW_LIBS) $(LIBREADLINE) -lglob $(LIBS) $(FLIBS)
|
||||
+ -L../libcruft -L. $(RLD_FLAG) \
|
||||
+ $(LIBCRUFT) $(BLAS_LIBS) $(FFTW_LIBS) $(LIBREADLINE) $(LIBS) $(FLIBS)
|
||||
|
||||
MATRIX_INC := Array.h Array2.h Array3.h ArrayN.h DiagArray2.h \
|
||||
Array-flags.h Array-util.h ArrayN-idx.h MArray-defs.h \
|
251
octave-2.1.70-libs.patch
Normal file
251
octave-2.1.70-libs.patch
Normal file
@ -0,0 +1,251 @@
|
||||
ChangeLog:
|
||||
|
||||
2005-05-06 John W. Eaton <jwe@octave.org>
|
||||
|
||||
* octMakefile.in (DISTDIRS): Remove glob from the list.
|
||||
(dist): No need to clean up in glob subdirectory.
|
||||
* glob: Delete directory.
|
||||
* Makeconf.in (GLOB_INCFLAGS, LIBGLOB): Delete.
|
||||
(do-subst-config-vals): Don't substitute them.
|
||||
(INCFLAGS): Remove $(GLOB_INCFLAGS) from the list.
|
||||
* configure.in: Don't test for glob or fnmatch.
|
||||
|
||||
|
||||
src/ChangeLog:
|
||||
|
||||
2005-05-06 John W. Eaton <jwe@octave.org>
|
||||
|
||||
* toplev.cc (octave_config_info): Remove LIBGLOB and GLOB_INCFLAGS
|
||||
from the list.
|
||||
* oct-conf.h.in (OCTAVE_CONF_LIBGLOB, OCTAVE_CONF_GLOB_INCFLAGS):
|
||||
Delete.
|
||||
* Makefile.in (OCTAVE_LIBS): Remove $(LIBGLOB) from the list.
|
||||
|
||||
|
||||
Index: Makeconf.in
|
||||
===================================================================
|
||||
RCS file: /usr/local/cvsroot/octave/Makeconf.in,v
|
||||
retrieving revision 1.151.2.1
|
||||
diff -u -r1.151.2.1 Makeconf.in
|
||||
--- Makeconf.in 21 Feb 2005 16:49:41 -0000 1.151.2.1
|
||||
+++ Makeconf.in 6 May 2005 18:52:53 -0000
|
||||
@@ -91,7 +91,6 @@
|
||||
# cc and associated flags.
|
||||
|
||||
DLFCN_INCFLAGS = @DLFCN_INCFLAGS@
|
||||
-GLOB_INCFLAGS = @GLOB_INCFLAGS@
|
||||
|
||||
# Clean up INCFLAGS a bit if we are not compiling in a separate
|
||||
# directory.
|
||||
@@ -109,7 +108,7 @@
|
||||
-I$(top_srcdir)/liboctave -I$(top_srcdir)/src \
|
||||
-I$(top_srcdir)/libcruft/misc
|
||||
endif
|
||||
-INCFLAGS = $(TMP_IF_1) $(TMP_IF_2) $(DLFCN_INCFLAGS) $(GLOB_INCFLAGS)
|
||||
+INCFLAGS = $(TMP_IF_1) $(TMP_IF_2) $(DLFCN_INCFLAGS)
|
||||
|
||||
LIBFLAGS = -L$(TOPDIR)
|
||||
|
||||
@@ -170,7 +169,6 @@
|
||||
FLIBS = @FLIBS@
|
||||
|
||||
LIBDLFCN = @LIBDLFCN@
|
||||
-LIBGLOB = @LIBGLOB@
|
||||
LIBPLPLOT = @LIBPLPLOT@
|
||||
LIBOCTINTERP = @LIBOCTINTERP@
|
||||
LIBOCTAVE = @LIBOCTAVE@
|
||||
@@ -422,7 +420,6 @@
|
||||
-e "s;%OCTAVE_CONF_FFTW_LIBS%;\"${FFTW_LIBS}\";" \
|
||||
-e "s;%OCTAVE_CONF_FLIBS%;\"${FLIBS}\";" \
|
||||
-e "s;%OCTAVE_CONF_FPICFLAG%;\"${FPICFLAG}\";" \
|
||||
- -e "s;%OCTAVE_CONF_GLOB_INCFLAGS%;\"${GLOB_INCFLAGS}\";" \
|
||||
-e "s;%OCTAVE_CONF_INCFLAGS%;\"${INCFLAGS}\";" \
|
||||
-e "s;%OCTAVE_CONF_LD_CXX%;\"${LD_CXX}\";" \
|
||||
-e "s;%OCTAVE_CONF_LDFLAGS%;\"${LDFLAGS}\";" \
|
||||
@@ -434,7 +431,6 @@
|
||||
-e "s;%OCTAVE_CONF_LIBDLFCN%;\"${LIBDLFCN}\";" \
|
||||
-e "s;%OCTAVE_CONF_LIBEXT%;\"${LIBEXT}\";" \
|
||||
-e "s;%OCTAVE_CONF_LIBFLAGS%;\"${LIBFLAGS}\";" \
|
||||
- -e "s;%OCTAVE_CONF_LIBGLOB%;\"${LIBGLOB}\";" \
|
||||
-e "s;%OCTAVE_CONF_LIBOCTAVE%;\"${LIBOCTAVE}\";" \
|
||||
-e "s;%OCTAVE_CONF_LIBOCTINTERP%;\"${LIBOCTINTERP}\";" \
|
||||
-e "s;%OCTAVE_CONF_LIBPLPLOT%;\"${LIBPLPLOT}\";" \
|
||||
Index: configure.in
|
||||
===================================================================
|
||||
RCS file: /usr/local/cvsroot/octave/configure.in,v
|
||||
retrieving revision 1.458.2.7
|
||||
diff -u -r1.458.2.7 configure.in
|
||||
--- configure.in 26 Apr 2005 19:43:53 -0000 1.458.2.7
|
||||
+++ configure.in 6 May 2005 18:52:54 -0000
|
||||
@@ -920,8 +920,6 @@
|
||||
AC_CHECK_HEADERS($TERMIOS_H, have_termios_h=yes)
|
||||
AC_CHECK_HEADERS(termio.h, have_termio_h=yes, have_termio_h=no)
|
||||
AC_CHECK_HEADERS(sgtty.h, have_sgtty_h=yes, have_sgtty_h=no)
|
||||
-AC_CHECK_HEADERS(glob.h, have_glob_h=yes, have_glob_h=no)
|
||||
-AC_CHECK_HEADERS(fnmatch.h, have_fnmatch_h=yes, have_fnmatch_h=no)
|
||||
AC_CHECK_HEADERS(conio.h, have_conio_h=yes, have_conio_h=no)
|
||||
|
||||
### I'm told that termios.h is broken on NeXT systems.
|
||||
@@ -943,42 +941,6 @@
|
||||
AC_MSG_WARN([I couldn't find termios.h, termio.h, or sgtty.h!])
|
||||
fi
|
||||
|
||||
-## I'm told that setting LIBGLOB to be $(TOPDIR)/glob/libglob.a causes
|
||||
-## trouble on SCO systems, but setting it to be the two object files
|
||||
-## avoids the problem.
|
||||
-
|
||||
-GLOB_DIR=glob
|
||||
-if test -n "$ALLOCA"; then
|
||||
- LIBGLOB='$(TOPDIR)/glob/glob.o $(TOPDIR)/glob/fnmatch.o $(TOPDIR)/glob/alloca.o'
|
||||
-else
|
||||
- LIBGLOB='$(TOPDIR)/glob/glob.o $(TOPDIR)/glob/fnmatch.o'
|
||||
-fi
|
||||
-GLOB_INCFLAGS='-I$(top_srcdir)/glob -I$(TOPDIR)/glob'
|
||||
-if test "$have_fnmatch_h" = yes && test "$have_glob_h" = yes; then
|
||||
- AC_EGREP_CPP(yes, [#include <fnmatch.h>
|
||||
-#ifdef FNM_NOESCAPE
|
||||
-#ifdef FNM_PATHNAME
|
||||
-#ifdef FNM_PERIOD
|
||||
- yes
|
||||
-#endif
|
||||
-#endif
|
||||
-#endif
|
||||
- ], [
|
||||
- GLOB_DIR=
|
||||
- AC_CHECK_LIB(glob, glob)
|
||||
- AC_CHECK_FUNCS(fnmatch, have_fnmatch=yes, have_fnmatch=no)
|
||||
- AC_CHECK_FUNCS(glob, have_glob=yes, have_glob=no)
|
||||
- if test "$have_fnmatch" = yes && test "$have_glob" = yes; then
|
||||
- GLOB_DIR=
|
||||
- LIBGLOB=
|
||||
- GLOB_INCFLAGS=
|
||||
- fi
|
||||
- ])
|
||||
-fi
|
||||
-AC_SUBST(GLOB_DIR)
|
||||
-AC_SUBST(LIBGLOB)
|
||||
-AC_SUBST(GLOB_INCFLAGS)
|
||||
-
|
||||
### Checks for functions and variables.
|
||||
|
||||
AC_CHECK_FUNCS(atexit basename bcopy bzero canonicalize_file_name \
|
||||
@@ -1365,13 +1327,6 @@
|
||||
|
||||
AC_CONFIG_SUBDIRS(scripts)
|
||||
|
||||
-# autoconf 2.50 deprecates the use of variables (e.g. $GLOB_DIR)
|
||||
-# in AC_CONFIG_SUBDIRS; the following form is recommended instead:
|
||||
-
|
||||
-if test "x$GLOB_DIR" = xglob; then
|
||||
- AC_CONFIG_SUBDIRS(glob)
|
||||
-fi
|
||||
-
|
||||
if test "x$PLPLOT_DIR" = xplplot; then
|
||||
AC_CONFIG_SUBDIRS(plplot)
|
||||
fi
|
||||
Index: octMakefile.in
|
||||
===================================================================
|
||||
RCS file: /usr/local/cvsroot/octave/octMakefile.in,v
|
||||
retrieving revision 1.195
|
||||
diff -u -r1.195 octMakefile.in
|
||||
--- octMakefile.in 2 Apr 2004 14:54:20 -0000 1.195
|
||||
+++ octMakefile.in 6 May 2005 18:52:54 -0000
|
||||
@@ -32,10 +32,10 @@
|
||||
mkoctfile.in texi2dvi ChangeLog ChangeLog.[0-9]
|
||||
|
||||
# Complete directory trees to distribute.
|
||||
-DISTDIRS = glob # plplot
|
||||
+DISTDIRS = # plplot
|
||||
|
||||
# Subdirectories in which to run `make all'.
|
||||
-SUBDIRS = @PLPLOT_DIR@ @DLFCN_DIR@ @GLOB_DIR@ \
|
||||
+SUBDIRS = @PLPLOT_DIR@ @DLFCN_DIR@ \
|
||||
libcruft liboctave scripts doc examples
|
||||
|
||||
ALL_SUBDIRS = $(SUBDIRS) src
|
||||
@@ -62,7 +62,7 @@
|
||||
BINDISTSUBDIRS = libcruft liboctave src scripts doc emacs examples
|
||||
|
||||
# Subdirectories in which to run clean targets.
|
||||
-CLEANSUBDIRS = $(DISTSUBDIRS) @GLOB_DIR@
|
||||
+CLEANSUBDIRS = $(DISTSUBDIRS)
|
||||
|
||||
DIRS_TO_MAKE = $(bindir) $(libdir) $(octincludedir)/octave $(fcnfiledir) \
|
||||
$(octfiledir) $(archlibdir) $(localarchlibdir) $(localverarchlibdir) \
|
||||
@@ -179,8 +179,6 @@
|
||||
-o -name config.status -o -name config.cache -o -name stamp-h \
|
||||
-o -name klibtool.config -o -name stamp-auto \
|
||||
-o -name c-auto.h \) -print | xargs rm -rf
|
||||
- find `cat .fname`/glob -name Makefile | xargs rm -f
|
||||
- find `cat .fname`/glob -name config.h | xargs rm -f
|
||||
rm -f `cat .fname`/test/octave.test/*.m
|
||||
chmod -R a+rwX `cat .fname`
|
||||
tar cf `cat .fname`.tar `cat .fname`
|
||||
Index: src/Makefile.in
|
||||
===================================================================
|
||||
RCS file: /usr/local/cvsroot/octave/src/Makefile.in,v
|
||||
retrieving revision 1.352.2.5
|
||||
diff -u -r1.352.2.5 Makefile.in
|
||||
--- src/Makefile.in 2 Mar 2005 01:33:30 -0000 1.352.2.5
|
||||
+++ src/Makefile.in 6 May 2005 18:53:00 -0000
|
||||
@@ -213,7 +213,7 @@
|
||||
|
||||
OCTAVE_LIBS = $(LIBOCTINTERP) $(LIBOCTAVE) \
|
||||
$(SPECIAL_MATH_LIB) $(LIBCRUFT) \
|
||||
- $(LIBPLPLOT) $(LIBGLOB) $(LIBDLFCN)
|
||||
+ $(LIBPLPLOT) $(LIBDLFCN)
|
||||
|
||||
OCTINTERP_LINK_DEPS = \
|
||||
-L../liboctave $(LIBOCTAVE) -L../libcruft $(LIBCRUFT) $(LIBS) $(FLIBS)
|
||||
Index: src/oct-conf.h.in
|
||||
===================================================================
|
||||
RCS file: /usr/local/cvsroot/octave/src/oct-conf.h.in,v
|
||||
retrieving revision 1.23.2.1
|
||||
diff -u -r1.23.2.1 oct-conf.h.in
|
||||
--- src/oct-conf.h.in 26 Apr 2005 19:43:58 -0000 1.23.2.1
|
||||
+++ src/oct-conf.h.in 6 May 2005 18:53:00 -0000
|
||||
@@ -149,10 +149,6 @@
|
||||
#define OCTAVE_CONF_FPICFLAG %OCTAVE_CONF_FPICFLAG%
|
||||
#endif
|
||||
|
||||
-#ifndef OCTAVE_CONF_GLOB_INCFLAGS
|
||||
-#define OCTAVE_CONF_GLOB_INCFLAGS %OCTAVE_CONF_GLOB_INCFLAGS%
|
||||
-#endif
|
||||
-
|
||||
#ifndef OCTAVE_CONF_INCFLAGS
|
||||
#define OCTAVE_CONF_INCFLAGS %OCTAVE_CONF_INCFLAGS%
|
||||
#endif
|
||||
@@ -197,10 +193,6 @@
|
||||
#define OCTAVE_CONF_LIBFLAGS %OCTAVE_CONF_LIBFLAGS%
|
||||
#endif
|
||||
|
||||
-#ifndef OCTAVE_CONF_LIBGLOB
|
||||
-#define OCTAVE_CONF_LIBGLOB %OCTAVE_CONF_LIBGLOB%
|
||||
-#endif
|
||||
-
|
||||
#ifndef OCTAVE_CONF_LIBOCTAVE
|
||||
#define OCTAVE_CONF_LIBOCTAVE %OCTAVE_CONF_LIBOCTAVE%
|
||||
#endif
|
||||
Index: src/toplev.cc
|
||||
===================================================================
|
||||
RCS file: /usr/local/cvsroot/octave/src/toplev.cc,v
|
||||
retrieving revision 1.153.2.4
|
||||
diff -u -r1.153.2.4 toplev.cc
|
||||
--- src/toplev.cc 26 Apr 2005 19:44:00 -0000 1.153.2.4
|
||||
+++ src/toplev.cc 6 May 2005 18:53:00 -0000
|
||||
@@ -672,7 +672,6 @@
|
||||
"FFTW_LIBS", OCTAVE_CONF_FFTW_LIBS,
|
||||
"FLIBS", OCTAVE_CONF_FLIBS,
|
||||
"FPICFLAG", OCTAVE_CONF_FPICFLAG,
|
||||
- "GLOB_INCFLAGS", OCTAVE_CONF_GLOB_INCFLAGS,
|
||||
"INCFLAGS", OCTAVE_CONF_INCFLAGS,
|
||||
"LDFLAGS", OCTAVE_CONF_LDFLAGS,
|
||||
"LD_CXX", OCTAVE_CONF_LD_CXX,
|
||||
@@ -684,7 +683,6 @@
|
||||
"LIBDLFCN", OCTAVE_CONF_LIBDLFCN,
|
||||
"LIBEXT", OCTAVE_CONF_LIBEXT,
|
||||
"LIBFLAGS", OCTAVE_CONF_LIBFLAGS,
|
||||
- "LIBGLOB", OCTAVE_CONF_LIBGLOB,
|
||||
"LIBOCTAVE", OCTAVE_CONF_LIBOCTAVE,
|
||||
"LIBOCTINTERP", OCTAVE_CONF_LIBOCTINTERP,
|
||||
"LIBPLPLOT", OCTAVE_CONF_LIBPLPLOT,
|
56
octave-2.1.70-toplev.patch
Normal file
56
octave-2.1.70-toplev.patch
Normal file
@ -0,0 +1,56 @@
|
||||
src/ChangeLog:
|
||||
|
||||
2005-05-06 John W. Eaton <jwe@octave.org>
|
||||
|
||||
* toplev.cc (Fsystem): Move enum exec_type declaration to file
|
||||
scope and rename system_exec_type. Change all uses.
|
||||
|
||||
|
||||
Index: src/toplev.cc
|
||||
===================================================================
|
||||
RCS file: /usr/local/cvsroot/octave/src/toplev.cc,v
|
||||
retrieving revision 1.153.2.5
|
||||
diff -u -r1.153.2.5 toplev.cc
|
||||
--- src/toplev.cc 6 May 2005 18:59:41 -0000 1.153.2.5
|
||||
+++ src/toplev.cc 6 May 2005 19:02:49 -0000
|
||||
@@ -400,6 +400,8 @@
|
||||
return retval;
|
||||
}
|
||||
|
||||
+enum system_exec_type { et_sync, et_async };
|
||||
+
|
||||
DEFUN (system, args, nargout,
|
||||
"-*- texinfo -*-\n\
|
||||
@deftypefn {Built-in Function} {} system (@var{string}, @var{return_output}, @var{type})\n\
|
||||
@@ -454,9 +456,7 @@
|
||||
|
||||
std::string cmd_str = args(0).string_value ();
|
||||
|
||||
- enum exec_type { sync, async };
|
||||
-
|
||||
- exec_type type = sync;
|
||||
+ system_exec_type type = et_sync;
|
||||
|
||||
if (! error_state)
|
||||
{
|
||||
@@ -467,9 +467,9 @@
|
||||
if (! error_state)
|
||||
{
|
||||
if (type_str == "sync")
|
||||
- type = sync;
|
||||
+ type = et_sync;
|
||||
else if (type_str == "async")
|
||||
- type = async;
|
||||
+ type = et_async;
|
||||
else
|
||||
error ("system: third arg must be \"sync\" or \"async\"");
|
||||
}
|
||||
@@ -482,7 +482,7 @@
|
||||
|
||||
if (! error_state)
|
||||
{
|
||||
- if (type == async)
|
||||
+ if (type == et_async)
|
||||
{
|
||||
#ifdef HAVE_FORK
|
||||
pid_t pid = fork ();
|
407
octave.spec
Normal file
407
octave.spec
Normal file
@ -0,0 +1,407 @@
|
||||
%define __libtoolize /bin/true
|
||||
|
||||
Summary: A high-level language for numerical computations.
|
||||
Name: octave
|
||||
Version: 2.1.70
|
||||
Release: 1
|
||||
Epoch: 6
|
||||
License: GPL
|
||||
Group: Applications/Engineering
|
||||
Source: ftp://ftp.octave.org/pub/octave/bleeding-edge/octave-%{version}.tar.bz2
|
||||
URL: http://www.octave.org
|
||||
Requires: gnuplot less info texinfo
|
||||
Requires: /sbin/install-info
|
||||
BuildPrereq: gnuplot bison flex less tetex gcc-c++ gcc-gfortran gperf lapack blas
|
||||
BuildPrereq: ncurses-devel zlib-devel libtermcap-devel libstdc++-devel
|
||||
BuildPrereq: readline-devel glibc-devel fftw3-devel autoconf
|
||||
Prereq: /sbin/ldconfig
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Requires: /etc/ld.so.conf.d
|
||||
Patch0: octave-2.1.70-glob.patch
|
||||
Patch1: octave-2.1.70-libs.patch
|
||||
Patch2: octave-2.1.70-toplev.patch
|
||||
ExcludeArch: ppc64 s390x
|
||||
|
||||
%description
|
||||
GNU Octave is a high-level language, primarily intended for numerical
|
||||
computations. It provides a convenient command line interface for
|
||||
solving linear and nonlinear problems numerically, and for performing
|
||||
other numerical experiments using a language that is mostly compatible
|
||||
with Matlab. It may also be used as a batch-oriented language. Octave
|
||||
has extensive tools for solving common numerical linear algebra
|
||||
problems, finding the roots of nonlinear equations, integrating
|
||||
ordinary functions, manipulating polynomials, and integrating ordinary
|
||||
differential and differential-algebraic equations. It is easily
|
||||
extensible and customizable via user-defined functions written in
|
||||
Octave's own language, or using dynamically loaded modules written in
|
||||
C++, C, Fortran, or other languages.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Development headers and files for Octave
|
||||
Group: Development/Libraries
|
||||
|
||||
%description devel
|
||||
The octave-devel package contains files needed for developing
|
||||
applications which use GNU Octave.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p0
|
||||
%patch1 -p0
|
||||
%patch2 -p0
|
||||
./autogen.sh
|
||||
|
||||
|
||||
%ifarch s390
|
||||
(cd readline && libtoolize --copy --force)
|
||||
(cd glob && libtoolize --copy --force)
|
||||
(cd kpathsea && libtoolize --copy --force)
|
||||
%endif
|
||||
|
||||
%build
|
||||
LC_ALL=POSIX
|
||||
export LC_ALL
|
||||
CFLAGS="$RPM_OPT_FLAGS -fPIC -D_GNU_SOURCE" ./configure --enable-dl --enable-shared=yes --enable-rpath --enable-lite-kernel --enable-picky-flags --enable-static=no --with-g77 --prefix=/usr --infodir=/usr/share/info
|
||||
|
||||
make
|
||||
|
||||
#empty
|
||||
rm -f interpreter/octave.{ky,pg,tp}
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
%makeinstall
|
||||
rm -f doc/interpreter/munge-texi doc/interpreter/*.o
|
||||
strip $RPM_BUILD_ROOT/usr/libexec/octave/%{version}/oct/*/*.oct
|
||||
|
||||
# Make library links
|
||||
mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
|
||||
echo "%{_libdir}/octave-%{version}" > $RPM_BUILD_ROOT/etc/ld.so.conf.d/octave-%{_arch}.conf
|
||||
|
||||
perl -pi -e "s,$RPM_BUILD_ROOT,," $RPM_BUILD_ROOT/%{_libexecdir}/%{name}/ls-R
|
||||
perl -pi -e "s,$RPM_BUILD_ROOT,," $RPM_BUILD_ROOT/%{_datadir}/%{name}/ls-R
|
||||
|
||||
|
||||
# XXX Nuke unpackaged files
|
||||
rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%post
|
||||
/sbin/ldconfig
|
||||
/sbin/install-info --info-dir=%{_infodir}/ --section="Programming:" --entry="* Octave:(octave). Interactive language for numerical computations." %{_infodir}/octave.info.gz
|
||||
|
||||
%preun
|
||||
if [ "$1" = "0" ]; then
|
||||
/sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/octave.info.gz
|
||||
fi
|
||||
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc COPYING NEWS* PROJECTS README* ROADMAP SENDING-PATCHES
|
||||
%doc THANKS
|
||||
%doc doc/faq doc/liboctave doc/refcard emacs examples
|
||||
%{_bindir}/octave
|
||||
%{_bindir}/octave-%{version}
|
||||
/etc/ld.so.conf.d/*
|
||||
%{_libdir}/octave*
|
||||
%{_datadir}/octave
|
||||
%{_libexecdir}/octave/%{version}
|
||||
%{_libexecdir}/octave/site
|
||||
%{_mandir}/man*/octave*
|
||||
%{_infodir}/octave.info*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/mkoctfile*
|
||||
%{_bindir}/octave-bug*
|
||||
%{_bindir}/octave-config*
|
||||
%{_includedir}/octave*
|
||||
%{_mandir}/man*/mkoctfile*
|
||||
%{_libexecdir}/octave/ls-R
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon May 3 2005 Quentin Spencer <qspencer@users.sourceforge.net> 2.1.69-1
|
||||
- Imported 2.1.70 from upstream, removed old patches (resolved in new version)
|
||||
- Changed g77 dependency to gfortran.
|
||||
- Added fftw3 to BuildRequires.
|
||||
- Added patches (from maintainer) to fix build problems.
|
||||
|
||||
* Wed Feb 23 2005 Ivana Varekova <varekova@redhat.com> 2.1.57-13
|
||||
- fix typo in spec 149420
|
||||
|
||||
* Mon Feb 21 2005 Ivana Varekova <varekova@redhat.com> 2.1.57-12
|
||||
- Fix problem with symlinks using ldconfig (bug 147922)
|
||||
|
||||
* Wed Feb 16 2005 Ivana Varekova <varekova@redhat.com> 2.1.57-11
|
||||
- add $RPM_OPT_FLAGS
|
||||
|
||||
* Tue Feb 15 2005 Ivana Varekova <varekova@redhat.com> 2.1.57-10
|
||||
- Fix bug 142477 - problem with signbit definition (Patch2)
|
||||
|
||||
* Wed Jan 19 2005 Ivana Varekova <varekova@redhat.com> 2.1.57-9
|
||||
- Fix bug #142440 - change octave.spec: autoconf is BuildPrereq
|
||||
- Fix bug #142631 - change octave.spec: mkoctfile.1.gz is part of octave-devel not octave
|
||||
|
||||
* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> 2.1.57-8
|
||||
- Rebuilt for new readline.
|
||||
|
||||
* Mon Oct 18 2004 Lon Hohberger <lhh@redhat.com> 2.1.57-7
|
||||
- Don't forget default attributes for -devel package
|
||||
|
||||
* Mon Oct 18 2004 Lon Hohberger <lhh@redhat.com> 2.1.57-6
|
||||
- Remove old lib/lib64 badness.
|
||||
|
||||
* Wed Oct 13 2004 Lon Hohberger <lhh@redhat.com> 2.1.57-5
|
||||
- Split into octave and octave-devel
|
||||
|
||||
* Thu Jun 24 2004 Lon Hohberger <lhh@redhat.com> 2.1.57-4
|
||||
- Remove RPM_BUILD_ROOT from preun section (#119112)
|
||||
|
||||
* Thu Jun 24 2004 Lon Hohberger <lhh@redhat.com> 2.1.57-3
|
||||
- Er, typo in patch (thanks Nils)
|
||||
|
||||
* Thu Jun 24 2004 Lon Hohberger <lhh@redhat.com> 2.1.57-2
|
||||
- Fix for #113852 - signbit broken
|
||||
|
||||
* Wed Jun 15 2004 Lon Hohberger <lhh@redhat.com> 2.1.57-1
|
||||
- Import 2.1.57 from upstream; this fixes #126074
|
||||
|
||||
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Tue Mar 30 2004 Karsten Hopp <karsten@redhat.de> 2.1.50-9
|
||||
- remove builddir references from file list (#119112)
|
||||
|
||||
* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Fri Sep 26 2003 Lon Hohberger <lhh@redhat.com> 2.1.50-7
|
||||
- Add requirement for texinfo. #101299, round 3!
|
||||
|
||||
* Tue Sep 09 2003 Lon Hohberger <lhh@redhat.com> 2.1.50-6
|
||||
- Disable s390x again
|
||||
|
||||
* Tue Sep 09 2003 Lon Hohberger <lhh@redhat.com> 2.1.50-5
|
||||
- Disable ppc64
|
||||
|
||||
* Tue Sep 09 2003 Lon Hohberger <lhh@redhat.com> 2.1.50-4
|
||||
- Rebuild for Taroon
|
||||
|
||||
* Wed Jul 30 2003 Lon Hohberger <lhh@redhat.com> 2.1.50-3
|
||||
- Fix for Bugzilla #101299, round 2. Include a patch to
|
||||
quell sterr from info; it gives us funny messages if $HOME/.info
|
||||
does not exist.
|
||||
|
||||
* Wed Jul 30 2003 Lon Hohberger <lhh@redhat.com> 2.1.50-2
|
||||
- Fix for Bugzilla #101299
|
||||
|
||||
* Mon Jun 30 2003 Lon Hohberger <lhh@redhat.com> 2.1.50-1
|
||||
- Import 2.1.50 from upstream
|
||||
- Fix for Bugzilla #100682; try ppc64 again
|
||||
|
||||
* Mon Jun 30 2003 Lon Hohberger <lhh@redhat.com> 2.1.49-6
|
||||
- Rebuild; disabling ppc64
|
||||
|
||||
* Mon Jun 30 2003 Lon Hohberger <lhh@redhat.com> 2.1.49-4
|
||||
- Added link generation to /usr/lib so that munging
|
||||
/etc/ld.so.conf isn't required to get octave to work.
|
||||
(#98226)
|
||||
|
||||
* Thu Jun 05 2003 Lon Hohberger <lhh@redhat.com> 2.1.49-2
|
||||
- Import from upstream; rebuild
|
||||
|
||||
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Wed Apr 16 2003 Lon Hohberger <lhh@redhat.com> 2.1.46-2
|
||||
- Rebuilt
|
||||
|
||||
* Tue Apr 15 2003 Lon Hohberger <lhh@redhat.com> 2.1.46-1
|
||||
- Import from upstream: 2.1.46. Disabled s390x.
|
||||
|
||||
* Mon Mar 10 2003 Lon Hohberger <lhh@redhat.com> 2.1.40-5
|
||||
- Enabled s390[x]
|
||||
|
||||
* Fri Feb 7 2003 Lon Hohberger <lhh@redhat.com> 2.1.40-4
|
||||
- Disabled s390 and s390x builds for now.
|
||||
|
||||
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Thu Jan 2 2003 Lon Hohberger <lhh@redhat.com> 2.1.40-2
|
||||
- Fixed readline-devel build-rereq line. (#80673)
|
||||
|
||||
* Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 2.1.40-1
|
||||
- update to 2.1.40, fix matrix plotting (#77906).
|
||||
|
||||
* Mon Nov 11 2002 Jeff Johnson <jbj@redhat.com> 2.1.39-2
|
||||
- build on x86_64.
|
||||
|
||||
* Sun Nov 10 2002 Jeff Johnson <jbj@redhat.com> 2.1.39-1
|
||||
- update to 2.1.39.
|
||||
|
||||
* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt with gcc-3.2 (we hope)
|
||||
|
||||
* Mon Aug 5 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.1.36-7
|
||||
- Rebuild
|
||||
|
||||
* Tue Jul 23 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.1.36-6
|
||||
- Rebuild
|
||||
|
||||
* Thu Jul 11 2002 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- Rebuild with new readline
|
||||
|
||||
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Fri Jun 14 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.1.36-3
|
||||
- Get rid of 0 size doc files (#66116)
|
||||
|
||||
* Thu May 23 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.1.36-2
|
||||
- Rebuild
|
||||
- Patch C++ code gcc changed its opinion of the last 3 weeks
|
||||
|
||||
* Wed May 1 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.1.36-1
|
||||
- 2.1.36
|
||||
- Disable patch
|
||||
|
||||
* Wed Feb 27 2002 Trond Eivind Glomsrød <teg@redhat.com> 2.1.35-4
|
||||
- Rebuild
|
||||
|
||||
* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Tue Nov 27 2001 Trond Eivind Glomsrød <teg@redhat.com> 2.1.35-2
|
||||
- Add patch for kpathsea to avoid segfaults
|
||||
|
||||
* Tue Nov 6 2001 Trond Eivind Glomsrød <teg@redhat.com> 2.1.35-1
|
||||
- 2.1.35
|
||||
- s/Copyright/License/
|
||||
|
||||
* Wed Sep 12 2001 Tim Powers <timp@redhat.com>
|
||||
- rebuild with new gcc and binutils
|
||||
|
||||
* Wed Jun 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- Add more dependencies in BuildPrereq (#45184)
|
||||
|
||||
* Fri Jun 08 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- No longer exclude ia64
|
||||
|
||||
* Mon Apr 23 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- 2.1.34
|
||||
|
||||
* Tue Mar 27 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- set LC_ALL to POSIX before building, otherwise the generated paths.h is bad
|
||||
|
||||
* Wed Jan 10 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- 2.1.33
|
||||
|
||||
* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- do not require compat-egcs-c++, but gcc-c++
|
||||
- add some libtoolize calls to add newest versions
|
||||
|
||||
* Fri Dec 15 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- 2.1.32, no longer use CVS as our needed fixes are in now
|
||||
- add Prereq for info
|
||||
|
||||
* Thu Dec 07 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- use a development version, as they have now been fixed
|
||||
to compile with the our current toolchain.
|
||||
|
||||
* Thu Aug 24 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- 2.0.16, with compat C++ compiler and new C and f77 compilers
|
||||
The C++ code is too broken for our new toolchain (C++ reserved
|
||||
words used as enums and function names, arcane macros), but
|
||||
plotting works here and not in the beta (#16759)
|
||||
- add epoch to upgrade the betas
|
||||
|
||||
* Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
|
||||
- make sure #line commands are not output within macro arguments
|
||||
|
||||
* Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- 2.1.31
|
||||
|
||||
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
|
||||
- automatic rebuild
|
||||
|
||||
* Thu Jul 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- no longer disable optimizations, sparc excepted
|
||||
|
||||
* Tue Jul 4 2000 Jakub Jelinek <jakub@redhat.com>
|
||||
- Rebuild with new C++
|
||||
|
||||
* Mon Jul 3 2000 Matt Wilson <msw@redhat.com>
|
||||
- added missing %% before {_infodir} in the %%post
|
||||
|
||||
* Sat Jun 09 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- 2.1.30 - the old version contains invalid C++ code
|
||||
accepted by older compilers.
|
||||
|
||||
* Sat Jun 09 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- disable optimization for C++ code
|
||||
|
||||
* Fri Jun 08 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- add "Excludearch: " for Alpha - it triggers compiler bugs
|
||||
|
||||
* Fri Jun 08 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- use %%configure, %%makeinstall, %{_infodir}. %{_mandir}
|
||||
- remove prefix
|
||||
|
||||
* Tue May 09 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- upgraded to 2.0.16
|
||||
- removed "--enable-g77" from the configure flags - let autoconf find it
|
||||
|
||||
* Thu Jan 20 2000 Tim Powers <timp@redhat.com>
|
||||
- bzipped source to conserve space.
|
||||
|
||||
* Thu Jan 13 2000 Jeff Johnson <jbj@redhat.com>
|
||||
- update to 2.0.15.
|
||||
|
||||
* Tue Jul 20 1999 Tim Powers <timp@redhat.com>
|
||||
- rebuit for 6.1
|
||||
|
||||
* Wed Apr 28 1999 Jeff Johnson <jbj@redhat.com>
|
||||
- update to 2.0.14.
|
||||
|
||||
* Fri Oct 23 1998 Jeff Johnson <jbj@redhat.com>
|
||||
- update to 2.0.13.90
|
||||
|
||||
* Thu Jul 9 1998 Jeff Johnson <jbj@redhat.com>
|
||||
- repackage in powertools.
|
||||
|
||||
* Thu Jun 11 1998 Andrew Veliath <andrewtv@usa.net>
|
||||
- Add %attr, build as user.
|
||||
|
||||
* Mon Jun 1 1998 Andrew Veliath <andrewtv@usa.net>
|
||||
- Add BuildRoot, installinfo, require gnuplot, description from
|
||||
Octave's web page, update to Octave 2.0.13.
|
||||
- Adapt from existing spec file.
|
||||
|
||||
* Tue Dec 2 1997 Otto Hammersmith <otto@redhat.com>
|
||||
- removed libreadline stuff from the file list
|
||||
|
||||
* Mon Nov 24 1997 Otto Hammersmith <otto@redhat.com>
|
||||
- changed configure command to put things in $RPM_ARCH-rehat-linux,
|
||||
rather than genereated one... was causing problems between building
|
||||
on i686 build machine.
|
||||
|
||||
* Mon Nov 17 1997 Otto Hammersmith <otto@redhat.com>
|
||||
- moved buildroot from /tmp to /var/tmp
|
||||
|
||||
* Mon Sep 22 1997 Mike Wangsmo <wanger@redhat.com>
|
||||
- Upgraded to version 2.0.9 and built for glibc system
|
||||
|
||||
* Thu May 01 1997 Michael Fulbright <msf@redhat.com>
|
||||
- Updated to version 2.0.5 and changed to build using a BuildRoot
|
4
sources
4
sources
@ -1,5 +1 @@
|
||||
dc990918d464e17ff7806b1053a40c12 octave-2.1.70.tar.bz2
|
||||
037327dc1628b29b3da436ed6f04a1a7 octave-2.1.70-glob.patch
|
||||
c60edeab87eaa2db951f9778e90c51b6 octave-2.1.70-libs.patch
|
||||
e32cbc0047313928a6f7833c55b7fed0 octave-2.1.70-toplev.patch
|
||||
0679149dcfd71fa004ad681caeb457d5 octave.spec
|
||||
|
Loading…
Reference in New Issue
Block a user