Update to 7.2.0
This commit is contained in:
parent
05ff2329ce
commit
86aa2cf030
1
.gitignore
vendored
1
.gitignore
vendored
@ -40,3 +40,4 @@ octave-3.2.4.tar.bz2
|
||||
/octave-6.3.0.tar.lz
|
||||
/octave-6.4.0.tar.lz
|
||||
/octave-7.1.0.tar.lz
|
||||
/octave-7.2.0.tar.lz
|
||||
|
@ -1,27 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User John Donoghue <john.donoghue@ieee.org>
|
||||
# Date 1652358904 14400
|
||||
# Thu May 12 08:35:04 2022 -0400
|
||||
# Branch stable
|
||||
# Node ID 8c940cfcce257369677c09154da2aab2c56eaa79
|
||||
# Parent 63710f3bd9811c2d206ac9e7b4f47cf06c47e153
|
||||
* scripts/pkg/private/build.m: check configure and Makefile exist before trying to unlink them (Bug #62436)
|
||||
|
||||
diff -r 63710f3bd981 -r 8c940cfcce25 scripts/pkg/private/build.m
|
||||
--- a/scripts/pkg/private/build.m Wed May 11 09:44:55 2022 -0700
|
||||
+++ b/scripts/pkg/private/build.m Thu May 12 08:35:04 2022 -0400
|
||||
@@ -77,8 +77,12 @@
|
||||
else
|
||||
arch_abi = getarch ();
|
||||
configure_make (desc, build_root, verbose);
|
||||
- unlink (fullfile (build_root, "src", "configure"));
|
||||
- unlink (fullfile (build_root, "src", "Makefile"));
|
||||
+ if exist (fullfile (build_root, "src", "configure"), "file")
|
||||
+ unlink (fullfile (build_root, "src", "configure"));
|
||||
+ endif
|
||||
+ if exist (fullfile (build_root, "src", "Makefile"), "file")
|
||||
+ unlink (fullfile (build_root, "src", "Makefile"));
|
||||
+ endif
|
||||
endif
|
||||
tar_name = [desc.name "-" desc.version "-" arch_abi ".tar"];
|
||||
tar_path = fullfile (builddir, tar_name);
|
@ -1,111 +0,0 @@
|
||||
diff --git a/etc/NEWS.7.md b/etc/NEWS.7.md
|
||||
index b44e7ac..9d86936 100644
|
||||
--- a/etc/NEWS.7.md
|
||||
+++ b/etc/NEWS.7.md
|
||||
@@ -325,6 +325,10 @@ major release after 7):
|
||||
`disable_permutation_matrix` | `optimize_permutation_matrix`
|
||||
`disable_range` | `optimize_range`
|
||||
|
||||
+ For plot functions, the use of numbers to select line colors in
|
||||
+ shorthand formats was an undocumented feature that is deprecated in
|
||||
+ Octave 7 and will be removed from Octave 9.
|
||||
+
|
||||
- Operators
|
||||
|
||||
Operator | Replacement | Description
|
||||
@@ -362,7 +366,6 @@ from Octave 8 (or whatever version is the second major release after 6):
|
||||
and a warning is now emitted if it is used, but it will continue to
|
||||
work.
|
||||
|
||||
-
|
||||
### Removed functions, properties, and features
|
||||
|
||||
The following functions and properties were deprecated in Octave 5
|
||||
diff --git a/scripts/help/warning_ids.m b/scripts/help/warning_ids.m
|
||||
index 0215e67..0b46c00 100644
|
||||
--- a/scripts/help/warning_ids.m
|
||||
+++ b/scripts/help/warning_ids.m
|
||||
@@ -190,6 +190,11 @@
|
||||
## scheduled for removal from Octave.
|
||||
## By default, the @code{Octave:deprecated-keyword} warning is enabled.
|
||||
##
|
||||
+## @item Octave:deprecated-option
|
||||
+## If the @code{Octave:deprecated-option} warning is enabled, a
|
||||
+## warning is issued when an obsolete option or input to a function is used.
|
||||
+## By default, the @code{Octave:deprecated-option} warning is enabled.
|
||||
+##
|
||||
## @item Octave:deprecated-property
|
||||
## If the @code{Octave:deprecated-property} warning is enabled, a
|
||||
## warning is issued when Octave encounters a graphics property that
|
||||
diff --git a/scripts/plot/util/__pltopt__.m b/scripts/plot/util/__pltopt__.m
|
||||
index d91b52d..84d5e78 100644
|
||||
--- a/scripts/plot/util/__pltopt__.m
|
||||
+++ b/scripts/plot/util/__pltopt__.m
|
||||
@@ -158,6 +158,12 @@ function [options, valid] = decode_linespec (caller, opt, err_on_invalid)
|
||||
topt = opt(1);
|
||||
n = 1;
|
||||
|
||||
+ if (any (topt == "0":"6"))
|
||||
+ warning ("Octave:deprecated-option", ...
|
||||
+ ["%s: using numbers to select line colors is deprecated. ", ...
|
||||
+ "Use the corresponding color identifier instead."], caller);
|
||||
+ endif
|
||||
+
|
||||
## LineStyles
|
||||
if (strncmp (opt, "--", 2) || strncmp (opt, "-.", 2))
|
||||
options.linestyle = opt(1:2);
|
||||
@@ -181,21 +187,28 @@ function [options, valid] = decode_linespec (caller, opt, err_on_invalid)
|
||||
n = 9;
|
||||
endif
|
||||
endif
|
||||
+ ## Backward compatibility. Leave undocumented.
|
||||
+ if (topt == "@")
|
||||
+ warning ("Octave:deprecated-option", ...
|
||||
+ "%s: marker type '@' is deprecated. Use '+' instead.", ...
|
||||
+ caller);
|
||||
+ topt = "+";
|
||||
+ endif
|
||||
options.marker = topt;
|
||||
- ## Color specs
|
||||
- elseif (topt == "k")
|
||||
+ ## Numeric color specs are for backward compatibility. Don't document.
|
||||
+ elseif (topt == "k" || topt == "0")
|
||||
options.color = [0, 0, 0];
|
||||
- elseif (topt == "r")
|
||||
+ elseif (topt == "r" || topt == "1")
|
||||
if (strncmp (opt, "red", 3))
|
||||
n = 3;
|
||||
endif
|
||||
options.color = [1, 0, 0];
|
||||
- elseif (topt == "g")
|
||||
+ elseif (topt == "g" || topt == "2")
|
||||
if (strncmp (opt, "green", 5))
|
||||
n = 5;
|
||||
endif
|
||||
options.color = [0, 1, 0];
|
||||
- elseif (topt == "b")
|
||||
+ elseif (topt == "b" || topt == "3")
|
||||
if (strncmp (opt, "black", 5))
|
||||
options.color = [0, 0, 0];
|
||||
n = 5;
|
||||
@@ -210,17 +223,17 @@ function [options, valid] = decode_linespec (caller, opt, err_on_invalid)
|
||||
n = 6;
|
||||
endif
|
||||
options.color = [1, 1, 0];
|
||||
- elseif (topt == "m")
|
||||
+ elseif (topt == "m" || topt == "4")
|
||||
if (strncmp (opt, "magenta", 7))
|
||||
n = 7;
|
||||
endif
|
||||
options.color = [1, 0, 1];
|
||||
- elseif (topt == "c")
|
||||
+ elseif (topt == "c" || topt == "5")
|
||||
if (strncmp (opt, "cyan", 4))
|
||||
n = 4;
|
||||
endif
|
||||
options.color = [0, 1, 1];
|
||||
- elseif (topt == "w")
|
||||
+ elseif (topt == "w" || topt == "6")
|
||||
if (strncmp (opt, "white", 5))
|
||||
n = 5;
|
||||
endif
|
13
octave.spec
13
octave.spec
@ -36,8 +36,8 @@
|
||||
|
||||
Name: octave
|
||||
Epoch: 6
|
||||
Version: 7.1.0
|
||||
Release: 3%{?dist}
|
||||
Version: 7.2.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A high-level language for numerical computations
|
||||
License: GPLv3+
|
||||
URL: http://www.octave.org
|
||||
@ -47,12 +47,6 @@ Source0: https://ftp.gnu.org/gnu/octave/octave-%{version}.tar.lz
|
||||
# RPM macros for helping to build Octave packages
|
||||
Source1: macros.octave
|
||||
Source2: xorg.conf
|
||||
# Fix unlink failure on non-existent file in pkg build
|
||||
# https://savannah.gnu.org/bugs/index.php?62436
|
||||
Patch0: bug62436.patch
|
||||
# Deprecate rather than remove support for old numeric linestyles that broke vfrnav tests
|
||||
# https://savannah.gnu.org/bugs/index.php?62470
|
||||
Patch1: octave-linestyles.patch
|
||||
# Add needed time.h header
|
||||
Patch2: octave-time.patch
|
||||
|
||||
@ -451,6 +445,9 @@ make check
|
||||
%{_pkgdocdir}/refcard*.pdf
|
||||
|
||||
%changelog
|
||||
* Tue Aug 02 2022 Orion Poplawski <orion@nwra.com> - 6:7.2.0-1
|
||||
- Update to 7.2.0
|
||||
|
||||
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 6:7.1.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (octave-7.1.0.tar.lz) = 80e7f674d412a9d1300ad91109b891d276b7bf9a9f4cbf97dd6da4f684178f7f1a504f4ae780371dec031a932ac61ccd761853d29c4db60ea5e8ce2d7c71c96c
|
||||
SHA512 (octave-7.2.0.tar.lz) = 15189bfb28f9df74949d292cd712e8bd0ade72a8a5148f29bc386039cad3cbb0c1e55b5212bceb3c9285fd5a1a2663185ff7c80e8435ff14665469df58d76c0e
|
||||
|
Loading…
x
Reference in New Issue
Block a user