Merge branch 'el6' of ssh://pkgs.fedoraproject.org/octave into el6
This commit is contained in:
commit
78fadf8a8c
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1,3 @@
|
||||
/octave-3.4.0.tar.bz2
|
||||
/octave-3.4.2.tar.bz2
|
||||
/octave-3.4.3.tar.bz2
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -up octave-3.4.0/liboctave/oct-alloc.h.gcc46 octave-3.4.0/liboctave/oct-alloc.h
|
||||
--- octave-3.4.0/liboctave/oct-alloc.h.gcc46 2011-02-08 03:00:51.000000000 -0700
|
||||
+++ octave-3.4.0/liboctave/oct-alloc.h 2011-02-08 09:41:23.984081687 -0700
|
||||
@@ -23,6 +23,8 @@ along with Octave; see the file COPYING.
|
||||
#if !defined (octave_oct_alloc_h)
|
||||
#define octave_oct_alloc_h 1
|
||||
|
||||
+#include <cstddef>
|
||||
+
|
||||
class
|
||||
OCTAVE_API
|
||||
octave_allocator
|
||||
diff -up octave-3.4.0/src/pr-output.cc.gcc46 octave-3.4.0/src/pr-output.cc
|
||||
--- octave-3.4.0/src/pr-output.cc.gcc46 2011-02-08 03:00:52.000000000 -0700
|
||||
+++ octave-3.4.0/src/pr-output.cc 2011-02-08 09:55:16.149662744 -0700
|
||||
@@ -3024,7 +3024,7 @@ abs (T x)
|
||||
}
|
||||
|
||||
#define INSTANTIATE_ABS(T) \
|
||||
- template /* static */ inline T abs (T)
|
||||
+ template /* static */ T abs (T)
|
||||
|
||||
INSTANTIATE_ABS(signed char);
|
||||
INSTANTIATE_ABS(short);
|
@ -1,72 +0,0 @@
|
||||
--- octave-3.4.0/configure.libdir 2011-02-08 03:03:31.000000000 -0700
|
||||
+++ octave-3.4.0/configure 2011-03-18 10:35:25.014978076 -0600
|
||||
@@ -6680,7 +6680,7 @@
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: defining octetcdir to be $octetcdir" >&5
|
||||
$as_echo "defining octetcdir to be $octetcdir" >&6; }
|
||||
|
||||
-: ${octlibdir='$(libdir)/octave-$(version)'}
|
||||
+: ${octlibdir='$(libdir)/octave/$(version)'}
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: defining octlibdir to be $octlibdir" >&5
|
||||
$as_echo "defining octlibdir to be $octlibdir" >&6; }
|
||||
|
||||
@@ -6700,19 +6700,19 @@
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: defining localverarchlibdir to be $localverarchlibdir" >&5
|
||||
$as_echo "defining localverarchlibdir to be $localverarchlibdir" >&6; }
|
||||
|
||||
-: ${octfiledir='$(libexecdir)/octave/$(version)/oct/$(canonical_host_type)'}
|
||||
+: ${octfiledir='$(libdir)/octave/$(version)/oct'}
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: defining octfiledir to be $octfiledir" >&5
|
||||
$as_echo "defining octfiledir to be $octfiledir" >&6; }
|
||||
|
||||
-: ${localoctfiledir='$(libexecdir)/octave/site/oct/$(canonical_host_type)'}
|
||||
+: ${localoctfiledir='$(libdir)/octave/site/oct'}
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: defining localoctfiledir to be $localoctfiledir" >&5
|
||||
$as_echo "defining localoctfiledir to be $localoctfiledir" >&6; }
|
||||
|
||||
-: ${localapioctfiledir='$(libexecdir)/octave/site/oct/$(api_version)/$(canonical_host_type)'}
|
||||
+: ${localapioctfiledir='$(libdir)/octave/site/oct/$(api_version)'}
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: defining localapioctfiledir to be $localapioctfiledir" >&5
|
||||
$as_echo "defining localapioctfiledir to be $localapioctfiledir" >&6; }
|
||||
|
||||
-: ${localveroctfiledir='$(libexecdir)/octave/$(version)/site/oct/$(canonical_host_type)'}
|
||||
+: ${localveroctfiledir='$(libdir)/octave/$(version)/site/oct'}
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: defining localveroctfiledir to be $localveroctfiledir" >&5
|
||||
$as_echo "defining localveroctfiledir to be $localveroctfiledir" >&6; }
|
||||
|
||||
--- octave-3.4.0/scripts/pkg/pkg.m.libdir 2011-03-18 09:34:11.258406127 -0600
|
||||
+++ octave-3.4.0/scripts/pkg/pkg.m 2011-03-18 10:56:58.763177238 -0600
|
||||
@@ -248,7 +248,7 @@
|
||||
if (prefix == -1)
|
||||
if (global_install)
|
||||
prefix = fullfile (OCTAVE_HOME (), "share", "octave", "packages");
|
||||
- archprefix = fullfile (octave_config_info ("libexecdir"),
|
||||
+ archprefix = fullfile (octave_config_info ("libdir"),
|
||||
"octave", "packages");
|
||||
else
|
||||
prefix = fullfile ("~", "octave");
|
||||
@@ -293,7 +293,7 @@
|
||||
global_install = true;
|
||||
if (! user_prefix)
|
||||
prefix = fullfile (OCTAVE_HOME (), "share", "octave", "packages");
|
||||
- archprefix = fullfile (octave_config_info ("libexecdir"),
|
||||
+ archprefix = fullfile (octave_config_info ("libdir"),
|
||||
"octave", "packages");
|
||||
endif
|
||||
case available_actions
|
||||
@@ -2211,14 +2211,13 @@
|
||||
endfunction
|
||||
|
||||
function arch = getarch ()
|
||||
- persistent _arch = cstrcat (octave_config_info("canonical_host_type"), ...
|
||||
- "-", octave_config_info("api_version"));
|
||||
+ persistent _arch = octave_config_info("api_version");
|
||||
arch = _arch;
|
||||
endfunction
|
||||
|
||||
function archprefix = getarchprefix (desc, global_install)
|
||||
if ((nargin == 2 && global_install) || (nargin < 2 && issuperuser ()))
|
||||
- archprefix = fullfile (octave_config_info ("libexecdir"), "octave",
|
||||
+ archprefix = fullfile (octave_config_info ("libdir"), "octave",
|
||||
"packages", cstrcat(desc.name, "-", desc.version));
|
||||
else
|
||||
archprefix = desc.dir;
|
62
octave.spec
62
octave.spec
@ -1,19 +1,15 @@
|
||||
# From src/version.h:#define OCTAVE_API_VERSION
|
||||
%global octave_api api-v47+
|
||||
%global octave_api api-v45+
|
||||
|
||||
Name: octave
|
||||
Version: 3.4.0
|
||||
Release: 6%{?dist}
|
||||
Version: 3.4.3
|
||||
Release: 1%{?dist}
|
||||
Summary: A high-level language for numerical computations
|
||||
Epoch: 6
|
||||
Group: Applications/Engineering
|
||||
License: GPLv3+
|
||||
Source0: ftp://ftp.gnu.org/gnu/octave/octave-%{version}.tar.bz2
|
||||
Source1: macros.octave
|
||||
# Add missing cstddef for gcc 4.6
|
||||
Patch0: octave-3.4.0-gcc46.patch
|
||||
# Use libdir instead of libexecdir
|
||||
Patch1: octave-3.4.0-libdir.patch
|
||||
# https://savannah.gnu.org/bugs/index.php?32839
|
||||
# Fix building packages from directories
|
||||
Patch2: octave-3.4.0-pkgbuilddir.patch
|
||||
@ -28,6 +24,7 @@ BuildRequires: readline-devel glibc-devel fftw-devel gperf ghostscript
|
||||
BuildRequires: curl-devel pcre-devel texinfo-tex arpack-devel libX11-devel
|
||||
BuildRequires: suitesparse-devel glpk-devel gnuplot desktop-file-utils
|
||||
BuildRequires: GraphicsMagick-c++-devel fltk-devel ftgl-devel qrupdate-devel
|
||||
BuildRequires: tex(dvips)
|
||||
|
||||
Requires: gnuplot gnuplot-common less info texinfo
|
||||
Requires(post): info
|
||||
@ -73,15 +70,7 @@ This package contains documentation for Octave.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .gcc46
|
||||
%patch1 -p1 -b .libdir
|
||||
%patch2 -p1 -b .pkgbuilddir
|
||||
# Check that octave_api is set correctly
|
||||
if ! grep -q '^#define OCTAVE_API_VERSION "%{octave_api}"' src/version.h
|
||||
then
|
||||
echo "octave_api variable in spec does not match src/version.h"
|
||||
exit 1
|
||||
fi
|
||||
|
||||
# Check permissions
|
||||
find -name *.cc -exec chmod 644 {} \;
|
||||
@ -97,6 +86,16 @@ export F77=gfortran
|
||||
--with-lapack="-L%{_libdir}/atlas -llapack" \
|
||||
--with-amd --with-umfpack --with-colamd --with-ccolamd --with-cholmod \
|
||||
--with-cxsparse
|
||||
|
||||
# Check that octave_api is set correctly (autogenerated file)
|
||||
make -C src version.h
|
||||
if ! grep -q '^#define OCTAVE_API_VERSION "%{octave_api}"' src/version.h
|
||||
then
|
||||
echo "octave_api variable in spec does not match src/version.h"
|
||||
exit 1
|
||||
fi
|
||||
|
||||
# smp builds failing as of 3.4.2
|
||||
make OCTAVE_RELEASE="Fedora %{version}-%{release}"
|
||||
|
||||
%install
|
||||
@ -187,12 +186,8 @@ sed -i -e '/^# Created by Octave/d' %{buildroot}%{_datadir}/%{name}/%{version}/e
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/rpm
|
||||
cp -p %SOURCE1 %{buildroot}%{_sysconfdir}/rpm/
|
||||
|
||||
|
||||
# TODO - Fix this:
|
||||
# src/DLD-FUNCTIONS/md5sum.cc ............................*** stack smashing detected ***: /builddir/build/BUILD/octave-3.3.54/src/.libs/lt-octave terminated
|
||||
#%check
|
||||
#make check
|
||||
|
||||
%check
|
||||
make check
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
@ -211,11 +206,9 @@ fi
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc AUTHORS BUGS ChangeLog* COPYING NEWS* PROJECTS README README.Linux
|
||||
%doc README.kpathsea
|
||||
%doc AUTHORS BUGS ChangeLog COPYING NEWS README
|
||||
# FIXME: Create an -emacs package that has the emacs addon
|
||||
%config(noreplace) %{_sysconfdir}/ld.so.conf.d/octave-*.conf
|
||||
%config(noreplace) %{_sysconfdir}/rpm/macros.octave
|
||||
%{_bindir}/octave*
|
||||
%{_libdir}/octave/
|
||||
%{_libexecdir}/octave/
|
||||
@ -235,6 +228,7 @@ fi
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%config(noreplace) %{_sysconfdir}/rpm/macros.octave
|
||||
%{_bindir}/mkoctfile
|
||||
%{_bindir}/mkoctfile-%{version}
|
||||
%{_includedir}/octave-%{version}/
|
||||
@ -248,6 +242,26 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jun 4 2012 Orion Poplawski <orion[AT]cora.nwra com> - 6:3.4.3-1
|
||||
- Update to 3.4.3
|
||||
- Drop upstreamed patches
|
||||
- Place rpm macros in -devel.
|
||||
|
||||
* Thu Aug 11 2011 Orion Poplawski <orion[AT]cora.nwra com> - 6:3.4.2-2
|
||||
- Drop smp build - seems to be failing
|
||||
- Add patch to fix tar argument handling
|
||||
- Add patch to fix xzip
|
||||
|
||||
* Sat Aug 06 2011 Jussi Lehtola <jussilehtola@fedoraproject.org> - 6:3.4.2-1
|
||||
- Update to 3.4.2.
|
||||
|
||||
* Fri May 27 2011 Orion Poplawski <orion[AT]cora.nwra com> - 6:3.4.0-8
|
||||
- Add patch to fix Fl_File_Chooser.H location
|
||||
- Add BR tex(dvips)
|
||||
|
||||
* Thu May 26 2011 Orion Poplawski <orion[AT]cora.nwra com> - 6:3.4.0-7
|
||||
- Rebuild for fltk 1.3.0
|
||||
|
||||
* Tue May 17 2011 Orion Poplawski <orion[AT]cora.nwra com> - 6:3.4.0-6
|
||||
- Rebuild for hdf5 1.8.7
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user