Updated to 3.0.5
This commit is contained in:
parent
5ba6d72d44
commit
7426903e62
@ -1 +1 @@
|
|||||||
octave-3.0.3.tar.bz2
|
octave-3.0.5.tar.bz2
|
||||||
|
@ -1 +1,2 @@
|
|||||||
octave-3_0_2-2_fc10:HEAD:octave-3.0.2-2.fc10.src.rpm:1224776342
|
octave-3_0_2-2_fc10:HEAD:octave-3.0.2-2.fc10.src.rpm:1224776342
|
||||||
|
octave-3_0_5-1_fc11:HEAD:octave-3.0.5-1.fc11.src.rpm:1239552316
|
||||||
|
@ -1,71 +0,0 @@
|
|||||||
diff -r -u octave-3.0.3.orig/liboctave/oct-md5.cc octave-3.0.3/liboctave/oct-md5.cc
|
|
||||||
--- octave-3.0.3.orig/liboctave/oct-md5.cc 2008-09-24 00:13:47.000000000 -0700
|
|
||||||
+++ octave-3.0.3/liboctave/oct-md5.cc 2009-02-23 19:30:37.000000000 -0700
|
|
||||||
@@ -20,13 +20,15 @@
|
|
||||||
|
|
||||||
*/
|
|
||||||
|
|
||||||
-#include <string>
|
|
||||||
-#include <vector>
|
|
||||||
-
|
|
||||||
#ifdef HAVE_CONFIG_H
|
|
||||||
#include "config.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+#include <cstdio>
|
|
||||||
+
|
|
||||||
+#include <string>
|
|
||||||
+#include <vector>
|
|
||||||
+
|
|
||||||
#include "lo-error.h"
|
|
||||||
#include "oct-md5.h"
|
|
||||||
#include "md5.h"
|
|
||||||
diff -r -u octave-3.0.3.orig/scripts/gethelp.cc octave-3.0.3/scripts/gethelp.cc
|
|
||||||
--- octave-3.0.3.orig/scripts/gethelp.cc 2008-09-24 00:13:48.000000000 -0700
|
|
||||||
+++ octave-3.0.3/scripts/gethelp.cc 2009-02-23 19:30:37.000000000 -0700
|
|
||||||
@@ -24,8 +24,10 @@
|
|
||||||
#define __USE_STD_IOSTREAM
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#include <string>
|
|
||||||
+#include <cstdio>
|
|
||||||
+
|
|
||||||
#include <iostream>
|
|
||||||
+#include <string>
|
|
||||||
|
|
||||||
#ifndef NPOS
|
|
||||||
#define NPOS std::string::npos
|
|
||||||
--- a/liboctave/sparse-util.cc Fri Oct 10 11:35:10 2008 +0200
|
|
||||||
+++ b/liboctave/sparse-util.cc Sun Oct 12 10:30:40 2008 +0200
|
|
||||||
@@ -30,8 +30,15 @@ along with Octave; see the file COPYING.
|
|
||||||
#include "lo-error.h"
|
|
||||||
#include "sparse-util.h"
|
|
||||||
|
|
||||||
+// FIXME this overload is here due to API change in SuiteSparse (3.1 -> 3.2)
|
|
||||||
void
|
|
||||||
SparseCholError (int status, char *file, int line, char *message)
|
|
||||||
+{
|
|
||||||
+ SparseCholError (status, file, line, message);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+void
|
|
||||||
+SparseCholError (int status, const char *file, int line, const char *message)
|
|
||||||
{
|
|
||||||
(*current_liboctave_warning_handler)("warning %i, at line %i in file %s",
|
|
||||||
status, line, file);
|
|
||||||
--- a/liboctave/sparse-util.h Fri Oct 10 11:35:10 2008 +0200
|
|
||||||
+++ b/liboctave/sparse-util.h Sun Oct 12 10:30:40 2008 +0200
|
|
||||||
@@ -24,7 +24,11 @@ along with Octave; see the file COPYING.
|
|
||||||
#if !defined (octave_sparse_util_h)
|
|
||||||
#define octave_sparse_util_h 1
|
|
||||||
|
|
||||||
-extern OCTAVE_API void SparseCholError (int status, char *file, int line, char *message);
|
|
||||||
+// FIXME this overload is here due to API change in SuiteSparse (3.1 -> 3.2)
|
|
||||||
+extern OCTAVE_API void SparseCholError (int status, char *file,
|
|
||||||
+ int line, char *message);
|
|
||||||
+extern OCTAVE_API void SparseCholError (int status, const char *file,
|
|
||||||
+ int line, const char *message);
|
|
||||||
extern OCTAVE_API int SparseCholPrint (const char *fmt, ...);
|
|
||||||
|
|
||||||
#endif
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -u octave-3.0.2.org/configure octave-3.0.2/configure
|
|
||||||
--- octave-3.0.2.org/configure 2008-10-23 20:03:19.000000000 +0530
|
|
||||||
+++ octave-3.0.2/configure 2008-10-23 20:03:44.000000000 +0530
|
|
||||||
@@ -11078,7 +11078,7 @@
|
|
||||||
|
|
||||||
;;
|
|
||||||
# Ignore these flags.
|
|
||||||
- -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | -LANG:=* | -LIST:* | -LNO:*)
|
|
||||||
+ -little| -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | -LANG:=* | -LIST:* | -LNO:*)
|
|
||||||
;;
|
|
||||||
-lkernel32)
|
|
||||||
test x"$CYGWIN" != xyes && ac_cv_f77_libs="$ac_cv_f77_libs $ac_arg"
|
|
15
octave.spec
15
octave.spec
@ -2,16 +2,16 @@
|
|||||||
%define octave_api api-v32
|
%define octave_api api-v32
|
||||||
|
|
||||||
Name: octave
|
Name: octave
|
||||||
Version: 3.0.3
|
Version: 3.0.5
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A high-level language for numerical computations
|
Summary: A high-level language for numerical computations
|
||||||
Epoch: 6
|
Epoch: 6
|
||||||
|
|
||||||
Group: Applications/Engineering
|
Group: Applications/Engineering
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Source: ftp://ftp.octave.org/pub/octave/octave-%{version}.tar.bz2
|
Source: ftp://ftp.octave.org/pub/octave/octave-%{version}.tar.bz2
|
||||||
Patch1: %{name}-sh-arch.patch
|
#Patch1: %{name}-sh-arch.patch
|
||||||
Patch2: %{name}-gcc44.patch
|
#Patch2: %{name}-gcc44.patch
|
||||||
URL: http://www.octave.org
|
URL: http://www.octave.org
|
||||||
Requires: gnuplot less info texinfo
|
Requires: gnuplot less info texinfo
|
||||||
Requires(post): /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
@ -64,9 +64,9 @@ then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
# patch for sh arch
|
# patch for sh arch
|
||||||
%patch1 -p1 -b .sh-arch
|
#%patch1 -p1 -b .sh-arch
|
||||||
# patch for gcc 4.4
|
# patch for gcc 4.4
|
||||||
%patch2 -p1 -b .gcc44
|
#%patch2 -p1 -b .gcc44
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%define enable64 no
|
%define enable64 no
|
||||||
@ -147,6 +147,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Apr 12 2009 Rakesh Pandit <rakesh@fedoraproject.org> - 6:3.0.5-1
|
||||||
|
- Updated to latest upstream (3.0.5)
|
||||||
|
|
||||||
* Mon Feb 23 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 6:3.0.3-2
|
* Mon Feb 23 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 6:3.0.3-2
|
||||||
- Add patches from upstream for compiling against GCC 4.4
|
- Add patches from upstream for compiling against GCC 4.4
|
||||||
http://hg.savannah.gnu.org/hgweb/octave/rev/93cf10950334
|
http://hg.savannah.gnu.org/hgweb/octave/rev/93cf10950334
|
||||||
|
Loading…
Reference in New Issue
Block a user