Add patch to fix build with texinfo 6.0

This commit is contained in:
Orion Poplawski 2015-07-14 13:26:11 -06:00
parent 21dae87daf
commit 626ba12bb6
2 changed files with 58 additions and 1 deletions

View File

@ -0,0 +1,48 @@
diff -up octave-4.0.0/doc/liboctave/Makefile.in.texinfo6 octave-4.0.0/doc/liboctave/Makefile.in
--- octave-4.0.0/doc/liboctave/Makefile.in.texinfo6 2015-05-26 10:21:42.000000000 -0600
+++ octave-4.0.0/doc/liboctave/Makefile.in 2015-07-14 10:40:50.131788830 -0600
@@ -1854,7 +1854,6 @@ localstartupfiledir = ${localfcnfiledir}
# The separator used for elements of the LD_PRELOAD variable (might be
# a space, so protect with $(null))
null =
-TEXINFO_TEX = ../texinfo.tex
info_TEXINFOS = liboctave.texi
liboctave_TEXINFOS = \
array.texi \
diff -up octave-4.0.0/libinterp/corefcn/utils.cc.texinfo6 octave-4.0.0/libinterp/corefcn/utils.cc
--- octave-4.0.0/libinterp/corefcn/utils.cc.texinfo6 2015-05-23 08:21:53.000000000 -0600
+++ octave-4.0.0/libinterp/corefcn/utils.cc 2015-07-14 09:46:17.300468145 -0600
@@ -22,7 +22,7 @@ along with Octave; see the file COPYING.
*/
#ifdef HAVE_CONFIG_H
-#include <config.h>
+#include "config.h"
#endif
#include <cerrno>
@@ -1379,7 +1379,7 @@ indexing using @var{ind} will not perfor
\n\
Implementation Note: Strings are first converted to double values before the\n\
checks for valid indices are made. Unless a string contains the NULL\n\
-character @nospell{\"\\0\"}, it will always be a valid index.\n\
+character @nospell{\"@xbackslashchar{}0\"}, it will always be a valid index.\n\
@end deftypefn")
{
octave_value retval;
diff -up octave-4.0.0/scripts/io/beep.m.texinfo6 octave-4.0.0/scripts/io/beep.m
--- octave-4.0.0/scripts/io/beep.m.texinfo6 2015-05-23 08:21:53.000000000 -0600
+++ octave-4.0.0/scripts/io/beep.m 2015-07-14 09:46:16.894469886 -0600
@@ -20,9 +20,9 @@
## @deftypefn {Function File} {} beep ()
## Produce a beep from the speaker (or visual bell).
##
-## This function sends the alarm character @qcode{"\a"} to the terminal.
-## Depending on the user's configuration this may produce an audible beep,
-## a visual bell, or nothing at all.
+## This function sends the alarm character @qcode{"@xbackslashchar{}a"} to
+## the terminal. Depending on the user's configuration this may produce an
+## audible beep, a visual bell, or nothing at all.
## @seealso{puts, fputs, printf, fprintf}
## @end deftypefn

View File

@ -18,7 +18,7 @@
Name: octave
Epoch: 6
Version: 4.0.0
Release: 2%{?dist}
Release: 3%{?dist}
Summary: A high-level language for numerical computations
Group: Applications/Engineering
License: GPLv3+
@ -35,6 +35,9 @@ Source2: xorg.conf
# Fix to allow pkg build to use a directory
# https://savannah.gnu.org/bugs/?func=detailitem&item_id=32839
Patch0: octave-pkgbuilddir.patch
# Upstream patch to fix texinfo6 doc builds
# http://hg.savannah.gnu.org/hgweb/octave/rev/2ec049e50ed8
Patch1: octave-texinfo6-2ec049e50ed8.patch
Provides: octave(api) = %{octave_api}
Provides: bundled(gnulib)
@ -73,6 +76,7 @@ BuildRequires: suitesparse-devel
BuildRequires: tex(dvips)
BuildRequires: texinfo
BuildRequires: texinfo-tex
BuildRequires: texlive-collection-fontsrecommended
BuildRequires: zlib-devel
# For check
BuildRequires: mesa-dri-drivers
@ -126,6 +130,8 @@ This package contains documentation for Octave.
%prep
%setup -q -n %{name}-%{version}%{?rctag}
%patch0 -p1 -b .pkgbuilddir
%patch1 -p1 -b .texinfo6
rm doc/texinfo.tex
find -name \*.h -o -name \*.cc | xargs sed -i -e 's/<config.h>/"config.h"/' -e 's/<base-list.h>/"base-list.h"/'
# Check permissions
@ -357,6 +363,9 @@ fi
%{_pkgdocdir}/refcard*.pdf
%changelog
* Tue Jul 14 2015 Orion Poplawski <orion@cora.nwra.com> - 6:4.0.0-3
- Add patch to fix build with texinfo 6.0
* Mon Jul 13 2015 Dan Horák <dan[at]danny.cz> - 6:4.0.0-2
- build without the dummy Xorg driver on s390(x)