Update to 4.2.1
This commit is contained in:
parent
295daff22e
commit
435717d94e
1
.gitignore
vendored
1
.gitignore
vendored
@ -26,3 +26,4 @@ octave-3.2.4.tar.bz2
|
|||||||
/octave-4.0.3.tar.xz
|
/octave-4.0.3.tar.xz
|
||||||
/octave-4.2.0-rc1.tar.xz
|
/octave-4.2.0-rc1.tar.xz
|
||||||
/octave-4.2.0.tar.lz
|
/octave-4.2.0.tar.lz
|
||||||
|
/octave-4.2.1.tar.lz
|
||||||
|
@ -1,17 +1,9 @@
|
|||||||
--- octave-4.2.0/etc/icons/octave.appdata.xml.in.appdata 2016-11-13 16:16:10.000000000 +0100
|
diff -up octave-4.2.1/etc/icons/octave.appdata.xml.in.appdata octave-4.2.1/etc/icons/octave.appdata.xml.in
|
||||||
+++ octave-4.2.0/etc/icons/octave.appdata.xml.in 2016-12-29 14:54:32.389932341 +0100
|
--- octave-4.2.1/etc/icons/octave.appdata.xml.in.appdata 2017-02-24 20:46:50.581334701 -0700
|
||||||
@@ -17,7 +17,7 @@
|
+++ octave-4.2.1/etc/icons/octave.appdata.xml.in 2017-02-24 20:47:29.866515768 -0700
|
||||||
-->
|
@@ -58,5 +58,4 @@
|
||||||
<application>
|
|
||||||
<id type="desktop">%OCTAVE_DESKTOP_FILE%</id>
|
|
||||||
- <licence>GPLv3+</licence>
|
|
||||||
+ <licence>GPL-3.0+</licence>
|
|
||||||
<name>GNU Octave</name>
|
|
||||||
<summary>Interactive programming environment for numerical computations</summary>
|
|
||||||
<description>
|
|
||||||
@@ -52,5 +52,4 @@
|
|
||||||
</screenshots>
|
|
||||||
<url type="homepage">http://www.octave.org</url>
|
<url type="homepage">http://www.octave.org</url>
|
||||||
<updatecontact>maintainers@octave.org</updatecontact>
|
<update_contact>maintainers@octave.org</update_contact>
|
||||||
- <project_group>GNU</project_group>
|
- <project_group>GNU</project_group>
|
||||||
</application>
|
</component>
|
||||||
|
@ -1,38 +0,0 @@
|
|||||||
--- libinterp/dldfcn/gzip.cc.orig 2016-11-13 08:16:10.000000000 -0700
|
|
||||||
+++ libinterp/dldfcn/gzip.cc 2016-12-03 07:30:58.000000000 -0700
|
|
||||||
@@ -348,14 +348,18 @@
|
|
||||||
unsigned char buf_in[buf_len];
|
|
||||||
unsigned char buf_out[buf_len];
|
|
||||||
|
|
||||||
- while ((strm->avail_in = std::fread (buf_in, sizeof (buf_in[0]),
|
|
||||||
- buf_len, source.fp)) != 0)
|
|
||||||
+ int flush;
|
|
||||||
+
|
|
||||||
+ do
|
|
||||||
{
|
|
||||||
+ strm->avail_in = std::fread (buf_in, sizeof (buf_in[0]),
|
|
||||||
+ buf_len, source.fp);
|
|
||||||
+
|
|
||||||
if (std::ferror (source.fp))
|
|
||||||
throw std::runtime_error ("failed to read source file");
|
|
||||||
|
|
||||||
strm->next_in = buf_in;
|
|
||||||
- const int flush = std::feof (source.fp) ? Z_FINISH : Z_NO_FLUSH;
|
|
||||||
+ flush = std::feof (source.fp) ? Z_FINISH : Z_NO_FLUSH;
|
|
||||||
|
|
||||||
// If deflate returns Z_OK and with zero avail_out, it must be
|
|
||||||
// called again after making room in the output buffer because
|
|
||||||
@@ -376,8 +380,11 @@
|
|
||||||
while (strm->avail_out == 0);
|
|
||||||
|
|
||||||
if (strm->avail_in != 0)
|
|
||||||
- throw std::runtime_error ("failed to wrote file");
|
|
||||||
- }
|
|
||||||
+ throw std::runtime_error ("failed to write file");
|
|
||||||
+ } while (flush != Z_FINISH);
|
|
||||||
+
|
|
||||||
+ if (status != Z_STREAM_END)
|
|
||||||
+ throw std::runtime_error ("failed to write file");
|
|
||||||
}
|
|
||||||
|
|
||||||
void
|
|
@ -1,29 +0,0 @@
|
|||||||
diff -up octave-4.2.0/m4/acinclude.m4.implicit octave-4.2.0/m4/acinclude.m4
|
|
||||||
--- octave-4.2.0/m4/acinclude.m4.implicit 2016-11-13 08:16:10.000000000 -0700
|
|
||||||
+++ octave-4.2.0/m4/acinclude.m4 2016-12-06 14:19:48.866621459 -0700
|
|
||||||
@@ -1646,12 +1646,13 @@ AC_DEFUN([OCTAVE_CHECK_SIZEOF_FORTRAN_IN
|
|
||||||
AC_RUN_IFELSE([AC_LANG_PROGRAM([[
|
|
||||||
#include <assert.h>
|
|
||||||
#include <stdint.h>
|
|
||||||
- ]], [[
|
|
||||||
#if defined (OCTAVE_ENABLE_64)
|
|
||||||
typedef int64_t octave_idx_type;
|
|
||||||
#else
|
|
||||||
typedef int octave_idx_type;
|
|
||||||
#endif
|
|
||||||
+ void F77_FUNC(foo,FOO) (octave_idx_type*, octave_idx_type**, octave_idx_type**);
|
|
||||||
+ ]], [[
|
|
||||||
octave_idx_type n = 2;
|
|
||||||
octave_idx_type in[2];
|
|
||||||
octave_idx_type out[2];
|
|
||||||
diff -up octave-4.2.0/m4/link.m4.implicit octave-4.2.0/m4/link.m4
|
|
||||||
--- octave-4.2.0/m4/link.m4.implicit 2016-11-13 08:21:54.000000000 -0700
|
|
||||||
+++ octave-4.2.0/m4/link.m4 2016-12-06 13:52:47.132003993 -0700
|
|
||||||
@@ -22,6 +22,7 @@ AC_DEFUN([gl_FUNC_LINK],
|
|
||||||
AC_RUN_IFELSE(
|
|
||||||
[AC_LANG_PROGRAM(
|
|
||||||
[[#include <unistd.h>
|
|
||||||
+ #include <stdio.h>
|
|
||||||
]],
|
|
||||||
[[int result = 0;
|
|
||||||
if (!link ("conftest.a", "conftest.b/"))
|
|
14
octave.spec
14
octave.spec
@ -13,8 +13,8 @@
|
|||||||
|
|
||||||
Name: octave
|
Name: octave
|
||||||
Epoch: 6
|
Epoch: 6
|
||||||
Version: 4.2.0
|
Version: 4.2.1
|
||||||
Release: 16%{?rcver:.rc%{rcver}}%{?dist}
|
Release: 1%{?rcver:.rc%{rcver}}%{?dist}
|
||||||
Summary: A high-level language for numerical computations
|
Summary: A high-level language for numerical computations
|
||||||
Group: Applications/Engineering
|
Group: Applications/Engineering
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
@ -28,14 +28,9 @@ Source0: ftp://alpha.gnu.org/gnu/octave/octave-%{version}%{rctag}.tar.lz
|
|||||||
# RPM macros for helping to build Octave packages
|
# RPM macros for helping to build Octave packages
|
||||||
Source1: macros.octave
|
Source1: macros.octave
|
||||||
Source2: xorg.conf
|
Source2: xorg.conf
|
||||||
# Fix compilation with -Werror=implicit-declarations
|
|
||||||
Patch1: octave-implicit.patch
|
|
||||||
# Remove project_group from appdata.xml file
|
# Remove project_group from appdata.xml file
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1293561
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1293561
|
||||||
Patch2: octave-appdata.patch
|
Patch2: octave-appdata.patch
|
||||||
# Fix gzip
|
|
||||||
# https://savannah.gnu.org/bugs/?49760
|
|
||||||
Patch3: octave-gzip.patch
|
|
||||||
# Add needed #include <math.h> to bring in gnulib
|
# Add needed #include <math.h> to bring in gnulib
|
||||||
Patch4: octave-gnulib.patch
|
Patch4: octave-gnulib.patch
|
||||||
|
|
||||||
@ -185,9 +180,7 @@ This package contains documentation for Octave.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}%{?rctag}
|
%setup -q -n %{name}-%{version}%{?rctag}
|
||||||
%patch1 -p1 -b .implicit
|
|
||||||
%patch2 -p1 -b .appdata
|
%patch2 -p1 -b .appdata
|
||||||
%patch3 -p0 -b .gzip
|
|
||||||
%patch4 -p1 -b .gnulib
|
%patch4 -p1 -b .gnulib
|
||||||
# __osmesa_print__ test is triggering a crash in libgcc, disable it
|
# __osmesa_print__ test is triggering a crash in libgcc, disable it
|
||||||
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=78409
|
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=78409
|
||||||
@ -431,6 +424,9 @@ fi
|
|||||||
%{_pkgdocdir}/refcard*.pdf
|
%{_pkgdocdir}/refcard*.pdf
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 24 2017 Orion Poplawski <orion@cora.nwra.com> - 6:4.2.1-1
|
||||||
|
- Update to 4.2.1
|
||||||
|
|
||||||
* Mon Feb 20 2017 Rex Dieter <rdieter@fedoraproject.org> - 6:4.2.0-16
|
* Mon Feb 20 2017 Rex Dieter <rdieter@fedoraproject.org> - 6:4.2.0-16
|
||||||
- rebuild (qscintilla)
|
- rebuild (qscintilla)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user