New release, one new patch, remove two old patches.
This commit is contained in:
parent
b6cf024ae1
commit
29a158d0dc
@ -1 +1 @@
|
||||
octave-2.9.6.tar.bz2
|
||||
octave-2.9.7.tar.bz2
|
||||
|
@ -1,39 +0,0 @@
|
||||
src/ChangeLog:
|
||||
|
||||
2006-07-02 John W. Eaton <jwe at octave.org>
|
||||
|
||||
* ov-str-mat.cc (CHAR_MATRIX_CONV): Omit "warn-" from label.
|
||||
* parse.y (maybe_warn_variable_switch_label): Likewise.
|
||||
|
||||
|
||||
Index: src/ov-str-mat.cc
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/src/ov-str-mat.cc,v
|
||||
retrieving revision 1.62
|
||||
diff -u -u -r1.62 ov-str-mat.cc
|
||||
--- src/ov-str-mat.cc 23 May 2006 06:05:14 -0000 1.62
|
||||
+++ src/ov-str-mat.cc 2 Jul 2006 17:44:21 -0000
|
||||
@@ -176,7 +176,7 @@
|
||||
gripe_invalid_conversion ("string", TNAME); \
|
||||
else \
|
||||
{ \
|
||||
- warning_with_id ("Octave:warn-str-to-num", \
|
||||
+ warning_with_id ("Octave:str-to-num", \
|
||||
"implicit conversion from %s to %s", \
|
||||
"string", TNAME); \
|
||||
\
|
||||
Index: src/parse.y
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/src/parse.y,v
|
||||
retrieving revision 1.264
|
||||
diff -u -u -r1.264 parse.y
|
||||
--- src/parse.y 1 Jul 2006 15:24:44 -0000 1.264
|
||||
+++ src/parse.y 2 Jul 2006 17:44:21 -0000
|
||||
@@ -1533,7 +1533,7 @@
|
||||
maybe_warn_variable_switch_label (tree_expression *expr)
|
||||
{
|
||||
if (! expr->is_constant ())
|
||||
- warning_with_id ("Octave:warn-variable-switch-label",
|
||||
+ warning_with_id ("Octave:variable-switch-label",
|
||||
"variable switch label");
|
||||
}
|
@ -1,95 +0,0 @@
|
||||
liboctave/ChangeLog:
|
||||
|
||||
2006-06-30 John W. Eaton <jwe@octave.org>
|
||||
|
||||
* dir-ops.cc (dir_entry::open): Perform tilde expansion here.
|
||||
* file-stat.cc (stat::update_internal): Ditto.
|
||||
|
||||
src/ChangeLog:
|
||||
|
||||
2006-06-30 John W. Eaton <jwe@octave.org>
|
||||
|
||||
* load-path.cc (genpath): Don't perform tilde expansion on name.
|
||||
(load_path::do_add): Don't warn about moving "." to front of list.
|
||||
|
||||
|
||||
Index: liboctave/dir-ops.cc
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/liboctave/dir-ops.cc,v
|
||||
retrieving revision 1.8
|
||||
diff -u -u -r1.8 dir-ops.cc
|
||||
--- liboctave/dir-ops.cc 26 Apr 2005 19:24:28 -0000 1.8
|
||||
+++ liboctave/dir-ops.cc 30 Jun 2006 16:45:59 -0000
|
||||
@@ -32,6 +32,7 @@
|
||||
#include "sysdir.h"
|
||||
|
||||
#include "dir-ops.h"
|
||||
+#include "file-ops.h"
|
||||
#include "lo-error.h"
|
||||
#include "lo-sysdep.h"
|
||||
#include "str-vec.h"
|
||||
@@ -47,8 +48,10 @@
|
||||
if (! name.empty ())
|
||||
{
|
||||
close ();
|
||||
+
|
||||
+ std::string fullname = file_ops::tilde_expand (name);
|
||||
|
||||
- dir = static_cast<void *> (opendir (name.c_str ()));
|
||||
+ dir = static_cast<void *> (opendir (fullname.c_str ()));
|
||||
|
||||
if (dir)
|
||||
fail = false;
|
||||
Index: liboctave/file-stat.cc
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/liboctave/file-stat.cc,v
|
||||
retrieving revision 1.8
|
||||
diff -u -u -r1.8 file-stat.cc
|
||||
--- liboctave/file-stat.cc 24 Apr 2006 19:13:07 -0000 1.8
|
||||
+++ liboctave/file-stat.cc 30 Jun 2006 16:45:59 -0000
|
||||
@@ -35,6 +35,7 @@
|
||||
#include <unistd.h>
|
||||
#endif
|
||||
|
||||
+#include "file-ops.h"
|
||||
#include "file-stat.h"
|
||||
#include "statdefs.h"
|
||||
|
||||
@@ -196,8 +197,10 @@
|
||||
{
|
||||
initialized = false;
|
||||
fail = false;
|
||||
+
|
||||
+ std::string full_file_name = file_ops::tilde_expand (file_name);
|
||||
|
||||
- const char *cname = file_name.c_str ();
|
||||
+ const char *cname = full_file_name.c_str ();
|
||||
|
||||
struct stat buf;
|
||||
|
||||
Index: src/load-path.cc
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/src/load-path.cc,v
|
||||
retrieving revision 1.4
|
||||
diff -u -u -r1.4 load-path.cc
|
||||
--- src/load-path.cc 28 Jun 2006 22:11:51 -0000 1.4
|
||||
+++ src/load-path.cc 30 Jun 2006 16:46:03 -0000
|
||||
@@ -1140,9 +1135,7 @@
|
||||
{
|
||||
std::string retval;
|
||||
|
||||
- std::string full_dirname = file_ops::tilde_expand (dirname);
|
||||
-
|
||||
- dir_entry dir (full_dirname);
|
||||
+ dir_entry dir (dirname);
|
||||
|
||||
if (dir)
|
||||
{
|
||||
@@ -1172,7 +1165,7 @@
|
||||
|
||||
if (! skip_p)
|
||||
{
|
||||
- std::string nm = full_dirname + file_ops::dir_sep_str + elt;
|
||||
+ std::string nm = dirname + file_ops::dir_sep_str + elt;
|
||||
|
||||
file_stat fs (nm);
|
16
octave-2.9.7-misc.patch
Normal file
16
octave-2.9.7-misc.patch
Normal file
@ -0,0 +1,16 @@
|
||||
Index: scripts/miscellaneous/mex.m
|
||||
===================================================================
|
||||
RCS file: /cvs/octave/scripts/miscellaneous/mex.m,v
|
||||
retrieving revision 1.1
|
||||
diff -u -r1.1 mex.m
|
||||
--- scripts/miscellaneous/mex.m 26 Jul 2006 17:19:10 -0000 1.1
|
||||
+++ scripts/miscellaneous/mex.m 28 Jul 2006 21:06:42 -0000
|
||||
@@ -20,7 +20,7 @@
|
||||
## -*- texinfo -*-
|
||||
## @deftypefn {Function File} {} mex [options] file ...
|
||||
## Compile source code written in C, C++, or Fortran, to a MEX file.
|
||||
-## This is equivalent to @code {mkoctfile --mex [options] file}.
|
||||
+## This is equivalent to @code{mkoctfile --mex [options] file}.
|
||||
## @seealso{mkoctfile}
|
||||
## @end deftypefn
|
||||
|
11
octave.spec
11
octave.spec
@ -1,14 +1,13 @@
|
||||
Name: octave
|
||||
Version: 2.9.6
|
||||
Release: 2%{?dist}
|
||||
Version: 2.9.7
|
||||
Release: 1%{?dist}
|
||||
Summary: A high-level language for numerical computations
|
||||
Epoch: 6
|
||||
|
||||
Group: Applications/Engineering
|
||||
License: GPL
|
||||
Source: ftp://ftp.octave.org/pub/octave/bleeding-edge/octave-%{version}.tar.bz2
|
||||
Patch0: octave-2.9.6-parse.patch
|
||||
Patch1: octave-2.9.6-path.patch
|
||||
Patch0: octave-2.9.7-misc.patch
|
||||
URL: http://www.octave.org
|
||||
Requires: gnuplot less info texinfo
|
||||
Requires(post): /sbin/install-info
|
||||
@ -52,7 +51,6 @@ applications which use GNU Octave.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p0
|
||||
%patch1 -p0
|
||||
|
||||
|
||||
%build
|
||||
@ -127,6 +125,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jul 28 2006 Quentin Spencer <qspencer@users.sourceforge.net> 2.9.7-1
|
||||
- New release. Remove old patches and add one new one.
|
||||
|
||||
* Tue Jul 11 2006 Quentin Spencer <qspencer@users.sourceforge.net> 2.9.6-2
|
||||
- Patch for some erroneous warnings and a file path bug.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user