Add patch to fix Fl_File_Chooser.H location
Add BR dvips
This commit is contained in:
parent
3d0821b1a7
commit
2180c3afad
24
octave-3.4.0-fltk.patch
Normal file
24
octave-3.4.0-fltk.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -up octave-3.4.0/src/DLD-FUNCTIONS/__fltk_uigetfile__.cc.fltk octave-3.4.0/src/DLD-FUNCTIONS/__fltk_uigetfile__.cc
|
||||||
|
--- octave-3.4.0/src/DLD-FUNCTIONS/__fltk_uigetfile__.cc.fltk 2011-02-08 03:00:52.000000000 -0700
|
||||||
|
+++ octave-3.4.0/src/DLD-FUNCTIONS/__fltk_uigetfile__.cc 2011-05-26 14:09:51.277484258 -0600
|
||||||
|
@@ -27,7 +27,7 @@ along with Octave; see the file COPYING.
|
||||||
|
#if defined (HAVE_FLTK)
|
||||||
|
|
||||||
|
#include <FL/Fl.H>
|
||||||
|
-#include <Fl/Fl_File_Chooser.H>
|
||||||
|
+#include <FL/Fl_File_Chooser.H>
|
||||||
|
|
||||||
|
// FLTK headers may include X11/X.h which defines Complex, and that
|
||||||
|
// conflicts with Octave's Complex typedef. We don't need the X11
|
||||||
|
diff -up octave-3.4.0/src/DLD-FUNCTIONS/__init_fltk__.cc.fltk octave-3.4.0/src/DLD-FUNCTIONS/__init_fltk__.cc
|
||||||
|
--- octave-3.4.0/src/DLD-FUNCTIONS/__init_fltk__.cc.fltk 2011-05-26 14:10:40.447667595 -0600
|
||||||
|
+++ octave-3.4.0/src/DLD-FUNCTIONS/__init_fltk__.cc 2011-05-26 14:10:14.456627808 -0600
|
||||||
|
@@ -44,7 +44,7 @@ To initialize:
|
||||||
|
#include <FL/Fl_Box.H>
|
||||||
|
#include <FL/Fl_Button.H>
|
||||||
|
#include <FL/Fl_Choice.H>
|
||||||
|
-#include <Fl/Fl_File_Chooser.H>
|
||||||
|
+#include <FL/Fl_File_Chooser.H>
|
||||||
|
#include <FL/Fl_Gl_Window.H>
|
||||||
|
#include <FL/Fl_Menu_Bar.H>
|
||||||
|
#include <FL/Fl_Menu_Button.H>
|
11
octave.spec
11
octave.spec
@ -3,7 +3,7 @@
|
|||||||
|
|
||||||
Name: octave
|
Name: octave
|
||||||
Version: 3.4.0
|
Version: 3.4.0
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
Summary: A high-level language for numerical computations
|
Summary: A high-level language for numerical computations
|
||||||
Epoch: 6
|
Epoch: 6
|
||||||
Group: Applications/Engineering
|
Group: Applications/Engineering
|
||||||
@ -17,6 +17,9 @@ Patch1: octave-3.4.0-libdir.patch
|
|||||||
# https://savannah.gnu.org/bugs/index.php?32839
|
# https://savannah.gnu.org/bugs/index.php?32839
|
||||||
# Fix building packages from directories
|
# Fix building packages from directories
|
||||||
Patch2: octave-3.4.0-pkgbuilddir.patch
|
Patch2: octave-3.4.0-pkgbuilddir.patch
|
||||||
|
# Fix Fl_File_Chooser.H file location
|
||||||
|
# Fixed upstream https://savannah.gnu.org/bugs/?func=detailitem&item_id=32972
|
||||||
|
Patch3: octave-3.4.0-fltk.patch
|
||||||
URL: http://www.octave.org
|
URL: http://www.octave.org
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -28,6 +31,7 @@ BuildRequires: readline-devel glibc-devel fftw-devel gperf ghostscript
|
|||||||
BuildRequires: curl-devel pcre-devel texinfo-tex arpack-devel libX11-devel
|
BuildRequires: curl-devel pcre-devel texinfo-tex arpack-devel libX11-devel
|
||||||
BuildRequires: suitesparse-devel glpk-devel gnuplot desktop-file-utils
|
BuildRequires: suitesparse-devel glpk-devel gnuplot desktop-file-utils
|
||||||
BuildRequires: GraphicsMagick-c++-devel fltk-devel ftgl-devel qrupdate-devel
|
BuildRequires: GraphicsMagick-c++-devel fltk-devel ftgl-devel qrupdate-devel
|
||||||
|
BuildRequires: dvips
|
||||||
|
|
||||||
Requires: gnuplot gnuplot-common less info texinfo
|
Requires: gnuplot gnuplot-common less info texinfo
|
||||||
Requires(post): info
|
Requires(post): info
|
||||||
@ -76,6 +80,7 @@ This package contains documentation for Octave.
|
|||||||
%patch0 -p1 -b .gcc46
|
%patch0 -p1 -b .gcc46
|
||||||
%patch1 -p1 -b .libdir
|
%patch1 -p1 -b .libdir
|
||||||
%patch2 -p1 -b .pkgbuilddir
|
%patch2 -p1 -b .pkgbuilddir
|
||||||
|
%patch3 -p1 -b .fltk
|
||||||
# Check that octave_api is set correctly
|
# Check that octave_api is set correctly
|
||||||
if ! grep -q '^#define OCTAVE_API_VERSION "%{octave_api}"' src/version.h
|
if ! grep -q '^#define OCTAVE_API_VERSION "%{octave_api}"' src/version.h
|
||||||
then
|
then
|
||||||
@ -248,6 +253,10 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 27 2011 Orion Poplawski <orion[AT]cora.nwra com> - 6:3.4.0-8
|
||||||
|
- Add patch to fix Fl_File_Chooser.H location
|
||||||
|
- Add BR dvips
|
||||||
|
|
||||||
* Thu May 26 2011 Orion Poplawski <orion[AT]cora.nwra com> - 6:3.4.0-7
|
* Thu May 26 2011 Orion Poplawski <orion[AT]cora.nwra com> - 6:3.4.0-7
|
||||||
- Rebuild for fltk 1.3.0
|
- Rebuild for fltk 1.3.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user