Drop smp build - seems to be failing
Add patch to fix tar argument handling Add patch to fix xzip
This commit is contained in:
parent
2eb0eabb3a
commit
1605c403eb
12
octave-tar.patch
Normal file
12
octave-tar.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -r d1db86336a49 scripts/miscellaneous/tar.m
|
||||
--- a/scripts/miscellaneous/tar.m Thu Aug 11 02:41:36 2011 -0500
|
||||
+++ b/scripts/miscellaneous/tar.m Thu Aug 11 10:56:18 2011 -0600
|
||||
@@ -42,7 +42,7 @@
|
||||
files = cellstr (files);
|
||||
endif
|
||||
|
||||
- if (ischar (tarfile) && iscellstr (files) && ischar (root))
|
||||
+ if !(ischar (tarfile) && iscellstr (files) && ischar (root))
|
||||
error ("tar: all arguments must be character strings");
|
||||
endif
|
||||
|
25
octave-xzip.patch
Normal file
25
octave-xzip.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff -r d1db86336a49 scripts/miscellaneous/private/__xzip__.m
|
||||
--- a/scripts/miscellaneous/private/__xzip__.m Thu Aug 11 02:41:36 2011 -0500
|
||||
+++ b/scripts/miscellaneous/private/__xzip__.m Thu Aug 11 14:28:45 2011 -0600
|
||||
@@ -80,14 +80,16 @@
|
||||
commandname, status);
|
||||
endif
|
||||
|
||||
- if (nargout > 0)
|
||||
- if (nargin == 5)
|
||||
+ if (nargin == 5)
|
||||
+ if (nargout > 0)
|
||||
entries = cellfun(
|
||||
@(x) fullfile (outdir, sprintf ("%s.%s", x, extension)),
|
||||
f, "uniformoutput", false);
|
||||
- else
|
||||
- movefile (cellfun(@(x) sprintf ("%s.%s", x, extension), f,
|
||||
- "uniformoutput", false), cwd);
|
||||
+ endif
|
||||
+ else
|
||||
+ movefile (cellfun(@(x) sprintf ("%s.%s", x, extension), f,
|
||||
+ "uniformoutput", false), cwd);
|
||||
+ if (nargout > 0)
|
||||
## FIXME this does not work when you try to compress directories
|
||||
entries = cellfun(@(x) sprintf ("%s.%s", x, extension),
|
||||
files, "uniformoutput", false);
|
19
octave.spec
19
octave.spec
@ -3,7 +3,7 @@
|
||||
|
||||
Name: octave
|
||||
Version: 3.4.2
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: A high-level language for numerical computations
|
||||
Epoch: 6
|
||||
Group: Applications/Engineering
|
||||
@ -12,9 +12,15 @@ Source0: ftp://ftp.gnu.org/gnu/octave/octave-%{version}.tar.bz2
|
||||
Source1: macros.octave
|
||||
# Don't include <curl/types.h> which isn't used and is missing on newer versions of libcurl
|
||||
Patch0: octave-3.4.2-curl.patch
|
||||
# https://savannah.gnu.org/bugs/index.php?33988
|
||||
# Fix tar argument handling
|
||||
Patch1: octave-tar.patch
|
||||
# https://savannah.gnu.org/bugs/index.php?32839
|
||||
# Fix building packages from directories
|
||||
Patch2: octave-3.4.0-pkgbuilddir.patch
|
||||
# https://savannah.gnu.org/bugs/index.php?33993
|
||||
# Fix xzip
|
||||
Patch3: octave-xzip.patch
|
||||
URL: http://www.octave.org
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -73,7 +79,9 @@ This package contains documentation for Octave.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .curl
|
||||
%patch1 -p1 -b .tar
|
||||
%patch2 -p1 -b .pkgbuilddir
|
||||
%patch3 -p1 -b .xzip
|
||||
|
||||
# Check permissions
|
||||
find -name *.cc -exec chmod 644 {} \;
|
||||
@ -98,7 +106,8 @@ then
|
||||
exit 1
|
||||
fi
|
||||
|
||||
make OCTAVE_RELEASE="Fedora %{version}-%{release}" %{?_smp_mflags}
|
||||
# smp builds failing as of 3.4.2
|
||||
make OCTAVE_RELEASE="Fedora %{version}-%{release}"
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
@ -244,6 +253,11 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Aug 11 2011 Orion Poplawski <orion[AT]cora.nwra com> - 6:3.4.2-2
|
||||
- Drop smp build - seems to be failing
|
||||
- Add patch to fix tar argument handling
|
||||
- Add patch to fix xzip
|
||||
|
||||
* Sat Aug 06 2011 Jussi Lehtola <jussilehtola@fedoraproject.org> - 6:3.4.2-1
|
||||
- Update to 3.4.2.
|
||||
|
||||
@ -263,7 +277,6 @@ fi
|
||||
- Fix multilib installs
|
||||
- Re-enable prelinking, seems to work
|
||||
- Add patch to enable building packages from directories
|
||||
>>>>>>> c9d48722b5642ad74c3504a69163771eb4b11d9d
|
||||
|
||||
* Wed Feb 23 2011 Orion Poplawski <orion[AT]cora.nwra com> - 6:3.4.0-4
|
||||
- Update rpm macros per FPC comments
|
||||
|
Loading…
Reference in New Issue
Block a user