Update to 0.11.7-1
- Update to upstream 0.11.7 release
This commit is contained in:
parent
2f721a69c0
commit
b5af65c1bb
11
.gitignore
vendored
11
.gitignore
vendored
@ -50,3 +50,14 @@
|
||||
/ocserv-0.11.6.tar.xz
|
||||
/ocserv-0.11.6.tar.xz.sig
|
||||
/gpgkey-1F42418905D8206AA754CCDC29EE58B996865171.gpg
|
||||
/ocserv.init
|
||||
/gpgkey-56EE7FA9E8173B19FE86268D763712747F343FA7.gpg
|
||||
/ocserv-script
|
||||
/ocserv-genkey
|
||||
/PACKAGE-LICENSING
|
||||
/ocserv-pamd.conf
|
||||
/ocserv.service
|
||||
/ocserv.conf
|
||||
/gpgkey-1F42418905D8206AA754CCDC29EE58B996865171.gpg
|
||||
/ocserv-0.11.7.tar.xz.sig
|
||||
/ocserv-0.11.7.tar.xz
|
||||
|
@ -1,29 +0,0 @@
|
||||
diff --git a/src/occtl-print.c b/src/occtl-print.c
|
||||
index 1441cd6..8ff297e 100644
|
||||
--- a/src/occtl-print.c
|
||||
+++ b/src/occtl-print.c
|
||||
@@ -47,9 +47,9 @@ int print_list_entries(FILE* out, cmd_params_st *params, const char* name, char
|
||||
tmp = val[i];
|
||||
if (tmp != NULL) {
|
||||
if (i==0)
|
||||
- fprintf(out, "%s", tmp);
|
||||
+ fprintf(out, "\"%s\"", tmp);
|
||||
else
|
||||
- fprintf(out, ", %s", tmp);
|
||||
+ fprintf(out, ", \"%s\"", tmp);
|
||||
}
|
||||
}
|
||||
fprintf(out, "]%s\n", have_more?",":"");
|
||||
diff --git a/src/occtl-unix.c b/src/occtl-unix.c
|
||||
index 6df5a1e..d6b28f3 100644
|
||||
--- a/src/occtl-unix.c
|
||||
+++ b/src/occtl-unix.c
|
||||
@@ -254,7 +254,7 @@ int handle_status_cmd(struct unix_ctx *ctx, const char *arg, cmd_params_st *para
|
||||
print_single_value_int(stdout, params, "TLS DB entries", rep->stored_tls_sessions, 1);
|
||||
print_separator(stdout, params);
|
||||
print_single_value_int(stdout, params, "Server PID", rep->pid, 1);
|
||||
- print_single_value_int(stdout, params, "Sec-mod PID", rep->sec_mod_pid, 1);
|
||||
+ print_single_value_int(stdout, params, "Sec-mod PID", rep->sec_mod_pid, 0);
|
||||
print_end_block(stdout, params, 0);
|
||||
|
||||
status_rep__free_unpacked(rep, &pa);
|
@ -1,13 +0,0 @@
|
||||
diff --git a/src/worker-vpn.c b/src/worker-vpn.c
|
||||
index 7765e84..cf2a6b6 100644
|
||||
--- a/src/worker-vpn.c
|
||||
+++ b/src/worker-vpn.c
|
||||
@@ -46,7 +46,7 @@
|
||||
#include <c-ctype.h>
|
||||
#include <worker-bandwidth.h>
|
||||
|
||||
-#ifdef __linux__
|
||||
+#if 0
|
||||
/* for IPV6_PATHMTU */
|
||||
# include <linux/in6.h>
|
||||
#endif
|
77
ocserv.spec
77
ocserv.spec
@ -1,28 +1,36 @@
|
||||
# This spec file has been automatically updated
|
||||
Version: 0.11.7
|
||||
Release: 1%{?dist}
|
||||
%global _hardened_build 1
|
||||
|
||||
Name: ocserv
|
||||
Version: 0.11.6
|
||||
Release: 4%{?dist}
|
||||
Summary: OpenConnect SSL VPN server
|
||||
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
# To simplify licenses LGPLv2+ files have been promoted to GPLv3+.
|
||||
# To simplify licenses LGPLv2+ files have been promoted to GPLv2+.
|
||||
License: GPLv2+ and BSD and MIT and CC0
|
||||
URL: http://www.infradead.org/ocserv/
|
||||
Source0: ftp://ftp.infradead.org/pub/ocserv/%{name}-%{version}.tar.xz
|
||||
Source1: ocserv.conf
|
||||
Source2: ocserv.service
|
||||
Source3: ocserv-pamd.conf
|
||||
Source4: PACKAGE-LICENSING
|
||||
Source6: ftp://ftp.infradead.org/pub/ocserv/%{name}-%{version}.tar.xz.sig
|
||||
Source7: ocserv-genkey
|
||||
Source8: ocserv-script
|
||||
Source1: ftp://ftp.infradead.org/pub/ocserv/%{name}-%{version}.tar.xz.sig
|
||||
Source2: gpgkey-1F42418905D8206AA754CCDC29EE58B996865171.gpg
|
||||
Source3: ocserv.conf
|
||||
Source4: ocserv.service
|
||||
Source5: ocserv-pamd.conf
|
||||
Source6: PACKAGE-LICENSING
|
||||
Source8: ocserv-genkey
|
||||
Source9: ocserv-script
|
||||
Source10: gpgkey-56EE7FA9E8173B19FE86268D763712747F343FA7.gpg
|
||||
Source11: ocserv.init
|
||||
|
||||
# Taken from upstream:
|
||||
# http://git.infradead.org/ocserv.git/commitdiff/7d70006a2dbddf783213f1856374bacc74217e09
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
%if 0%{?rhel} && 0%{?rhel} <= 6
|
||||
BuildRequires: gnutls30-devel
|
||||
%else
|
||||
BuildRequires: gnutls-devel
|
||||
%endif
|
||||
BuildRequires: pam-devel
|
||||
BuildRequires: iproute
|
||||
BuildRequires: systemd
|
||||
@ -32,24 +40,33 @@ BuildRequires: protobuf-c-devel
|
||||
BuildRequires: libnl3-devel
|
||||
BuildRequires: krb5-devel
|
||||
BuildRequires: libtasn1-devel
|
||||
%if 0%{?fedora}
|
||||
BuildRequires: liboath-devel
|
||||
BuildRequires: uid_wrapper
|
||||
BuildRequires: socket_wrapper
|
||||
%endif
|
||||
BuildRequires: readline-devel
|
||||
BuildRequires: autogen
|
||||
BuildRequires: gperf
|
||||
BuildRequires: libev-devel
|
||||
|
||||
%if 0%{?rhel} && 0%{?rhel} >= 7
|
||||
%ifarch x86_64 %{ix86}
|
||||
BuildRequires: libseccomp-devel
|
||||
%endif
|
||||
%else
|
||||
%ifarch x86_64 %{ix86} %{arm} aarch64
|
||||
BuildRequires: libseccomp-devel
|
||||
%endif
|
||||
%endif
|
||||
BuildRequires: pcllib-devel
|
||||
BuildRequires: libtalloc-devel
|
||||
BuildRequires: libev-devel
|
||||
BuildRequires: http-parser-devel
|
||||
BuildRequires: tcp_wrappers-devel
|
||||
BuildRequires: automake, autoconf
|
||||
BuildRequires: radcli-devel
|
||||
BuildRequires: lz4-devel
|
||||
BuildRequires: vim-minimal
|
||||
|
||||
# we don't build with dbus support
|
||||
#BuildRequires: dbus-devel
|
||||
|
||||
Requires: gnutls-utils
|
||||
Requires: iproute
|
||||
@ -74,10 +91,11 @@ uses the standard IETF security protocols such as TLS 1.2, and Datagram TLS
|
||||
to provide the secure VPN service.
|
||||
|
||||
%prep
|
||||
gpgv2 --keyring %{SOURCE2} %{SOURCE1} %{SOURCE0} || gpgv2 --keyring %{SOURCE10} %{SOURCE1} %{SOURCE0}
|
||||
%setup -q
|
||||
|
||||
rm -f src/http-parser/http_parser.c src/http-parser/http_parser.h
|
||||
rm -rf src/protobuf/protobuf-c
|
||||
rm -rf src/protobuf/protobuf-c/
|
||||
rm -rf src/ccan/talloc
|
||||
rm -f libopts/*.c libopts/*.h libopts/*/*.c libopts/*/*.h
|
||||
rm -f src/pcl/*.c src/pcl/*.h
|
||||
@ -118,19 +136,25 @@ make check %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
cp -a %{SOURCE4} PACKAGE-LICENSING
|
||||
cp -a %{SOURCE6} PACKAGE-LICENSING
|
||||
mkdir -p %{buildroot}/%{_sysconfdir}/pam.d/
|
||||
mkdir -p %{buildroot}/%{_sysconfdir}/ocserv/
|
||||
install -p -m 644 %{SOURCE3} %{buildroot}/%{_sysconfdir}/pam.d/ocserv
|
||||
install -p -m 644 %{SOURCE1} %{buildroot}/%{_sysconfdir}/ocserv/
|
||||
mkdir -p %{buildroot}/%{_unitdir}
|
||||
install -p -m 644 %{SOURCE2} %{buildroot}/%{_unitdir}
|
||||
install -p -m 644 %{SOURCE5} %{buildroot}/%{_sysconfdir}/pam.d/ocserv
|
||||
install -p -m 644 %{SOURCE3} %{buildroot}/%{_sysconfdir}/ocserv/
|
||||
mkdir -p %{buildroot}%{_localstatedir}/lib/ocserv/
|
||||
install -p -m 644 doc/profile.xml %{buildroot}%{_localstatedir}/lib/ocserv/
|
||||
mkdir -p %{buildroot}/%{_sbindir}
|
||||
install -p -m 755 %{SOURCE7} %{buildroot}/%{_sbindir}
|
||||
install -p -m 755 %{SOURCE8} %{buildroot}/%{_sbindir}
|
||||
mkdir -p %{buildroot}/%{_bindir}
|
||||
install -p -m 755 %{SOURCE8} %{buildroot}/%{_bindir}
|
||||
install -p -m 755 %{SOURCE9} %{buildroot}/%{_bindir}
|
||||
|
||||
%if 0%{?rhel} && 0%{?rhel} <= 6
|
||||
install -D -m 0755 %{SOURCE8} %{buildroot}/%{_initrddir}/%{name}
|
||||
%else
|
||||
mkdir -p %{buildroot}/%{_unitdir}
|
||||
install -p -m 644 %{SOURCE4} %{buildroot}/%{_unitdir}
|
||||
%endif
|
||||
|
||||
%make_install
|
||||
|
||||
%clean
|
||||
@ -156,10 +180,17 @@ rm -rf %{buildroot}
|
||||
%{_bindir}/ocserv-script
|
||||
%{_sbindir}/ocserv
|
||||
%{_sbindir}/ocserv-genkey
|
||||
%{_unitdir}/ocserv.service
|
||||
%{_localstatedir}/lib/ocserv/profile.xml
|
||||
%if 0%{?rhel} && 0%{?rhel} <= 6
|
||||
%{_initrddir}/%{name}
|
||||
%else
|
||||
%{_unitdir}/ocserv.service
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Feb 13 2017 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.7-1
|
||||
- Update to upstream 0.11.7 release
|
||||
|
||||
* Mon Dec 5 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 0.11.6-4
|
||||
- Reverted the libnl3 removal; the actual issue is compatibility with
|
||||
Centos7.2 which is not possible due to EPEL build root.
|
||||
|
15
sources
15
sources
@ -1,4 +1,11 @@
|
||||
0e4f82d267d27f2f9d3fcba58ac6cf5a ocserv-0.11.6.tar.xz
|
||||
12a026b472daa54373f38538773673d8 ocserv-0.11.6.tar.xz.sig
|
||||
310168e221d6e810022b270e32bf9662 gpgkey-1F42418905D8206AA754CCDC29EE58B996865171.gpg
|
||||
c144d7522377a701cb9e63a20098e122 gpgkey-56EE7FA9E8173B19FE86268D763712747F343FA7.gpg
|
||||
SHA512 (ocserv.init) = 7c3256dd0f7d5882c4e126c95209084e2476f7d8d142af137f46c5987364982eb88044bfa5d587ebc397ebd379edb40f22e5c97c0276764be982a27715a9c601
|
||||
SHA512 (gpgkey-56EE7FA9E8173B19FE86268D763712747F343FA7.gpg) = c664fd9999cbf9912eeea88ee3a2c356df3f70813a664bb7a7f592be258c12bdeb9e99e4aa9a368c1f123ee449eb08e288d1dc3dcf81e849a958ece6eab82d67
|
||||
SHA512 (ocserv-script) = 6d77ebe95d23469d96b45b1ac8de7a062cb1360febd0f9664b42debf0494891a522e3da8feec53d22b84e39ad349a1824b7ecd6b6b8f0790edf75aed1087e2d0
|
||||
SHA512 (ocserv-genkey) = c02a25a5504e2bd514c6e6944651960a3cc9bf2ef0a4509744f99d61421feace1f8e440c4d336652efd7349465d1a707cd3a370ff6102ef5096d709b34099a86
|
||||
SHA512 (PACKAGE-LICENSING) = eea2a2a4765c90d874c79bb72d754c8b26b58d5e5b3c3cee10c24754fbba6849fd91f7b28e380b5db9789a456f95fc94b3bd8fe8c160a98c8042f404479ecb68
|
||||
SHA512 (ocserv-pamd.conf) = 3a75f19d89ddd164f3faa9c3579c7f675fc58413a194f43ec28eee7ebced6fee3f4ca305fe9b0ddf76ae39cd669e8d3d63b58afbbf19b84e4ca646ae7f42d61a
|
||||
SHA512 (ocserv.service) = 264f3389d88aec1f7d2e4683a4dfc0aa67af2325154de822eecf5fb43f8c221aab0d9f0c6a8eedb893e6d69ed4d94c9397b01e5d0d12e88330017a3bfa5f3644
|
||||
SHA512 (ocserv.conf) = 0a48d394dba183528c1e92df2a8b844a4d7d419244b1c08883f79c8b48843986e786ea4d48478ed4e8d57fd56626bf962dbcf6c76b5839ba5ab5fac8b089c44c
|
||||
SHA512 (gpgkey-1F42418905D8206AA754CCDC29EE58B996865171.gpg) = 7eccc70fb763cf8a6525228230c1f537224809cf553efb3ad6bc88ad96f01122c30a5cd9d8328fa3a97b242d59e00bc9966589a24b1e65dd4a27eb71393f097c
|
||||
SHA512 (ocserv-0.11.7.tar.xz.sig) = fd4af775842cff6817adaf4a641b180d3be3b55e3b64a026977fd6f328ddc5f7070f4c91cdce7e83eb8c3b078a5c1dc7780cfe40c5322abef61ca7fc408fbb2c
|
||||
SHA512 (ocserv-0.11.7.tar.xz) = a563725bd8753186ece80c91a237a2940071047bb32d1990e2ee122a32ad0468b78a7f35d422dcc9b968a8c56358992842d00958dbf9d743632a03623dd2f5cf
|
||||
|
Loading…
Reference in New Issue
Block a user