New upstream release and start to integrate with cman and pacemaker

This commit is contained in:
Fabio M. Di Nitto 2009-09-02 11:13:54 +00:00
parent bf09090a91
commit a852cc7efe
4 changed files with 76 additions and 25 deletions

View File

@ -1 +1 @@
ocfs2-tools-1.3.9.tar.gz
ocfs2-tools-1.4.2.tar.gz

23
minor_build_fixes.diff Normal file
View File

@ -0,0 +1,23 @@
diff -Naurd ocfs2-tools-1.4.2.orig/ocfs2_controld/Makefile ocfs2-tools-1.4.2/ocfs2_controld/Makefile
--- ocfs2-tools-1.4.2.orig/ocfs2_controld/Makefile 2009-04-14 00:10:40.000000000 +0200
+++ ocfs2-tools-1.4.2/ocfs2_controld/Makefile 2009-08-31 16:15:04.000000000 +0200
@@ -17,7 +17,7 @@
PCMK_INCLUDES = -I/usr/include/pacemaker -I/usr/include/heartbeat/ $(GLIB_CFLAGS)
endif
-INCLUDES = -I$(TOPDIR)/include -I. $(PCMK_INCLUDES)
+INCLUDES = -I/usr/include/libxml2 -I$(TOPDIR)/include -I. $(PCMK_INCLUDES)
LIBO2CB_LIBS = -L$(TOPDIR)/libo2cb -lo2cb
LIBO2CB_DEPS = $(TOPDIR)/libo2cb/libo2cb.a
LIBOCFS2_LIBS = -L$(TOPDIR)/libocfs2 -locfs2
diff -Naurd ocfs2-tools-1.4.2.orig/ocfs2_controld/pacemaker.c ocfs2-tools-1.4.2/ocfs2_controld/pacemaker.c
--- ocfs2-tools-1.4.2.orig/ocfs2_controld/pacemaker.c 2009-05-06 03:36:57.000000000 +0200
+++ ocfs2-tools-1.4.2/ocfs2_controld/pacemaker.c 2009-08-31 16:18:15.000000000 +0200
@@ -22,6 +22,7 @@
#include <bzlib.h>
+#include <corosync/corodefs.h>
#include <pacemaker/crm_config.h>
/* heartbeat support is irrelevant here */
#undef SUPPORT_HEARTBEAT

View File

@ -1,12 +1,12 @@
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%define with_console %{?_without_console: 0} %{?!_without_console: 1}
%define alphatag 20080221git
## define alphatag 20080221git
Summary: Tools for managing the Ocfs2 cluster file system
Name: ocfs2-tools
Version: 1.3.9
Release: 11%{?alphatag:.%{alphatag}}%{?dist}
Version: 1.4.2
Release: 1%{?alphatag:.%{alphatag}}%{?dist}
License: GPLv2
Group: System Environment/Base
# The source for this package was pulled from upstream's git repo and manually
@ -18,16 +18,22 @@ Group: System Environment/Base
# ./autogen.sh
# cd ..
# tar -czvf ocfs2-tools-1.3.9.tar.gz ocfs2-tools-1.3.9
Source: %{name}-%{version}.tar.gz
Source0: %{name}-%{version}.tar.gz
Patch0: minor_build_fixes.diff
URL: http://oss.oracle.com/projects/ocfs2-tools/
Requires(post): chkconfig
Requires(preun): chkconfig
Requires(preun): initscripts
Requires: bash, coreutils, net-tools, modutils
Requires: e2fsprogs, chkconfig, glib2 >= 2.2.3
Requires: redhat-lsb
BuildRequires: e2fsprogs-devel, glib2-devel >= 2.2.3
BuildRequires: libblkid-devel, bzip2-devel
BuildRequires: pygtk2 >= 1.99.16, python-devel >= 2.5
BuildRequires: ncurses-devel, readline-devel, desktop-file-utils
BuildRequires: ncurses-devel, readline-devel
BuildRequires: openaislib-devel, clusterlib-devel
BuildRequires: cluster-glue-libs-devel, pacemaker-libs-devel
BuildRequires: libxml2-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
@ -49,7 +55,6 @@ Group: System Environment/Kernel
Requires: e2fsprogs, glib2 >= 2.2.3, vte >= 0.11.10, pygtk2 >= 1.99.16
Requires: python >= 2.5, %{name} = %{version}-%{release}
%description -n ocfs2console
Ocfs2console can make it easier to manage an Ocfs2 cluster by
providing a gui front-end to common tasks, including initial cluster
@ -68,14 +73,30 @@ Provides: %{name}-static = %{version}-%{release}
ocfs2-tools-devel contains the libraries and header files needed to
develop Ocfs2 filesystem-specific programs.
%package cman
Summary: Tools for managing the Ocfs2 cluster file system (cman component)
Group: System Environment/Base
Requires: cman >= 3.0.0-1
%description cman
ocfs2-tools-cman contains the daemon required to use Ocfs2 with
cman cluster manager
%package pcmk
Summary: Tools for managing the Ocfs2 cluster file system (pacemaker component)
Group: System Environment/Base
Requires: pacemaker >= 1.0.5-1
%description pcmk
ocfs2-tools-pcmk contains the daemon required to use Ocfs2 with
pacemaker cluster manager
%prep
%setup -q
%patch0 -p1
%build
%configure \
%{configure} \
%if ! %{with_console}
--enable-ocfs2console=no \
%endif
@ -84,7 +105,6 @@ develop Ocfs2 filesystem-specific programs.
# parallel build currently fails, so no %{_smp_mflags}
CFLAGS="$(echo '%{optflags}')" make
%install
rm -rf "$RPM_BUILD_ROOT"
@ -93,6 +113,9 @@ cp -f vendor/common/o2cb.init $RPM_BUILD_ROOT/%{_initrddir}/o2cb
cp -f vendor/common/ocfs2.init $RPM_BUILD_ROOT/%{_initrddir}/ocfs2
mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
cp -f vendor/common/o2cb.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/o2cb
mkdir -p $RPM_BUILD_ROOT/etc/udev/rules.d
cp -f vendor/common/51-ocfs2.rules \
$RPM_BUILD_ROOT/etc/udev/rules.d/51-ocfs2.rules
make DESTDIR="$RPM_BUILD_ROOT" install
@ -102,19 +125,11 @@ chmod 644 $RPM_BUILD_ROOT/%{_libdir}/*.a
%{__python} -c "import compileall; compileall.compile_dir('$RPM_BUILD_ROOT/%{python_sitearch}/ocfs2interface', ddir='%{python_sitearch}/ocfs2interface')"
# rpm autostripper needs to see these as executable
chmod 755 $RPM_BUILD_ROOT/%{python_sitearch}/ocfs2interface/*.so
mkdir -p $RPM_BUILD_ROOT%{_datadir}/ocfs2console/
cp -f vendor/common/ocfs2console.png $RPM_BUILD_ROOT%{_datadir}/ocfs2console/
desktop-file-install --vendor="fedora" \
--dir=$RPM_BUILD_ROOT%{_datadir}/applications/ \
vendor/common/ocfs2console.desktop
%endif
%clean
rm -rf "$RPM_BUILD_ROOT"
%post
/sbin/chkconfig --add o2cb
/sbin/chkconfig --add ocfs2
@ -138,11 +153,12 @@ fi
/sbin/debugfs.ocfs2
/sbin/o2cb_ctl
/sbin/mount.ocfs2
/sbin/ocfs2cdsl
/sbin/ocfs2_hb_ctl
/sbin/o2image
%{_initrddir}/o2cb
%{_initrddir}/ocfs2
%config(noreplace) /etc/sysconfig/o2cb
%{_mandir}/man7/o2cb.7.gz
%{_mandir}/man8/debugfs.ocfs2.8.gz
%{_mandir}/man8/fsck.ocfs2.8.gz
%{_mandir}/man8/fsck.ocfs2.checks.8.gz
@ -152,8 +168,7 @@ fi
%{_mandir}/man8/mounted.ocfs2.8.gz
%{_mandir}/man8/o2cb_ctl.8.gz
%{_mandir}/man8/ocfs2_hb_ctl.8.gz
%{_mandir}/man8/ocfs2cdsl.8.gz
%{_mandir}/man8/o2image.8.gz
%if %{with_console}
%files -n ocfs2console
@ -162,9 +177,6 @@ fi
%{python_sitearch}/ocfs2interface/*
%{_sbindir}/ocfs2console
%{_mandir}/man8/ocfs2console.8.gz
%{_datadir}/applications/fedora-ocfs2console.desktop
%dir %{_datadir}/ocfs2console/
%{_datadir}/ocfs2console/*
%endif
%files devel
@ -180,9 +192,25 @@ fi
%{_includedir}/o2dlm/*
%{_includedir}/ocfs2/*
%files cman
%defattr(-,root,root,-)
/sbin/ocfs2_controld.cman
%files pcmk
%defattr(-,root,root,-)
/sbin/ocfs2_controld.pcmk
%changelog
* Mon Aug 31 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.4.2-1
- New upstream release
- Undefine alpha tag
- Add patch to fix 2 minor build glitches
- Add Requires: redhat-lsb for init scripts
- Update BuildRequires to enable all features
- Add ocfs2-tools-{cman,pcmk} packages with respective control daemons
- Install udev rule
- Update file lists
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.9-11.20080221git
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

View File

@ -1 +1 @@
150346c30891caa4273849f23fdc1a08 ocfs2-tools-1.3.9.tar.gz
1dfc4a4ba72ba96250b508c8e27af981 ocfs2-tools-1.4.2.tar.gz