Fix python2 path in shebang

This commit is contained in:
Robin Lee 2018-09-23 14:34:11 +08:00
parent 789d37e216
commit 95f740625a
2 changed files with 15 additions and 2 deletions

View File

@ -1,12 +1,23 @@
From a32e9de8fd3d6965f76d04a94a39ea4ba8be7a3c Mon Sep 17 00:00:00 2001
From 5ad9fc097fd96c4872b08cf343f7c42f4ea18334 Mon Sep 17 00:00:00 2001
From: Robin Lee <cheeselee@fedoraproject.org>
Date: Sat, 22 Sep 2018 23:03:59 +0800
Subject: [PATCH] Explicit call Python 2 command
---
ocfs2console/ocfs2console | 2 +-
ocfs2console/ocfs2interface/Makefile | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/ocfs2console/ocfs2console b/ocfs2console/ocfs2console
index 5130d52f..6c713780 100755
--- a/ocfs2console/ocfs2console
+++ b/ocfs2console/ocfs2console
@@ -1,4 +1,4 @@
-#!/usr/bin/python -W ignore::DeprecationWarning
+#!/usr/bin/python2 -W ignore::DeprecationWarning
from ocfs2interface.about import process_args
nodeconf = process_args()
diff --git a/ocfs2console/ocfs2interface/Makefile b/ocfs2console/ocfs2interface/Makefile
index 7c7c9b1c..4964bce2 100644
--- a/ocfs2console/ocfs2interface/Makefile

View File

@ -100,6 +100,8 @@ develop OCFS2 filesystem-specific programs.
%patch2 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
# remove -Wno-format to prevent conflict with rpm optflags
sed -i -e 's/-Wno-format//g' {o2info,o2image,o2monitor}/Makefile