ocaml/0007-Fix-failure-to-install...

46 lines
1.4 KiB
Diff

From fa36269c5752bfb8f4b65dd0f9a2dd8f9c9eeb8f Mon Sep 17 00:00:00 2001
From: David Allsopp <david.allsopp@metastack.com>
Date: Tue, 6 Aug 2019 09:23:06 +0100
Subject: [PATCH 07/13] Fix failure to install tools links
In --disable-installing-bytecode-programs mode, the .opt version of the
tools is installed, but the symlink for the tool itself is not created.
(cherry picked from commit 705739fa54260b7a0e6cbba0b5a99e52c79f9c09)
---
Changes | 5 +++++
tools/Makefile | 1 +
2 files changed, 6 insertions(+)
diff --git a/Changes b/Changes
index 257a75e3d..3fdc31a5f 100644
--- a/Changes
+++ b/Changes
@@ -1,6 +1,11 @@
OCaml 4.09 maintenance branch:
------------------------------
+- #8855, #8858: Links for tools not created when installing with
+ --disable-installing-byecode-programs (e.g. ocamldep.opt installed, but
+ ocamldep link not created)
+ (David Allsopp, report by Thomas Leonard)
+
- #8953, #8954: Fix error submessages in the toplevel: do not display
dummy locations
(Armaël Guéneau, review by Gabriel Scherer)
diff --git a/tools/Makefile b/tools/Makefile
index afefc4d83..84ddd79fb 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -242,6 +242,7 @@ else
do \
if test -f "$$i".opt; then \
$(INSTALL_PROG) "$$i.opt" "$(INSTALL_BINDIR)/$$i.opt$(EXE)"; \
+ (cd "$(INSTALL_BINDIR)/" && $(LN) "$$i.opt$(EXE)" "$$i$(EXE)"); \
fi; \
done
endif
--
2.23.0