68 lines
1.7 KiB
Diff
68 lines
1.7 KiB
Diff
From 41d5e2db7a4667560d6aedda11a3c6a80c8f1b83 Mon Sep 17 00:00:00 2001
|
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
Date: Fri, 26 Apr 2019 16:16:29 +0100
|
|
Subject: [PATCH 8/9] configure: Remove incorrect assumption about
|
|
cross-compiling.
|
|
|
|
See https://github.com/ocaml/ocaml/issues/8647#issuecomment-487094390
|
|
|
|
The error seen without this patch is:
|
|
|
|
sh: line 1: x86_64-pc-linux-gnu-as: command not found
|
|
---
|
|
configure.ac | 31 ++++++++++++++++---------------
|
|
1 file changed, 16 insertions(+), 15 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 5ccfe8fb01..c763310acb 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -578,10 +578,11 @@ AS_IF(
|
|
|
|
# Are we building a cross-compiler
|
|
|
|
-AS_IF(
|
|
- [test x"$host" = x"$target"],
|
|
- [cross_compiler=false],
|
|
- [cross_compiler=true])
|
|
+#AS_IF(
|
|
+# [test x"$host" = x"$target"],
|
|
+# [cross_compiler=false],
|
|
+# [cross_compiler=true])
|
|
+cross_compiler=false
|
|
|
|
# Checks for programs
|
|
|
|
@@ -1212,17 +1213,17 @@ AS_CASE([$arch],
|
|
|
|
# Assembler
|
|
|
|
-AS_IF([test -n "$target_alias"],
|
|
- [toolpref="${target_alias}-"
|
|
- as_target="$target"
|
|
- as_cpu="$target_cpu"],
|
|
- [AS_IF([test -n "$host_alias"],
|
|
- [toolpref="${host_alias}-"
|
|
- as_target="$host"
|
|
- as_cpu="$host_cpu"],
|
|
- [toolpref=""
|
|
- as_target="$build"
|
|
- as_cpu="$build_cpu"])])
|
|
+dnl AS_IF([test -n "$target_alias"],
|
|
+dnl [toolpref="${target_alias}-"
|
|
+dnl as_target="$target"
|
|
+dnl as_cpu="$target_cpu"],
|
|
+dnl [AS_IF([test -n "$host_alias"],
|
|
+dnl [toolpref="${host_alias}-"
|
|
+dnl as_target="$host"
|
|
+dnl as_cpu="$host_cpu"],
|
|
+dnl [toolpref=""
|
|
+dnl as_target="$build"
|
|
+dnl as_cpu="$build_cpu"])])
|
|
|
|
# Finding the assembler
|
|
# The OCaml build system distinguishes two different assemblers:
|
|
--
|
|
2.36.1
|
|
|