367 lines
10 KiB
Diff
367 lines
10 KiB
Diff
From 07839dfc746ccee318601b9668aa094d4465bc6e Mon Sep 17 00:00:00 2001
|
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
Date: Thu, 7 Jun 2012 16:00:28 +0100
|
|
Subject: [PATCH 01/12] Add .gitignore file to ignore generated files.
|
|
|
|
---
|
|
.gitignore | 347 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
|
|
1 file changed, 347 insertions(+)
|
|
create mode 100644 .gitignore
|
|
|
|
diff --git a/.gitignore b/.gitignore
|
|
new file mode 100644
|
|
index 0000000..7191b83
|
|
--- /dev/null
|
|
+++ b/.gitignore
|
|
@@ -0,0 +1,347 @@
|
|
+*~
|
|
+*.a
|
|
+*.bak
|
|
+*.cma
|
|
+*.cmi
|
|
+*.cmo
|
|
+*.cmx
|
|
+*.o
|
|
+*.so
|
|
+/_boot_log1
|
|
+/_boot_log2
|
|
+/_build/
|
|
+/_log
|
|
+/asmcomp/arch.ml
|
|
+/asmcomp/emit.ml
|
|
+/asmcomp/proc.ml
|
|
+/asmcomp/reload.ml
|
|
+/asmcomp/scheduling.ml
|
|
+/asmcomp/selection.ml
|
|
+/asmrun/alloc.c
|
|
+/asmrun/array.c
|
|
+/asmrun/callback.c
|
|
+/asmrun/compact.c
|
|
+/asmrun/compare.c
|
|
+/asmrun/custom.c
|
|
+/asmrun/debugger.c
|
|
+/asmrun/dynlink.c
|
|
+/asmrun/extern.c
|
|
+/asmrun/finalise.c
|
|
+/asmrun/floats.c
|
|
+/asmrun/freelist.c
|
|
+/asmrun/gc_ctrl.c
|
|
+/asmrun/globroots.c
|
|
+/asmrun/hash.c
|
|
+/asmrun/intern.c
|
|
+/asmrun/ints.c
|
|
+/asmrun/io.c
|
|
+/asmrun/lexing.c
|
|
+/asmrun/main.c
|
|
+/asmrun/major_gc.c
|
|
+/asmrun/md5.c
|
|
+/asmrun/memory.c
|
|
+/asmrun/meta.c
|
|
+/asmrun/minor_gc.c
|
|
+/asmrun/misc.c
|
|
+/asmrun/obj.c
|
|
+/asmrun/parsing.c
|
|
+/asmrun/printexc.c
|
|
+/asmrun/signals.c
|
|
+/asmrun/str.c
|
|
+/asmrun/sys.c
|
|
+/asmrun/terminfo.c
|
|
+/asmrun/unix.c
|
|
+/asmrun/weak.c
|
|
+/boot/camlheader
|
|
+/boot/myocamlbuild
|
|
+/boot/ocamlrun
|
|
+/boot/ocamlyacc
|
|
+/build/ocamlbuild_mixed_mode
|
|
+/bytecomp/opcodes.ml
|
|
+/bytecomp/runtimedef.ml
|
|
+/byterun/jumptbl.h
|
|
+/byterun/ld.conf
|
|
+/byterun/ocamlrun
|
|
+/byterun/primitives
|
|
+/byterun/prims.c
|
|
+/byterun/version.h
|
|
+/compilerlibs/ocamlbytecomp.cmxa
|
|
+/compilerlibs/ocamlcommon.cmxa
|
|
+/compilerlibs/ocamloptcomp.cmxa
|
|
+/configure
|
|
+/config/Makefile
|
|
+/config/config.sh
|
|
+/config/m.h
|
|
+/config/s.h
|
|
+/debugger/dynlink.ml
|
|
+/debugger/dynlink.mli
|
|
+/debugger/lexer.ml
|
|
+/debugger/ocamldebug
|
|
+/debugger/parser.ml
|
|
+/debugger/parser.mli
|
|
+/expunge
|
|
+/lex/lexer.ml
|
|
+/lex/ocamllex
|
|
+/lex/ocamllex.opt
|
|
+/lex/parser.ml
|
|
+/lex/parser.mli
|
|
+/lex/parser.output
|
|
+/myocamlbuild_config.ml
|
|
+/ocamlbuild-mixed-boot
|
|
+/ocaml
|
|
+/ocamlc
|
|
+/ocamlc.opt
|
|
+/ocamlcomp.sh
|
|
+/ocamlcompopt.sh
|
|
+/ocamldoc/generators/odoc_literate.cmxs
|
|
+/ocamldoc/generators/odoc_todo.cmxs
|
|
+/ocamldoc/ocamldoc
|
|
+/ocamldoc/ocamldoc.opt
|
|
+/ocamldoc/odoc_info.cmxa
|
|
+/ocamldoc/odoc_lexer.ml
|
|
+/ocamldoc/odoc_ocamlhtml.ml
|
|
+/ocamldoc/odoc_parser.ml
|
|
+/ocamldoc/odoc_parser.mli
|
|
+/ocamldoc/odoc_parser.output
|
|
+/ocamldoc/odoc_see_lexer.ml
|
|
+/ocamldoc/odoc_text_lexer.ml
|
|
+/ocamldoc/odoc_text_parser.ml
|
|
+/ocamldoc/odoc_text_parser.mli
|
|
+/ocamldoc/odoc_text_parser.output
|
|
+/ocamldoc/stdlib_man/
|
|
+/ocamlnat
|
|
+/ocamlopt
|
|
+/ocamlopt.opt
|
|
+/otherlibs/bigarray/bigarray.cmxa
|
|
+/otherlibs/bigarray/bigarray.cmxs
|
|
+/otherlibs/dynlink/dynlink.cmxa
|
|
+/otherlibs/dbm/
|
|
+/otherlibs/dynlink/extract_crc
|
|
+/otherlibs/graph/graphics.cmxa
|
|
+/otherlibs/graph/graphics.cmxs
|
|
+/otherlibs/labltk/frx/frxlib.cmxa
|
|
+/otherlibs/labltk/jpf/jpflib.cmxa
|
|
+/otherlibs/labltk/lib/labltk.cmxa
|
|
+/otherlibs/labltk/browser/dummy.mli
|
|
+/otherlibs/labltk/browser/help.ml
|
|
+/otherlibs/labltk/browser/ocamlbrowser
|
|
+/otherlibs/labltk/camltk/.depend
|
|
+/otherlibs/labltk/camltk/_tkfgen.ml
|
|
+/otherlibs/labltk/camltk/_tkgen.ml
|
|
+/otherlibs/labltk/camltk/_tkgen.mli
|
|
+/otherlibs/labltk/camltk/_tkigen.ml
|
|
+/otherlibs/labltk/camltk/cBell.ml
|
|
+/otherlibs/labltk/camltk/cBell.mli
|
|
+/otherlibs/labltk/camltk/cButton.ml
|
|
+/otherlibs/labltk/camltk/cButton.mli
|
|
+/otherlibs/labltk/camltk/cCanvas.ml
|
|
+/otherlibs/labltk/camltk/cCanvas.mli
|
|
+/otherlibs/labltk/camltk/cCheckbutton.ml
|
|
+/otherlibs/labltk/camltk/cCheckbutton.mli
|
|
+/otherlibs/labltk/camltk/cClipboard.ml
|
|
+/otherlibs/labltk/camltk/cClipboard.mli
|
|
+/otherlibs/labltk/camltk/cDialog.ml
|
|
+/otherlibs/labltk/camltk/cDialog.mli
|
|
+/otherlibs/labltk/camltk/cEncoding.ml
|
|
+/otherlibs/labltk/camltk/cEncoding.mli
|
|
+/otherlibs/labltk/camltk/cEntry.ml
|
|
+/otherlibs/labltk/camltk/cEntry.mli
|
|
+/otherlibs/labltk/camltk/cFocus.ml
|
|
+/otherlibs/labltk/camltk/cFocus.mli
|
|
+/otherlibs/labltk/camltk/cFont.ml
|
|
+/otherlibs/labltk/camltk/cFont.mli
|
|
+/otherlibs/labltk/camltk/cFrame.ml
|
|
+/otherlibs/labltk/camltk/cFrame.mli
|
|
+/otherlibs/labltk/camltk/cGrab.ml
|
|
+/otherlibs/labltk/camltk/cGrab.mli
|
|
+/otherlibs/labltk/camltk/cGrid.ml
|
|
+/otherlibs/labltk/camltk/cGrid.mli
|
|
+/otherlibs/labltk/camltk/cImage.ml
|
|
+/otherlibs/labltk/camltk/cImage.mli
|
|
+/otherlibs/labltk/camltk/cImagebitmap.ml
|
|
+/otherlibs/labltk/camltk/cImagebitmap.mli
|
|
+/otherlibs/labltk/camltk/cImagephoto.ml
|
|
+/otherlibs/labltk/camltk/cImagephoto.mli
|
|
+/otherlibs/labltk/camltk/cLabel.ml
|
|
+/otherlibs/labltk/camltk/cLabel.mli
|
|
+/otherlibs/labltk/camltk/cListbox.ml
|
|
+/otherlibs/labltk/camltk/cListbox.mli
|
|
+/otherlibs/labltk/camltk/cMenu.ml
|
|
+/otherlibs/labltk/camltk/cMenu.mli
|
|
+/otherlibs/labltk/camltk/cMenubutton.ml
|
|
+/otherlibs/labltk/camltk/cMenubutton.mli
|
|
+/otherlibs/labltk/camltk/cMessage.ml
|
|
+/otherlibs/labltk/camltk/cMessage.mli
|
|
+/otherlibs/labltk/camltk/cOption.ml
|
|
+/otherlibs/labltk/camltk/cOption.mli
|
|
+/otherlibs/labltk/camltk/cOptionmenu.ml
|
|
+/otherlibs/labltk/camltk/cOptionmenu.mli
|
|
+/otherlibs/labltk/camltk/cPack.ml
|
|
+/otherlibs/labltk/camltk/cPack.mli
|
|
+/otherlibs/labltk/camltk/cPalette.ml
|
|
+/otherlibs/labltk/camltk/cPalette.mli
|
|
+/otherlibs/labltk/camltk/cPixmap.ml
|
|
+/otherlibs/labltk/camltk/cPixmap.mli
|
|
+/otherlibs/labltk/camltk/cPlace.ml
|
|
+/otherlibs/labltk/camltk/cPlace.mli
|
|
+/otherlibs/labltk/camltk/cRadiobutton.ml
|
|
+/otherlibs/labltk/camltk/cRadiobutton.mli
|
|
+/otherlibs/labltk/camltk/cResource.ml
|
|
+/otherlibs/labltk/camltk/cResource.mli
|
|
+/otherlibs/labltk/camltk/cScale.ml
|
|
+/otherlibs/labltk/camltk/cScale.mli
|
|
+/otherlibs/labltk/camltk/cScrollbar.ml
|
|
+/otherlibs/labltk/camltk/cScrollbar.mli
|
|
+/otherlibs/labltk/camltk/cSelection.ml
|
|
+/otherlibs/labltk/camltk/cSelection.mli
|
|
+/otherlibs/labltk/camltk/cText.ml
|
|
+/otherlibs/labltk/camltk/cText.mli
|
|
+/otherlibs/labltk/camltk/cTk.ml
|
|
+/otherlibs/labltk/camltk/cTkvars.ml
|
|
+/otherlibs/labltk/camltk/cTkvars.mli
|
|
+/otherlibs/labltk/camltk/cTkwait.ml
|
|
+/otherlibs/labltk/camltk/cTkwait.mli
|
|
+/otherlibs/labltk/camltk/cToplevel.ml
|
|
+/otherlibs/labltk/camltk/cToplevel.mli
|
|
+/otherlibs/labltk/camltk/cWinfo.ml
|
|
+/otherlibs/labltk/camltk/cWinfo.mli
|
|
+/otherlibs/labltk/camltk/cWm.ml
|
|
+/otherlibs/labltk/camltk/cWm.mli
|
|
+/otherlibs/labltk/camltk/camltk.ml
|
|
+/otherlibs/labltk/compiler/copyright.ml
|
|
+/otherlibs/labltk/compiler/lexer.ml
|
|
+/otherlibs/labltk/compiler/parser.ml
|
|
+/otherlibs/labltk/compiler/parser.mli
|
|
+/otherlibs/labltk/compiler/parser.output
|
|
+/otherlibs/labltk/compiler/pp
|
|
+/otherlibs/labltk/compiler/pplex.ml
|
|
+/otherlibs/labltk/compiler/ppyac.ml
|
|
+/otherlibs/labltk/compiler/ppyac.mli
|
|
+/otherlibs/labltk/compiler/ppyac.output
|
|
+/otherlibs/labltk/compiler/tkcompiler
|
|
+/otherlibs/labltk/labltk/.depend
|
|
+/otherlibs/labltk/labltk/_tkfgen.ml
|
|
+/otherlibs/labltk/labltk/_tkgen.ml
|
|
+/otherlibs/labltk/labltk/_tkgen.mli
|
|
+/otherlibs/labltk/labltk/_tkigen.ml
|
|
+/otherlibs/labltk/labltk/bell.ml
|
|
+/otherlibs/labltk/labltk/bell.mli
|
|
+/otherlibs/labltk/labltk/button.ml
|
|
+/otherlibs/labltk/labltk/button.mli
|
|
+/otherlibs/labltk/labltk/canvas.ml
|
|
+/otherlibs/labltk/labltk/canvas.mli
|
|
+/otherlibs/labltk/labltk/checkbutton.ml
|
|
+/otherlibs/labltk/labltk/checkbutton.mli
|
|
+/otherlibs/labltk/labltk/clipboard.ml
|
|
+/otherlibs/labltk/labltk/clipboard.mli
|
|
+/otherlibs/labltk/labltk/dialog.ml
|
|
+/otherlibs/labltk/labltk/dialog.mli
|
|
+/otherlibs/labltk/labltk/encoding.ml
|
|
+/otherlibs/labltk/labltk/encoding.mli
|
|
+/otherlibs/labltk/labltk/entry.ml
|
|
+/otherlibs/labltk/labltk/entry.mli
|
|
+/otherlibs/labltk/labltk/focus.ml
|
|
+/otherlibs/labltk/labltk/focus.mli
|
|
+/otherlibs/labltk/labltk/font.ml
|
|
+/otherlibs/labltk/labltk/font.mli
|
|
+/otherlibs/labltk/labltk/frame.ml
|
|
+/otherlibs/labltk/labltk/frame.mli
|
|
+/otherlibs/labltk/labltk/grab.ml
|
|
+/otherlibs/labltk/labltk/grab.mli
|
|
+/otherlibs/labltk/labltk/grid.ml
|
|
+/otherlibs/labltk/labltk/grid.mli
|
|
+/otherlibs/labltk/labltk/image.ml
|
|
+/otherlibs/labltk/labltk/image.mli
|
|
+/otherlibs/labltk/labltk/imagebitmap.ml
|
|
+/otherlibs/labltk/labltk/imagebitmap.mli
|
|
+/otherlibs/labltk/labltk/imagephoto.ml
|
|
+/otherlibs/labltk/labltk/imagephoto.mli
|
|
+/otherlibs/labltk/labltk/label.ml
|
|
+/otherlibs/labltk/labltk/label.mli
|
|
+/otherlibs/labltk/labltk/labltk.ml
|
|
+/otherlibs/labltk/labltk/listbox.ml
|
|
+/otherlibs/labltk/labltk/listbox.mli
|
|
+/otherlibs/labltk/labltk/menu.ml
|
|
+/otherlibs/labltk/labltk/menu.mli
|
|
+/otherlibs/labltk/labltk/menubutton.ml
|
|
+/otherlibs/labltk/labltk/menubutton.mli
|
|
+/otherlibs/labltk/labltk/message.ml
|
|
+/otherlibs/labltk/labltk/message.mli
|
|
+/otherlibs/labltk/labltk/option.ml
|
|
+/otherlibs/labltk/labltk/option.mli
|
|
+/otherlibs/labltk/labltk/optionmenu.ml
|
|
+/otherlibs/labltk/labltk/optionmenu.mli
|
|
+/otherlibs/labltk/labltk/pack.ml
|
|
+/otherlibs/labltk/labltk/pack.mli
|
|
+/otherlibs/labltk/labltk/palette.ml
|
|
+/otherlibs/labltk/labltk/palette.mli
|
|
+/otherlibs/labltk/labltk/pixmap.ml
|
|
+/otherlibs/labltk/labltk/pixmap.mli
|
|
+/otherlibs/labltk/labltk/place.ml
|
|
+/otherlibs/labltk/labltk/place.mli
|
|
+/otherlibs/labltk/labltk/radiobutton.ml
|
|
+/otherlibs/labltk/labltk/radiobutton.mli
|
|
+/otherlibs/labltk/labltk/scale.ml
|
|
+/otherlibs/labltk/labltk/scale.mli
|
|
+/otherlibs/labltk/labltk/scrollbar.ml
|
|
+/otherlibs/labltk/labltk/scrollbar.mli
|
|
+/otherlibs/labltk/labltk/selection.ml
|
|
+/otherlibs/labltk/labltk/selection.mli
|
|
+/otherlibs/labltk/labltk/text.ml
|
|
+/otherlibs/labltk/labltk/text.mli
|
|
+/otherlibs/labltk/labltk/tk.ml
|
|
+/otherlibs/labltk/labltk/tkvars.ml
|
|
+/otherlibs/labltk/labltk/tkvars.mli
|
|
+/otherlibs/labltk/labltk/tkwait.ml
|
|
+/otherlibs/labltk/labltk/tkwait.mli
|
|
+/otherlibs/labltk/labltk/toplevel.ml
|
|
+/otherlibs/labltk/labltk/toplevel.mli
|
|
+/otherlibs/labltk/labltk/winfo.ml
|
|
+/otherlibs/labltk/labltk/winfo.mli
|
|
+/otherlibs/labltk/labltk/wm.ml
|
|
+/otherlibs/labltk/labltk/wm.mli
|
|
+/otherlibs/labltk/lib/labltk
|
|
+/otherlibs/labltk/lib/labltktop
|
|
+/otherlibs/num/nums.cmxa
|
|
+/otherlibs/num/nums.cmxs
|
|
+/otherlibs/str/str.cmxa
|
|
+/otherlibs/str/str.cmxs
|
|
+/otherlibs/systhreads/threads.cmxa
|
|
+/otherlibs/threads/marshal.mli
|
|
+/otherlibs/threads/pervasives.mli
|
|
+/otherlibs/threads/unix.mli
|
|
+/otherlibs/unix/unix.cmxa
|
|
+/otherlibs/unix/unix.cmxs
|
|
+/package-macosx
|
|
+/parsing/lexer.ml
|
|
+/parsing/linenum.ml
|
|
+/parsing/parser.ml
|
|
+/parsing/parser.mli
|
|
+/parsing/parser.output
|
|
+/stdlib/caml
|
|
+/stdlib/camlheader
|
|
+/stdlib/camlheader_ur
|
|
+/stdlib/camlheaderd
|
|
+/stdlib/stdlib.cmxa
|
|
+/stdlib/stdlib.p.cmxa
|
|
+/stdlib/sys.ml
|
|
+/tools/cvt_emit
|
|
+/tools/cvt_emit.ml
|
|
+/tools/dumpobj
|
|
+/tools/myocamlbuild_config.ml
|
|
+/tools/objinfo
|
|
+/tools/objinfo_helper
|
|
+/tools/ocamlcp
|
|
+/tools/ocamldep
|
|
+/tools/ocamldep.opt
|
|
+/tools/ocamlmklib
|
|
+/tools/ocamlmklib.ml
|
|
+/tools/ocamlmktop
|
|
+/tools/ocamloptp
|
|
+/tools/ocamlprof
|
|
+/tools/opnames.ml
|
|
+/tools/read_cmt
|
|
+/tools/read_cmt.opt
|
|
+/utils/config.ml
|
|
+/yacc/ocamlyacc
|
|
+/yacc/version.h
|
|
--
|
|
1.8.5.3
|
|
|