New upstream version 4.02.1.

- Rebase patches on top.
This commit is contained in:
Richard W.M. Jones 2015-02-16 12:39:40 +00:00
parent c4dd5fe841
commit fa72b7f43e
17 changed files with 55 additions and 51 deletions

View File

@ -1,4 +1,4 @@
From ccc1bf226619608230dc94b26377756719cf7b20 Mon Sep 17 00:00:00 2001
From 607ae33eed09f9eafccda1276626e9c509dcbed1 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 24 Jun 2014 22:29:38 +0100
Subject: [PATCH 01/15] Don't ignore ./configure, it's a real git file.
@ -8,7 +8,7 @@ Subject: [PATCH 01/15] Don't ignore ./configure, it's a real git file.
1 file changed, 1 deletion(-)
diff --git a/.gitignore b/.gitignore
index d36195a..dbb0e3e 100644
index 6c66ecc..5d4b626 100644
--- a/.gitignore
+++ b/.gitignore
@@ -19,7 +19,6 @@
@ -20,5 +20,5 @@ index d36195a..dbb0e3e 100644
/ocamlc.opt
/expunge
--
2.0.4
2.1.0

View File

@ -1,4 +1,4 @@
From 0e3b6450f6ab803442a809b6da41d5d5c5da650f Mon Sep 17 00:00:00 2001
From 89f29afc4aaa324585aa010289a4a58416d53700 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 7 Jun 2012 15:36:16 +0100
Subject: [PATCH 02/15] Ensure empty compilerlibs/ directory is created by git.
@ -14,5 +14,5 @@ diff --git a/compilerlibs/.exists b/compilerlibs/.exists
new file mode 100644
index 0000000..e69de29
--
2.0.4
2.1.0

View File

@ -1,4 +1,4 @@
From 79f0f91e3e4abbfbd3564c11ea72e53310236afc Mon Sep 17 00:00:00 2001
From 10209519de242952ebdef608ab5f2f51a6c9e2b3 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 24 Jun 2014 10:00:15 +0100
Subject: [PATCH 03/15] Don't add rpaths to libraries.
@ -25,5 +25,5 @@ index 2517434..75a75b4 100644
sed -n -e 's/^#ml //p' ../config/Makefile) \
> ocamlmklibconfig.ml
--
2.0.4
2.1.0

View File

@ -1,4 +1,4 @@
From 11b377aee2811891635982a5590fef62f12645b6 Mon Sep 17 00:00:00 2001
From b360841d9b1eae64201d1ee7a1ff6dc5a5b0fa87 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 29 May 2012 20:40:36 +0100
Subject: [PATCH 04/15] ocamlbyteinfo, ocamlplugininfo: Useful utilities from
@ -236,5 +236,5 @@ index 0000000..e28800f
+ header.units
+ end
--
2.0.4
2.1.0

View File

@ -1,4 +1,4 @@
From 5308c47681201ef3beef3e543ab877f81aa08784 Mon Sep 17 00:00:00 2001
From 6193266853d3667f18048989ebaaa0cbcb74afb5 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 29 May 2012 20:44:18 +0100
Subject: [PATCH 05/15] configure: Allow user defined C compiler flags.
@ -8,10 +8,10 @@ Subject: [PATCH 05/15] configure: Allow user defined C compiler flags.
1 file changed, 4 insertions(+)
diff --git a/configure b/configure
index dbc6178..c1133ee 100755
index 3edb9fd..18b95cd 100755
--- a/configure
+++ b/configure
@@ -1633,6 +1633,10 @@ case "$buggycc" in
@@ -1654,6 +1654,10 @@ case "$buggycc" in
nativecccompopts="$nativecccompopts -fomit-frame-pointer";;
esac
@ -23,5 +23,5 @@ index dbc6178..c1133ee 100755
cclibs="$cclibs $mathlib"
--
2.0.4
2.1.0

View File

@ -1,4 +1,4 @@
From 3628c89d319ac8286b62ec1405561b72bda4ba0d Mon Sep 17 00:00:00 2001
From 5022b33b094d5a88c5c372b0873d81023f0d7bb4 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 29 May 2012 20:47:07 +0100
Subject: [PATCH 06/15] Add support for ppc64.
@ -2105,10 +2105,10 @@ index 92b3c28..5202c3a 100644
#define Saved_return_address(sp) *((intnat *)((sp) - 4))
#define Callback_link(sp) ((struct caml_context *)((sp) + 8))
diff --git a/configure b/configure
index c1133ee..954b25e 100755
index 18b95cd..57c8699 100755
--- a/configure
+++ b/configure
@@ -808,6 +808,7 @@ case "$target" in
@@ -814,6 +814,7 @@ case "$target" in
fi;;
i[3456]86-*-gnu*) arch=i386; system=gnu;;
i[3456]86-*-mingw*) arch=i386; system=mingw;;
@ -2116,7 +2116,7 @@ index c1133ee..954b25e 100755
powerpc*-*-linux*) arch=power; model=ppc; system=elf;;
powerpc-*-netbsd*) arch=power; model=ppc; system=elf;;
powerpc-*-openbsd*) arch=power; model=ppc; system=bsd_elf;;
@@ -888,6 +889,8 @@ case "$arch,$system" in
@@ -894,6 +895,8 @@ case "$arch,$system" in
aspp="/usr/ccs/bin/${TOOLPREF}as -P";;
power,elf) as="${TOOLPREF}as -u -m ppc"
aspp="${TOOLPREF}gcc -c";;
@ -2126,5 +2126,5 @@ index c1133ee..954b25e 100755
aspp="$bytecc -c";;
sparc,solaris) as="${TOOLPREF}as"
--
2.0.4
2.1.0

View File

@ -1,4 +1,4 @@
From e07a92272d84fc98ddbe0b42439fa1518283296d Mon Sep 17 00:00:00 2001
From 834644b81c536fc81022a0a13f860fb33e3d78d2 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Fri, 24 Oct 2014 12:59:23 +0200
Subject: [PATCH 07/15] ppc64: Update for OCaml 4.02.0.
@ -201,5 +201,5 @@ index b7bba9b..b582b6a 100644
| Iintop(Imod) -> 40 (* assuming full stall *)
| Iintop(Icomp _) -> 4
--
2.0.4
2.1.0

View File

@ -1,4 +1,4 @@
From 371f3ea408ebfc627ab964bb82efc1b5ced1b9b0 Mon Sep 17 00:00:00 2001
From c89bde7d3563e2c7bb725272334fabf53044bd9c Mon Sep 17 00:00:00 2001
From: Michel Normand <normand@linux.vnet.ibm.com>
Date: Tue, 18 Mar 2014 09:15:47 -0400
Subject: [PATCH 08/15] Add support for ppc64le.
@ -1892,10 +1892,10 @@ index b79252d..049652e 100755
echo powerpc-unknown-linux-${LIBC}
exit ;;
diff --git a/configure b/configure
index 954b25e..cc3cbbf 100755
index 57c8699..c04272c 100755
--- a/configure
+++ b/configure
@@ -809,6 +809,7 @@ case "$target" in
@@ -815,6 +815,7 @@ case "$target" in
i[3456]86-*-gnu*) arch=i386; system=gnu;;
i[3456]86-*-mingw*) arch=i386; system=mingw;;
powerpc64-*-linux*) arch=power64; model=ppc64; system=elf;;
@ -1903,7 +1903,7 @@ index 954b25e..cc3cbbf 100755
powerpc*-*-linux*) arch=power; model=ppc; system=elf;;
powerpc-*-netbsd*) arch=power; model=ppc; system=elf;;
powerpc-*-openbsd*) arch=power; model=ppc; system=bsd_elf;;
@@ -891,6 +892,8 @@ case "$arch,$system" in
@@ -897,6 +898,8 @@ case "$arch,$system" in
aspp="${TOOLPREF}gcc -c";;
power64,elf) as='${TOOLPREF}as -u -m ppc64'
aspp='${TOOLPREF}gcc -c';;
@ -1913,5 +1913,5 @@ index 954b25e..cc3cbbf 100755
aspp="$bytecc -c";;
sparc,solaris) as="${TOOLPREF}as"
--
2.0.4
2.1.0

View File

@ -1,4 +1,4 @@
From 2d809c0bf3d0f4106ec7ff9c9e4ee3c8204d9516 Mon Sep 17 00:00:00 2001
From 8d86aba4983a254f36f2f1758079b3099ba5fc07 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Fri, 24 Oct 2014 12:59:23 +0200
Subject: [PATCH 09/15] ppc64le: Update for OCaml 4.02.0.
@ -200,5 +200,5 @@ index b7bba9b..b582b6a 100644
| Iintop(Imod) -> 40 (* assuming full stall *)
| Iintop(Icomp _) -> 4
--
2.0.4
2.1.0

View File

@ -1,4 +1,4 @@
From 00721516cd921f71f727915e14b723412afe835a Mon Sep 17 00:00:00 2001
From 4d08d0e8511e247a96440693b73773c72b04fee2 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sat, 10 May 2014 03:20:35 -0400
Subject: [PATCH 10/15] arm, arm64: Mark stack as non-executable.
@ -35,5 +35,5 @@ index 9b4b9ab..c23168b 100644
+ /* Mark stack as non-executable, PR#4564 */
+ .section .note.GNU-stack,"",%progbits
--
2.0.4
2.1.0

View File

@ -1,4 +1,4 @@
From 8c54b8588ea3000c5082a0a2b2e57c3d5a1a8655 Mon Sep 17 00:00:00 2001
From 8ee89eee0500d17ffb91aa2febdeb6792ac53f27 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 1 Apr 2014 11:17:07 +0100
Subject: [PATCH 11/15] arg: Add no_arg and get_arg helper functions.
@ -19,7 +19,7 @@ In particular, this should not change the treatment of Arg.current
1 file changed, 26 insertions(+), 21 deletions(-)
diff --git a/stdlib/arg.ml b/stdlib/arg.ml
index 0f6480b..a41e0a2 100644
index d7b8ac0..a8f3964 100644
--- a/stdlib/arg.ml
+++ b/stdlib/arg.ml
@@ -134,56 +134,62 @@ let parse_argv_dynamic ?(current=current) argv speclist anonfun errmsg =
@ -114,5 +114,5 @@ index 0f6480b..a41e0a2 100644
treat_action action
with Bad m -> stop (Message m);
--
2.0.4
2.1.0

View File

@ -1,4 +1,4 @@
From 857b0cdc2ac37926e625034e5e62114e103cfe9e Mon Sep 17 00:00:00 2001
From 350eab7918f0adf385e01411ae6fed3e0579145f Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 1 Apr 2014 11:21:40 +0100
Subject: [PATCH 12/15] arg: Allow flags such as --flag=arg as well as --flag
@ -16,7 +16,7 @@ http://caml.inria.fr/mantis/view.php?id=5197
2 files changed, 26 insertions(+), 7 deletions(-)
diff --git a/stdlib/arg.ml b/stdlib/arg.ml
index a41e0a2..5ffdabc 100644
index a8f3964..f2b6f13 100644
--- a/stdlib/arg.ml
+++ b/stdlib/arg.ml
@@ -55,6 +55,12 @@ let rec assoc3 x l =
@ -66,7 +66,7 @@ index a41e0a2..5ffdabc 100644
begin try
let rec treat_action = function
diff --git a/stdlib/arg.mli b/stdlib/arg.mli
index 22eda40..7078071 100644
index 0999edf..71af638 100644
--- a/stdlib/arg.mli
+++ b/stdlib/arg.mli
@@ -25,7 +25,8 @@
@ -80,5 +80,5 @@ index 22eda40..7078071 100644
Examples ([cmd] is assumed to be the command name):
--
2.0.4
2.1.0

View File

@ -1,4 +1,4 @@
From d58a221d0fd307d80bed6cfcec67a1c97e47439c Mon Sep 17 00:00:00 2001
From 4072cbf56bba989f87783f285952d7227ba5898d Mon Sep 17 00:00:00 2001
From: Xavier Leroy <xavier.leroy@inria.fr>
Date: Wed, 27 Aug 2014 09:58:33 +0000
Subject: [PATCH 13/15] PR#6517: use ISO C99 types {,u}int{32,64}_t in
@ -53,7 +53,7 @@ http://caml.inria.fr/mantis/view.php?id=6517
34 files changed, 319 insertions(+), 320 deletions(-)
diff --git a/asmrun/backtrace.c b/asmrun/backtrace.c
index c72a237..773e22c 100644
index 05e0d6b..5eb8600 100644
--- a/asmrun/backtrace.c
+++ b/asmrun/backtrace.c
@@ -217,7 +217,7 @@ static void extract_location_info(frame_descr * d,
@ -1683,7 +1683,7 @@ index 5795e48..c143986 100644
} else {
res = 1;
diff --git a/config/s-nt.h b/config/s-nt.h
index 6df440b..603b050 100644
index e8aa878..ccf1bf4 100644
--- a/config/s-nt.h
+++ b/config/s-nt.h
@@ -15,6 +15,9 @@
@ -1697,10 +1697,10 @@ index 6df440b..603b050 100644
#define HAS_STRERROR
#define HAS_SOCKETS
diff --git a/configure b/configure
index cc3cbbf..ff27aa9 100755
index c04272c..092d467 100755
--- a/configure
+++ b/configure
@@ -615,26 +615,6 @@ case "$target" in
@@ -619,26 +619,6 @@ case "$target" in
esac
esac
@ -1727,7 +1727,7 @@ index cc3cbbf..ff27aa9 100755
# Shared library support
shared_libraries_supported=false
@@ -1085,6 +1065,11 @@ if sh ./hasgot -i sys/types.h -i sys/socket.h -i netinet/in.h \
@@ -1097,6 +1077,11 @@ if sh ./hasgot -i sys/types.h -i sys/socket.h -i netinet/in.h \
echo "#define HAS_IPV6" >> s.h
fi
@ -1959,5 +1959,5 @@ index cb3d995..93cdfeb 100644
lseek(fd, (long) -TRAILER_SIZE, SEEK_END);
--
2.0.4
2.1.0

View File

@ -1,4 +1,4 @@
From 907e64f45ad87b746aad704af717b067d0909014 Mon Sep 17 00:00:00 2001
From 074d0a2b85a7d4f505846ac629b28a3a8894ebbc Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 11 Sep 2014 14:49:54 +0100
Subject: [PATCH 14/15] ppc, ppc64, ppc64le: Mark stack as non-executable.
@ -34,5 +34,5 @@ index 98c42e2..b7bfce4 100644
+/* Mark stack as non-executable, PR#4564 */
+ .section .note.GNU-stack,"",%progbits
--
2.0.4
2.1.0

View File

@ -1,4 +1,4 @@
From a3cbc5d7e8f5576c9b0d5fb32b359d75c0edfdb1 Mon Sep 17 00:00:00 2001
From 632c63206ec47f67af0027b5c0d173784e510c08 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Fri, 24 Oct 2014 10:10:54 +0100
Subject: [PATCH 15/15] ppc64/ppc64le: proc: Interim definitions for op_is_pure
@ -80,5 +80,5 @@ index 476c984..56473ac 100644
let num_stack_slots = [| 0; 0 |]
--
2.0.4
2.1.0

View File

@ -16,8 +16,8 @@
%endif
Name: ocaml
Version: 4.02.0
Release: 6%{?dist}
Version: 4.02.1
Release: 1%{?dist}
Summary: OCaml compiler and programming environment
@ -39,7 +39,7 @@ Source3: http://caml.inria.fr/pub/distrib/ocaml-4.02/ocaml-4.02-refman.in
#
# https://git.fedorahosted.org/cgit/fedora-ocaml.git/
#
# Current branch: fedora-22-4.02
# Current branch: fedora-23-4.02
#
# ALTERNATIVELY add a patch to the end of the list (leaving the
# existing patches unchanged) adding a comment to note that it should
@ -422,6 +422,10 @@ fi
%changelog
* Mon Feb 16 2015 Richard W.M. Jones <rjones@redhat.com> - 4.02.1-1
- New upstream version 4.02.1.
- Rebase patches on top.
* Fri Oct 24 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02.0-6
- Fixes for ppc64/ppc64le (RHBZ#1156300).

View File

@ -1,4 +1,4 @@
8bba7e7d872083af1723dd450e07a5f4 ocaml-4.02.0.tar.gz
20b691d71d36df69f9cb16ab4521ed49 ocaml-4.02-refman-html.tar.gz
265b7db123e925e8b7b70ca2266b4206 ocaml-4.02-refman.info.tar.gz
1d683029a6ef48e34cc24eb1982cdd05 ocaml-4.02-refman.pdf
3c35318eefd201f96797c093c920b343 ocaml-4.02.1.tar.gz