OCaml 4.10.0 final.

This commit is contained in:
Richard W.M. Jones 2020-02-25 21:25:57 +00:00
parent 39e6786df8
commit dc143d5bb6
7 changed files with 24 additions and 20 deletions

View File

@ -1,4 +1,4 @@
From 1f575196cc7c26a1edc016bca8f7ff052636186b Mon Sep 17 00:00:00 2001
From bf123e43c444ff14fcb76f806d90806e4960a1a4 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 24 Jun 2014 10:00:15 +0100
Subject: [PATCH 1/5] Don't add rpaths to libraries.
@ -23,5 +23,5 @@ index 18aead935..e374c05ee 100644
> ocamlmklibconfig.ml
--
2.24.1
2.25.0

View File

@ -1,4 +1,4 @@
From 122b350037d93e9f44357b215d5ecfbadb8d8fa5 Mon Sep 17 00:00:00 2001
From 3a5dfecb2e4078bcd7388412783b50014006e7c9 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 29 May 2012 20:44:18 +0100
Subject: [PATCH 2/5] configure: Allow user defined C compiler flags.
@ -8,7 +8,7 @@ Subject: [PATCH 2/5] configure: Allow user defined C compiler flags.
1 file changed, 4 insertions(+)
diff --git a/configure.ac b/configure.ac
index 90e6a041e..2f7e829e5 100644
index e3e28fb6f..0648f0553 100644
--- a/configure.ac
+++ b/configure.ac
@@ -590,6 +590,10 @@ AS_CASE([$host],
@ -23,5 +23,5 @@ index 90e6a041e..2f7e829e5 100644
# Enable SSE2 on x86 mingw to avoid using 80-bit registers.
--
2.24.1
2.25.0

View File

@ -1,4 +1,4 @@
From 4481368be15b3dbd07c9ed8a3194194fe8594fc5 Mon Sep 17 00:00:00 2001
From b32e6fc3318a2d25d7ae233a8999beb752d6131d Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Fri, 26 Apr 2019 16:16:29 +0100
Subject: [PATCH 3/5] configure: Remove incorrect assumption about
@ -10,7 +10,7 @@ See https://github.com/ocaml/ocaml/issues/8647#issuecomment-487094390
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/configure.ac b/configure.ac
index 2f7e829e5..ed6e0b0ca 100644
index 0648f0553..ad07516e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -505,10 +505,11 @@ AS_IF(
@ -39,5 +39,5 @@ index 2f7e829e5..ed6e0b0ca 100644
# We first compute default values for as and aspp
# If values have been given by the user then they take precedence over
--
2.24.1
2.25.0

View File

@ -1,4 +1,4 @@
From 95c9c4486c1c23cc735d4986d1b3e6b812514184 Mon Sep 17 00:00:00 2001
From 9ea729ce863396484d2e4c5a93af4b625fc5c90c Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sat, 18 Jan 2020 11:31:27 +0000
Subject: [PATCH 4/5] Remove configure from .gitattributes.
@ -24,5 +24,5 @@ index 9be9e33a0..5df88ab4e 100644
# http://krlmlr.github.io/using-gitattributes-to-avoid-merge-conflicts/
/.mailmap merge=union
--
2.24.1
2.25.0

View File

@ -1,4 +1,4 @@
From 17f5c84a20466e9ef6f1821a45b88e6bb0df8102 Mon Sep 17 00:00:00 2001
From 68ad1dae406a172cd3b0a4b38b8b36150c270b96 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Nicol=C3=A1s=20Ojeda=20B=C3=A4r?= <n.oje.bar@gmail.com>
Date: Mon, 18 Nov 2019 01:13:30 +0100
Subject: [PATCH 5/5] Add riscv64 backend
@ -1318,7 +1318,7 @@ index 000000000..62fccb648
+
+let fundecl f = (new selector)#emit_fundecl f
diff --git a/configure b/configure
index eb5f3a685..76fd3331b 100755
index b8f74728f..ec3d7e83d 100755
--- a/configure
+++ b/configure
@@ -13509,6 +13509,8 @@ if test x"$enable_shared" != "xno"; then :
@ -1353,7 +1353,7 @@ index eb5f3a685..76fd3331b 100755
case $ocaml_cv_cc_vendor in #(
clang-*) :
diff --git a/configure.ac b/configure.ac
index ed6e0b0ca..0a1ad8f86 100644
index ad07516e7..562f916dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -841,7 +841,8 @@ AS_IF([test x"$enable_shared" != "xno"],
@ -1389,7 +1389,7 @@ index ed6e0b0ca..0a1ad8f86 100644
AS_CASE([$ocaml_cv_cc_vendor],
[clang-*], [default_aspp="${toolpref}clang -c -Wno-trigraphs"],
diff --git a/runtime/caml/stack.h b/runtime/caml/stack.h
index cb8b77922..1d1305c8d 100644
index 259f97ac4..dac7cb3f7 100644
--- a/runtime/caml/stack.h
+++ b/runtime/caml/stack.h
@@ -70,6 +70,11 @@
@ -1931,5 +1931,5 @@ index 000000000..8b34a40f8
+caml_c_call:
+ jr t2
--
2.24.1
2.25.0

View File

@ -24,13 +24,14 @@
%global test_arches_required NONE
# Architectures where parallel builds fail.
#%global no_parallel_build_arches aarch64
#global no_parallel_build_arches aarch64
%global rcver +beta1
#global rcver +beta1
%global rcver %{nil}
Name: ocaml
Version: 4.10.0
Release: 0.beta1.0%{?dist}.1
Release: 1
Summary: OCaml compiler and programming environment
@ -49,7 +50,7 @@ Source0: http://caml.inria.fr/pub/distrib/ocaml-4.10/ocaml-%{version}%{rc
#
# https://pagure.io/fedora-ocaml
#
# Current branch: fedora-32-4.10.0-beta1
# Current branch: fedora-32-4.10.0
#
# ALTERNATIVELY add a patch to the end of the list (leaving the
# existing patches unchanged) adding a comment to note that it should
@ -368,6 +369,9 @@ find $RPM_BUILD_ROOT \( -name '*.cmt' -o -name '*.cmti' \) -a -delete
%changelog
* Tue Feb 25 2020 Richard W.M. Jones <rjones@redhat.com> - 4.10.0-1
- OCaml 4.10.0 final.
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 4.10.0-0.beta1.0.1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (ocaml-4.10.0+beta1.tar.xz) = 97be0fcf6dee2309c43bca86ace21c83dc5b36bac34b70144a06f36883d7bd5bc457d3e95c6ac47a2ec5e3262058d3be39fc2559f118e4e6b58ec5970ffa88dc
SHA512 (ocaml-4.10.0.tar.xz) = d2ed8b6162898da45ccc231c97a1b46a330467b9b24390ed17cf3e5367ae6d198ecac8e0df11e5501cdf22cc6313ec23c6cf477d621d017f69f9744eb0050e2e