Added patch for removing rpath from shared libs
This commit is contained in:
parent
ffb724a1e5
commit
c5c9c161e1
27
ocaml-rpath.patch
Normal file
27
ocaml-rpath.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
--- ocaml-3.08.2/tools/Makefile.rpath 2005-02-12 11:38:17.000000000 +0100
|
||||||
|
+++ ocaml-3.08.2/tools/Makefile 2005-02-12 11:38:41.000000000 +0100
|
||||||
|
@@ -101,9 +101,6 @@
|
||||||
|
sed -e "s|%%BINDIR%%|$(BINDIR)|" \
|
||||||
|
-e "s|%%SUPPORTS_SHARED_LIBRARIES%%|$(SUPPORTS_SHARED_LIBRARIES)|" \
|
||||||
|
-e "s|%%MKSHAREDLIB%%|$(MKSHAREDLIB)|" \
|
||||||
|
- -e "s|%%BYTECCRPATH%%|$(BYTECCRPATH)|" \
|
||||||
|
- -e "s|%%NATIVECCRPATH%%|$(NATIVECCRPATH)|" \
|
||||||
|
- -e "s|%%MKSHAREDLIBRPATH%%|$(MKSHAREDLIBRPATH)|" \
|
||||||
|
-e "s|%%RANLIB%%|$(RANLIB)|" \
|
||||||
|
ocamlmklib.mlp >> ocamlmklib.ml
|
||||||
|
|
||||||
|
--- ocaml-3.08.2/tools/ocamlmklib.mlp.rpath 2005-02-12 11:46:55.646162346 +0100
|
||||||
|
+++ ocaml-3.08.2/tools/ocamlmklib.mlp 2005-02-12 11:49:11.411467461 +0100
|
||||||
|
@@ -17,9 +17,9 @@
|
||||||
|
let bindir = "%%BINDIR%%"
|
||||||
|
and supports_shared_libraries = %%SUPPORTS_SHARED_LIBRARIES%%
|
||||||
|
and mksharedlib = "%%MKSHAREDLIB%%"
|
||||||
|
-and bytecc_rpath = "%%BYTECCRPATH%%"
|
||||||
|
-and nativecc_rpath = "%%NATIVECCRPATH%%"
|
||||||
|
-and mksharedlib_rpath = "%%MKSHAREDLIBRPATH%%"
|
||||||
|
+and bytecc_rpath = ""
|
||||||
|
+and nativecc_rpath = ""
|
||||||
|
+and mksharedlib_rpath = ""
|
||||||
|
and ranlib = "%%RANLIB%%"
|
||||||
|
|
||||||
|
let bytecode_objs = ref [] (* .cmo,.cma,.ml,.mli files to pass to ocamlc *)
|
13
ocaml.spec
13
ocaml.spec
@ -1,6 +1,6 @@
|
|||||||
Name: ocaml
|
Name: ocaml
|
||||||
Version: 3.08.2
|
Version: 3.08.2
|
||||||
Release: 1
|
Release: 2
|
||||||
Epoch: 0
|
Epoch: 0
|
||||||
Summary: The Objective Caml compiler and programming environment
|
Summary: The Objective Caml compiler and programming environment
|
||||||
|
|
||||||
@ -11,9 +11,10 @@ Source0: http://caml.inria.fr/distrib/ocaml-3.08/ocaml-3.08.2.tar.bz2
|
|||||||
Source1: http://caml.inria.fr/distrib/ocaml-3.08/ocaml-3.08-refman.html.tar.gz
|
Source1: http://caml.inria.fr/distrib/ocaml-3.08/ocaml-3.08-refman.html.tar.gz
|
||||||
Source2: http://caml.inria.fr/distrib/ocaml-3.08/ocaml-3.08-refman.ps.gz
|
Source2: http://caml.inria.fr/distrib/ocaml-3.08/ocaml-3.08-refman.ps.gz
|
||||||
Source3: http://caml.inria.fr/distrib/ocaml-3.08/ocaml-3.08-refman.info.tar.gz
|
Source3: http://caml.inria.fr/distrib/ocaml-3.08/ocaml-3.08-refman.info.tar.gz
|
||||||
|
Patch: ocaml-rpath.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: ncurses-devel, gdbm-devel, XFree86-devel
|
BuildRequires: ncurses-devel, gdbm-devel, xorg-x11-devel
|
||||||
BuildRequires: /usr/include/tcl.h, /usr/include/tk.h
|
BuildRequires: tcl-devel, tk-devel
|
||||||
BuildRequires: emacs, perl
|
BuildRequires: emacs, perl
|
||||||
Requires(post,preun): /sbin/install-info
|
Requires(post,preun): /sbin/install-info
|
||||||
|
|
||||||
@ -73,6 +74,7 @@ Documentation for Objective Caml.
|
|||||||
%setup -q -T -b 0
|
%setup -q -T -b 0
|
||||||
%setup -q -T -D -a 1
|
%setup -q -T -D -a 1
|
||||||
%setup -q -T -D -a 3
|
%setup -q -T -D -a 3
|
||||||
|
%patch -p1
|
||||||
cp %{SOURCE2} refman.ps.gz
|
cp %{SOURCE2} refman.ps.gz
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -174,11 +176,14 @@ fi
|
|||||||
%doc emacs/README
|
%doc emacs/README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Feb 12 2005 Gerard Milmeister <gemi@bluewin.ch> - 0:3.08.2-2
|
||||||
|
- Added patch for removing rpath from shared libs
|
||||||
|
|
||||||
* Sat Feb 12 2005 Gerard Milmeister <gemi@bluewin.ch> - 0:3.08.2-1
|
* Sat Feb 12 2005 Gerard Milmeister <gemi@bluewin.ch> - 0:3.08.2-1
|
||||||
- New Version 3.08.2
|
- New Version 3.08.2
|
||||||
|
|
||||||
* Thu Dec 30 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:3.07-6
|
* Thu Dec 30 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:3.07-6
|
||||||
- add -x11lib %%_prefix/X11R6/%%_lib to configure; fixes labltk build
|
- add -x11lib {_prefix}/X11R6/{libdir} to configure; fixes labltk build
|
||||||
on x86_64
|
on x86_64
|
||||||
|
|
||||||
* Tue Dec 2 2003 Gerard Milmeister <gemi@bluewin.ch> - 0:3.07-0.fdr.5
|
* Tue Dec 2 2003 Gerard Milmeister <gemi@bluewin.ch> - 0:3.07-0.fdr.5
|
||||||
|
Loading…
Reference in New Issue
Block a user