Upgrade to OCaml 4.00.0 official release.

- Remove one patch (add -lpthread) which went upstream.
This commit is contained in:
Richard W.M. Jones 2012-07-28 11:08:30 +01:00
parent e5596c32b7
commit 24e662a3fe
10 changed files with 42 additions and 63 deletions

3
.gitignore vendored
View File

@ -15,3 +15,6 @@ ocaml-3.11.2.tar.bz2
/ocaml-4.00beta-refman-html.tar.gz
/ocaml-4.00beta-refman.info.tar.gz
/ocaml-4.00beta-refman.pdf
/ocaml-4.00.0.tar.bz2
/ocaml-4.00-refman.info.tar.gz
/ocaml-4.00-refman.pdf

View File

@ -1,7 +1,7 @@
From c7fff641b0b04cde2ceeb8376b4e0715a64e7bb7 Mon Sep 17 00:00:00 2001
From 15b5463d5d69a235e9ae6dd63df69cf2895d5b0d Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 7 Jun 2012 16:00:28 +0100
Subject: [PATCH 1/7] Add .gitignore file to ignore generated files.
Subject: [PATCH 1/6] Add .gitignore file to ignore generated files.
---
.gitignore | 345 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
@ -360,5 +360,5 @@ index 0000000..b67b39f
+/yacc/ocamlyacc
+/yacc/version.h
--
1.7.10.1
1.7.10.4

View File

@ -1,7 +1,7 @@
From 025baae6645f09b0f34ca8f2a746e3d4261ae4c1 Mon Sep 17 00:00:00 2001
From 4199df517cc7701c7eab526077d144ed3b9509f2 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 7 Jun 2012 15:36:16 +0100
Subject: [PATCH 2/7] Ensure empty compilerlibs/ directory is created by git.
Subject: [PATCH 2/6] Ensure empty compilerlibs/ directory is created by git.
This directory exists in the OCaml tarball, but is empty. As a
result, git ignores it unless we put a dummy file in it.
@ -13,5 +13,5 @@ diff --git a/compilerlibs/.exists b/compilerlibs/.exists
new file mode 100644
index 0000000..e69de29
--
1.7.10.1
1.7.10.4

View File

@ -1,7 +1,7 @@
From 6865790801a84e9ad94234e30da346b73381b232 Mon Sep 17 00:00:00 2001
From e2e4674341b3f2f16adb30e2d0efd3ff824d0d84 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 29 May 2012 20:40:36 +0100
Subject: [PATCH 3/7] ocamlbyteinfo, ocamlplugininfo: Useful utilities from
Subject: [PATCH 3/6] ocamlbyteinfo, ocamlplugininfo: Useful utilities from
Debian, sent upstream.
See:
@ -236,5 +236,5 @@ index 0000000..e28800f
+ header.units
+ end
--
1.7.10.1
1.7.10.4

View File

@ -1,7 +1,7 @@
From 1e899c7ec6482dcecb57682a20a25df34315eb20 Mon Sep 17 00:00:00 2001
From 89b696fcb9fb4b34e79f4cf97b42057fe0c4c2ab Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 29 May 2012 20:43:34 +0100
Subject: [PATCH 4/7] Don't add rpaths to libraries.
Subject: [PATCH 4/6] Don't add rpaths to libraries.
---
tools/Makefile.shared | 3 ---
@ -22,5 +22,5 @@ index f6818d3..aadd7e2 100644
ocamlmklib.mlp >> ocamlmklib.ml
--
1.7.10.1
1.7.10.4

View File

@ -1,17 +1,17 @@
From 05d5577eecfd8d17f5d3f9a9f1063b8c6df295d4 Mon Sep 17 00:00:00 2001
From 054fdef0909de3dd1bd1142b4e57ff29f4826cfe Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 29 May 2012 20:44:18 +0100
Subject: [PATCH 5/7] configure: Allow user defined C compiler flags.
Subject: [PATCH 5/6] configure: Allow user defined C compiler flags.
---
configure | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/configure b/configure
index 72f4240..eafd6d9 100755
index e08bbce..cda73fd 100755
--- a/configure
+++ b/configure
@@ -1572,6 +1572,10 @@ case "$buggycc" in
@@ -1576,6 +1576,10 @@ case "$buggycc" in
nativecccompopts="$nativecccompopts -fomit-frame-pointer";;
esac
@ -23,5 +23,5 @@ index 72f4240..eafd6d9 100755
cclibs="$cclibs $mathlib"
--
1.7.10.1
1.7.10.4

View File

@ -1,7 +1,7 @@
From c5d136f4163a0b815f936269151faf2ae44791b2 Mon Sep 17 00:00:00 2001
From 8c0add238693e59d78e665e0d5275f6e77c35f8c Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 29 May 2012 20:47:07 +0100
Subject: [PATCH 7/7] Add support for ppc64.
Subject: [PATCH 6/6] Add support for ppc64.
Note (1): This patch was rejected upstream because they don't have
appropriate hardware for testing.
@ -2108,10 +2108,10 @@ index a801405..59a7bf2 100644
#define Saved_return_address(sp) *((intnat *)((sp) - 4))
#define Callback_link(sp) ((struct caml_context *)((sp) + 8))
diff --git a/configure b/configure
index eafd6d9..2f48daf 100755
index cda73fd..314d1e9 100755
--- a/configure
+++ b/configure
@@ -685,6 +685,7 @@ case "$host" in
@@ -686,6 +686,7 @@ case "$host" in
arch=i386; system=macosx
fi;;
i[3456]86-*-gnu*) arch=i386; system=gnu;;
@ -2119,7 +2119,7 @@ index eafd6d9..2f48daf 100755
powerpc*-*-linux*) arch=power; model=ppc; system=elf;;
powerpc-*-netbsd*) arch=power; model=ppc; system=elf;;
powerpc-*-rhapsody*) arch=power; model=ppc; system=rhapsody;;
@@ -756,6 +757,8 @@ case "$arch,$model,$system" in
@@ -757,6 +758,8 @@ case "$arch,$model,$system" in
aspp='gcc -c';;
power,*,elf) as='as -u -m ppc'
aspp='gcc -c';;
@ -2129,5 +2129,5 @@ index eafd6d9..2f48daf 100755
aspp='gcc -c';;
power,*,rhapsody) as="as -arch $model"
--
1.7.10.1
1.7.10.4

View File

@ -1,28 +0,0 @@
From a0bc0d6b0b714ea95e463b49b777a469b6e6281c Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 5 Jun 2012 22:49:17 +0100
Subject: [PATCH 6/7] Link dllthreads.so with -lpthread so that pthread_atfork
is included statically.
See:
https://lists.fedoraproject.org/pipermail/ppc/2012-June/001655.html
---
otherlibs/systhreads/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/otherlibs/systhreads/Makefile b/otherlibs/systhreads/Makefile
index 3d3f8fb..fb0ae87 100644
--- a/otherlibs/systhreads/Makefile
+++ b/otherlibs/systhreads/Makefile
@@ -30,7 +30,7 @@ all: libthreads.a threads.cma
allopt: libthreadsnat.a threads.cmxa
libthreads.a: $(BYTECODE_C_OBJS)
- $(MKLIB) -o threads $(BYTECODE_C_OBJS)
+ $(MKLIB) -o threads $(BYTECODE_C_OBJS) -lpthread
st_stubs_b.o: st_stubs.c st_posix.h
$(BYTECC) -O -I../../byterun $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS) \
--
1.7.10.1

View File

@ -1,6 +1,6 @@
Name: ocaml
Version: 4.00.0
Release: 0.6.beta2%{?dist}
Release: 1%{?dist}
Summary: OCaml compiler and programming environment
@ -9,10 +9,11 @@ License: QPL and (LGPLv2+ with exceptions)
URL: http://www.ocaml.org
Source0: http://caml.inria.fr/pub/distrib/ocaml-4.00/ocaml-%{version}+beta2.tar.bz2
Source0: http://caml.inria.fr/pub/distrib/ocaml-4.00/ocaml-%{version}.tar.bz2
# Link to non-beta file was broken on 2012-07-28:
Source1: http://caml.inria.fr/pub/distrib/ocaml-4.00/ocaml-4.00beta-refman-html.tar.gz
Source2: http://caml.inria.fr/pub/distrib/ocaml-4.00/ocaml-4.00beta-refman.pdf
Source3: http://caml.inria.fr/pub/distrib/ocaml-4.00/ocaml-4.00beta-refman.info.tar.gz
Source2: http://caml.inria.fr/pub/distrib/ocaml-4.00/ocaml-4.00-refman.pdf
Source3: http://caml.inria.fr/pub/distrib/ocaml-4.00/ocaml-4.00-refman.info.tar.gz
# IMPORTANT NOTE:
#
@ -32,8 +33,7 @@ Patch0002: 0002-Ensure-empty-compilerlibs-directory-is-created-by-gi.patch
Patch0003: 0003-ocamlbyteinfo-ocamlplugininfo-Useful-utilities-from-.patch
Patch0004: 0004-Don-t-add-rpaths-to-libraries.patch
Patch0005: 0005-configure-Allow-user-defined-C-compiler-flags.patch
Patch0006: 0006-Link-dllthreads.so-with-lpthread-so-that-pthread_atf.patch
Patch0007: 0007-Add-support-for-ppc64.patch
Patch0006: 0006-Add-support-for-ppc64.patch
BuildRequires: ncurses-devel
BuildRequires: gdbm-devel
@ -236,9 +236,9 @@ may not be portable between versions.
%prep
%setup -q -T -b 0 -n %{name}-%{version}+beta2
%setup -q -T -D -a 1 -n %{name}-%{version}+beta2
%setup -q -T -D -a 3 -n %{name}-%{version}+beta2
%setup -q -T -b 0 -n %{name}-%{version}
%setup -q -T -D -a 1 -n %{name}-%{version}
%setup -q -T -D -a 3 -n %{name}-%{version}
cp %{SOURCE2} refman.pdf
git init
@ -523,6 +523,10 @@ fi
%changelog
* Sat Jul 28 2012 Richard W.M. Jones <rjones@redhat.com> - 4.00.0-1
- Upgrade to OCaml 4.00.0 official release.
- Remove one patch (add -lpthread) which went upstream.
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.00.0-0.6.beta2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild

View File

@ -1,4 +1,4 @@
44105cb86be5ab0e82539fb49a2274d9 ocaml-4.00.0+beta2.tar.bz2
4e24c15df07bba220425da67f1a43c31 ocaml-4.00beta-refman-html.tar.gz
91feb3bf47c0420a41fc2796135cb9ad ocaml-4.00beta-refman.info.tar.gz
c9d58f5fdcb455f2d46fe238cc88aaba ocaml-4.00beta-refman.pdf
7b14718e69d84f10e7fb251c7ce0acd2 ocaml-4.00.0.tar.bz2
229d6b00715bf0d004a567bb1c3174a0 ocaml-4.00-refman.info.tar.gz
a9d66274dfb3a7244e725ab8f2b31209 ocaml-4.00-refman.pdf