OCaml 4.08.0 (RHBZ#1673688).

This commit is contained in:
Richard W.M. Jones 2019-06-27 14:50:15 +01:00
parent 1da04a1857
commit 0cadb87d84
7 changed files with 33 additions and 79 deletions

View File

@ -1,4 +1,4 @@
From 16555b698d5f98f475f0e2e3dc617f3fa8060543 Mon Sep 17 00:00:00 2001
From a41ca00e0fe462c09fc6c713351b8215c22e2e3d Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 24 Jun 2014 10:00:15 +0100
Subject: [PATCH 1/5] Don't add rpaths to libraries.
@ -23,5 +23,5 @@ index ee0e0be4c..7c96b6405 100644
> ocamlmklibconfig.ml
--
2.20.1
2.22.0

View File

@ -1,4 +1,4 @@
From 33f5ae7d0549815a1327e75106ce0373a51b5934 Mon Sep 17 00:00:00 2001
From 699314a4643500e1bcfa60cd5dcbf41162c7f461 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 29 May 2012 20:44:18 +0100
Subject: [PATCH 2/5] configure: Allow user defined C compiler flags.
@ -8,10 +8,10 @@ Subject: [PATCH 2/5] configure: Allow user defined C compiler flags.
1 file changed, 4 insertions(+)
diff --git a/configure.ac b/configure.ac
index 0bdb0e580..209a3cb32 100644
index 5bb061162..6e37ff6c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -549,6 +549,10 @@ AS_CASE([$host],
@@ -553,6 +553,10 @@ AS_CASE([$host],
internal_cflags="$gcc_warnings"],
[common_cflags="-O"])])
@ -21,7 +21,7 @@ index 0bdb0e580..209a3cb32 100644
+
internal_cppflags="-DCAML_NAME_SPACE $internal_cppflags"
# Use 64-bit file offset if possible
# Enable SSE2 on x86 mingw to avoid using 80-bit registers.
--
2.20.1
2.22.0

View File

@ -1,4 +1,4 @@
From e1efb51b32683daa4f4fcd08e5de53942da9d1da Mon Sep 17 00:00:00 2001
From 0df3ea4cd00fb364a4bedd3687979ea4385aa827 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Fri, 26 Apr 2019 16:16:29 +0100
Subject: [PATCH 3/5] configure: Remove incorrect assumption about
@ -10,10 +10,10 @@ See https://github.com/ocaml/ocaml/issues/8647#issuecomment-487094390
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 209a3cb32..016449288 100644
index 6e37ff6c0..3c287fbd0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -949,7 +949,7 @@ AS_CASE([$host],
@@ -958,7 +958,7 @@ AS_CASE([$host],
[*-*-mingw32|*-pc-windows], [asppprofflags=''],
[asppprofflags='-DPROFILING'])
@ -23,5 +23,5 @@ index 209a3cb32..016449288 100644
# We first compute default values for as and aspp
# If values have been given by the user then they take precedence over
--
2.20.1
2.22.0

View File

@ -1,4 +1,4 @@
From 482e8c1e992324407ec66a05bfc963a44898a1a4 Mon Sep 17 00:00:00 2001
From 29b180394530ed7f7d24e9d54eafb4475cf44c79 Mon Sep 17 00:00:00 2001
From: Nicolas Ojeda Bar <n.oje.bar@gmail.com>
Date: Fri, 27 Oct 2017 17:05:25 +0200
Subject: [PATCH 4/5] Add RISC-V backend
@ -50,11 +50,11 @@ The following additional commits are included:
asmcomp/riscv/selection.ml | 71 +
config/gnu/config.guess | 925 ++++++-------
config/gnu/config.sub | 2613 ++++++++++++++++++-----------------
configure | 24 +-
configure | 10 +-
configure.ac | 11 +-
runtime/caml/stack.h | 5 +
runtime/riscv.S | 424 ++++++
15 files changed, 3407 insertions(+), 1842 deletions(-)
15 files changed, 3406 insertions(+), 1829 deletions(-)
create mode 100644 asmcomp/riscv/CSE.ml
create mode 100644 asmcomp/riscv/arch.ml
create mode 100644 asmcomp/riscv/emit.mlp
@ -6131,59 +6131,10 @@ index 8b612ab89..3b4c7624b 100755
# time-stamp-format: "%:y-%02m-%02d"
# time-stamp-end: "'"
diff --git a/configure b/configure
index 94754db3d..6bf82fae9 100755
index 4e8ad00a5..1a6bc0a81 100755
--- a/configure
+++ b/configure
@@ -799,7 +799,6 @@ infodir
docdir
oldincludedir
includedir
-runstatedir
localstatedir
sharedstatedir
sysconfdir
@@ -914,7 +913,6 @@ datadir='${datarootdir}'
sysconfdir='${prefix}/etc'
sharedstatedir='${prefix}/com'
localstatedir='${prefix}/var'
-runstatedir='${localstatedir}/run'
includedir='${prefix}/include'
oldincludedir='/usr/include'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
@@ -1167,15 +1165,6 @@ do
| -silent | --silent | --silen | --sile | --sil)
silent=yes ;;
- -runstatedir | --runstatedir | --runstatedi | --runstated \
- | --runstate | --runstat | --runsta | --runst | --runs \
- | --run | --ru | --r)
- ac_prev=runstatedir ;;
- -runstatedir=* | --runstatedir=* | --runstatedi=* | --runstated=* \
- | --runstate=* | --runstat=* | --runsta=* | --runst=* | --runs=* \
- | --run=* | --ru=* | --r=*)
- runstatedir=$ac_optarg ;;
-
-sbindir | --sbindir | --sbindi | --sbind | --sbin | --sbi | --sb)
ac_prev=sbindir ;;
-sbindir=* | --sbindir=* | --sbindi=* | --sbind=* | --sbin=* \
@@ -1313,7 +1302,7 @@ fi
for ac_var in exec_prefix prefix bindir sbindir libexecdir datarootdir \
datadir sysconfdir sharedstatedir localstatedir includedir \
oldincludedir docdir infodir htmldir dvidir pdfdir psdir \
- libdir localedir mandir runstatedir
+ libdir localedir mandir
do
eval ac_val=\$$ac_var
# Remove trailing slashes.
@@ -1466,7 +1455,6 @@ Fine tuning of the installation directories:
--sysconfdir=DIR read-only single-machine data [PREFIX/etc]
--sharedstatedir=DIR modifiable architecture-independent data [PREFIX/com]
--localstatedir=DIR modifiable single-machine data [PREFIX/var]
- --runstatedir=DIR modifiable per-process data [LOCALSTATEDIR/run]
--libdir=DIR object code libraries [EPREFIX/lib]
--includedir=DIR C header files [PREFIX/include]
--oldincludedir=DIR C header files for non-gcc [/usr/include]
@@ -13412,6 +13400,8 @@ fi ;; #(
@@ -13405,6 +13405,8 @@ fi ;; #(
natdynlink=true ;; #(
aarch64-*-linux*) :
natdynlink=true ;; #(
@ -6192,7 +6143,7 @@ index 94754db3d..6bf82fae9 100755
*) :
;;
esac
@@ -13540,7 +13530,11 @@ fi; system=elf ;; #(
@@ -13533,7 +13535,11 @@ fi; system=elf ;; #(
aarch64-*-linux*) :
arch=arm64; system=linux ;; #(
x86_64-*-cygwin*) :
@ -6205,7 +6156,7 @@ index 94754db3d..6bf82fae9 100755
;; #(
*) :
;;
@@ -13796,7 +13790,7 @@ esac ;; #(
@@ -13789,7 +13795,7 @@ esac ;; #(
*,freebsd) :
default_as="${toolpref}as"
default_aspp="${toolpref}cc -c" ;; #(
@ -6215,10 +6166,10 @@ index 94754db3d..6bf82fae9 100755
case $ocaml_cv_cc_vendor in #(
clang-*) :
diff --git a/configure.ac b/configure.ac
index 016449288..d4db21b56 100644
index 3c287fbd0..5731e0f98 100644
--- a/configure.ac
+++ b/configure.ac
@@ -795,7 +795,8 @@ AS_IF([test x"$enable_shared" != "xno"],
@@ -804,7 +804,8 @@ AS_IF([test x"$enable_shared" != "xno"],
[arm*-*-linux*], [natdynlink=true],
[arm*-*-freebsd*], [natdynlink=true],
[earm*-*-netbsd*], [natdynlink=true],
@ -6228,7 +6179,7 @@ index 016449288..d4db21b56 100644
# Try to work around the Skylake/Kaby Lake processor bug.
AS_CASE(["$CC,$host"],
@@ -888,7 +889,11 @@ AS_CASE([$host],
@@ -897,7 +898,11 @@ AS_CASE([$host],
[aarch64-*-linux*],
[arch=arm64; system=linux],
[x86_64-*-cygwin*],
@ -6241,7 +6192,7 @@ index 016449288..d4db21b56 100644
)
AS_IF([test x"$enable_native_compiler" = "xno"],
@@ -998,7 +1003,7 @@ AS_CASE(["$arch,$system"],
@@ -1007,7 +1012,7 @@ AS_CASE(["$arch,$system"],
[*,freebsd],
[default_as="${toolpref}as"
default_aspp="${toolpref}cc -c"],
@ -6697,5 +6648,5 @@ index 000000000..d7e4e2d83
+ .align 3
+ .size caml_system__frametable, .-caml_system__frametable
--
2.20.1
2.22.0

View File

@ -1,4 +1,4 @@
From bdf0d8694e1f3d337a23f340875e0c2bf33766c8 Mon Sep 17 00:00:00 2001
From 2755c4af4689f261fcd99180cbcd764411cbb958 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 5 Jun 2018 19:48:08 +0000
Subject: [PATCH 5/5] riscv: Emit debug info.
@ -36,5 +36,5 @@ index 88ea9f884..cc05aefe4 100644
let lbl_begin = Compilenv.make_symbol (Some "data_begin") in
` {emit_string data_space}\n`;
--
2.20.1
2.22.0

View File

@ -28,7 +28,7 @@
Name: ocaml
Version: 4.08.0
Release: 0.beta3.1%{?dist}
Release: 1%{?dist}
Summary: OCaml compiler and programming environment
@ -36,7 +36,7 @@ License: QPL and (LGPLv2+ with exceptions)
URL: http://www.ocaml.org
Source0: http://caml.inria.fr/pub/distrib/ocaml-4.08/ocaml-%{version}+beta3.tar.xz
Source0: http://caml.inria.fr/pub/distrib/ocaml-4.08/ocaml-%{version}.tar.xz
# IMPORTANT NOTE:
#
@ -47,7 +47,7 @@ Source0: http://caml.inria.fr/pub/distrib/ocaml-4.08/ocaml-%{version}+bet
#
# https://pagure.io/fedora-ocaml
#
# Current branch: fedora-31-4.08.0-beta3
# Current branch: fedora-31-4.08.0
#
# ALTERNATIVELY add a patch to the end of the list (leaving the
# existing patches unchanged) adding a comment to note that it should
@ -176,7 +176,7 @@ may not be portable between versions.
%prep
%setup -q -T -b 0 -n %{name}-%{version}+beta3
%setup -q -T -b 0 -n %{name}-%{version}
%autopatch -p1
# Patches touch configure.ac, so rebuild it:
autoconf --force
@ -379,6 +379,9 @@ find $RPM_BUILD_ROOT \( -name '*.cmt' -o -name '*.cmti' \) -a -delete
%changelog
* Thu Jun 27 2019 Richard W.M. Jones <rjones@redhat.com> - 4.08.0-1
- OCaml 4.08.0 (RHBZ#1673688).
* Fri Apr 26 2019 Richard W.M. Jones <rjones@redhat.com> - 4.08.0-0.beta3.1
- OCaml 4.08.0 beta 3 (RHBZ#1673688).
- emacs subpackage has been dropped (from upstream):

View File

@ -1 +1 @@
SHA512 (ocaml-4.08.0+beta3.tar.xz) = 8d46a1233d791cd7fb19acf3c9a5eeec24a67b709abab0c330c52d1c6704d4acbf531785b8925925ea7b51ecff45b5e151405cb0810be0f1d61e586c6d222392
SHA512 (ocaml-4.08.0.tar.xz) = bd0739b8310f6a0dce17525ea734f3a1d29fec730656ca6fc5cae2dc8a12beca4ac8166a65ab3fa50490d01cc87b99c28eaa3b61d1cde7c30821b41e8d171a53