Add ppx_tools_versioned.diff, fix build.

This commit is contained in:
Andy Li 2019-08-06 21:58:55 +08:00
parent 1e9a808369
commit 23cfead6dc
2 changed files with 19 additions and 1 deletions

View File

@ -1,6 +1,6 @@
Name: ocaml-sedlex
Version: 1.99.4
Release: 6%{?dist}
Release: 7%{?dist}
Summary: Unicode-friendly lexer generator
License: MIT
@ -9,12 +9,15 @@ Source0: https://github.com/alainfrisch/sedlex/archive/v%{version}/%{name
# add -g when calling ocamlopt
Patch0: native_debug.diff
# https://github.com/ocaml-community/sedlex/issues/64
Patch1: ppx_tools_versioned.diff
BuildRequires: ocaml
BuildRequires: ocaml-findlib
BuildRequires: ocaml-ocamldoc
BuildRequires: ocaml-result-devel
BuildRequires: ocaml-migrate-parsetree-devel
BuildRequires: ocaml-ppx-derivers-devel
BuildRequires: ocaml-ppx-tools-versioned-devel
BuildRequires: ocaml-gen-devel
@ -37,6 +40,7 @@ files for developing applications that use %{name}.
%prep
%setup -q -n sedlex-%{version}
%patch0 -p1
%patch1 -p1
# spurious-executable-perm
chmod a-x src/syntax/sedlex_cset.ml
@ -86,6 +90,9 @@ find $RPM_BUILD_ROOT -name '*.{cmxs,opt}' -exec chmod 0755 {} \;
%changelog
* Tue Aug 08 2019 Andy Li <andy@onthewings.net> - 1.99.4-7
- Add ppx_tools_versioned.diff, fix build.
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.99.4-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

11
ppx_tools_versioned.diff Normal file
View File

@ -0,0 +1,11 @@
--- sedlex-1.99.4/src/syntax/Makefile.orig 2018-10-25 07:55:34.821346628 +0000
+++ sedlex-1.99.4/src/syntax/Makefile 2018-10-25 07:58:42.761346628 +0000
@@ -8,7 +8,7 @@
OCAMLC=ocamlfind ocamlc
OCAMLOPT=ocamlfind ocamlopt -g
-PACKAGES=-package ppx_tools_versioned.metaquot_405 -package ocaml-migrate-parsetree
+PACKAGES=-package ppx_tools_versioned.metaquot_405 -package ocaml-migrate-parsetree -package ppx_tools_versioned
OCAMLFLAGS=$(PACKAGES) -linkall -w +A-4-9-42 -annot
all: ppx_sedlex$(EXE) sedlex.cma