Initial import.
This commit is contained in:
parent
2118735872
commit
382cf20cb5
@ -0,0 +1 @@
|
||||
omake-0.9.8.5-3.tar.gz
|
26
ocaml-omake-debian-stdin-stdout-fix.patch
Executable file
26
ocaml-omake-debian-stdin-stdout-fix.patch
Executable file
@ -0,0 +1,26 @@
|
||||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 10_stdin_stdout_fix.dpatch by Mike Furr <mfurr@debian.org>
|
||||
##
|
||||
## All lines beginning with `## DP:' are a description of the patch.
|
||||
## DP: stdin <-> stdout fix (upstream r12115)
|
||||
|
||||
@DPATCH@
|
||||
diff -urNad omake-0.9.8.5~/src/build/omake_rule.ml omake-0.9.8.5/src/build/omake_rule.ml
|
||||
--- omake-0.9.8.5~/src/build/omake_rule.ml 2007-07-02 14:20:23.000000000 -0400
|
||||
+++ omake-0.9.8.5/src/build/omake_rule.ml 2007-09-06 12:52:23.752616976 -0400
|
||||
@@ -1040,12 +1040,12 @@
|
||||
* Evaluate the commands NOW.
|
||||
*)
|
||||
and exec_commands venv pos loc commands =
|
||||
- let stdin = channel_of_var venv pos loc stdin_var in
|
||||
let stdout = channel_of_var venv pos loc stdout_var in
|
||||
- let stdin = Lm_channel.descr stdin in
|
||||
+ let stderr = channel_of_var venv pos loc stderr_var in
|
||||
let stdout = Lm_channel.descr stdout in
|
||||
+ let stderr = Lm_channel.descr stderr in
|
||||
List.iter (fun command ->
|
||||
- let pid = eval_shell_internal stdin stdout command in
|
||||
+ let pid = eval_shell_internal stdout stderr command in
|
||||
let status, _ = eval_shell_wait venv pos pid in
|
||||
let code =
|
||||
match status with
|
91
ocaml-omake.spec
Normal file
91
ocaml-omake.spec
Normal file
@ -0,0 +1,91 @@
|
||||
%define debug_package %{nil}
|
||||
|
||||
Name: ocaml-omake
|
||||
Version: 0.9.8.5
|
||||
Release: 2%{?dist}
|
||||
Summary: OCaml build system with automated dependency analysis
|
||||
|
||||
Group: Development/Tools
|
||||
License: LGPLv2+ with exceptions and GPLv2+ and BSD
|
||||
URL: http://omake.metaprl.org/download.html
|
||||
Source0: http://omake.metaprl.org/downloads/omake-%{version}-3.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Patch0: ocaml-omake-debian-stdin-stdout-fix.patch
|
||||
|
||||
BuildRequires: ocaml >= 3.09.2
|
||||
BuildRequires: ocaml-findlib-devel
|
||||
BuildRequires: gamin-devel
|
||||
BuildRequires: readline-devel
|
||||
BuildRequires: ncurses-devel
|
||||
#BuildRequires: hevea
|
||||
BuildRequires: chrpath
|
||||
|
||||
%define _use_internal_dependency_generator 0
|
||||
%define __find_requires /usr/lib/rpm/ocaml-find-requires.sh
|
||||
%define __find_provides /usr/lib/rpm/ocaml-find-provides.sh
|
||||
|
||||
|
||||
%description
|
||||
OMake is a build system designed for scalability and portability. It
|
||||
uses a syntax similar to make utilities you may have used, but it
|
||||
features many additional enhancements, including the following.
|
||||
|
||||
* Support for projects spanning several directories or directory
|
||||
hierarchies.
|
||||
|
||||
* Fast, reliable, automated, scriptable dependency analysis using MD5
|
||||
digests, with full support for incremental builds.
|
||||
|
||||
* Dependency analysis takes the command lines into account — whenever
|
||||
the command line used to build a target changes, the target is
|
||||
considered out-of-date.
|
||||
|
||||
* Fully scriptable, includes a library that providing support for
|
||||
standard tasks in C, C++, OCaml, and LaTeX projects, or a mixture
|
||||
thereof.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n omake-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
|
||||
%build
|
||||
make all \
|
||||
PREFIX=%{_prefix} MANDIR=%{_mandir} BINDIR=%{_bindir} LIBDIR=%{_libdir}
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make install \
|
||||
INSTALL_ROOT=$RPM_BUILD_ROOT \
|
||||
PREFIX=%{_prefix} MANDIR=%{_mandir} BINDIR=%{_bindir} LIBDIR=%{_libdir}
|
||||
|
||||
chmod 0755 $RPM_BUILD_ROOT%{_bindir}/*
|
||||
strip $RPM_BUILD_ROOT%{_bindir}/omake
|
||||
strip $RPM_BUILD_ROOT%{_bindir}/cvs_realclean
|
||||
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc LICENSE LICENSE.OMake ocamldep/LICENSE.ocamldep-omake
|
||||
%doc CHANGELOG.txt
|
||||
%doc doc/txt/omake-doc.txt doc/ps/omake-doc.pdf doc/html/
|
||||
%{_libdir}/omake/
|
||||
%{_bindir}/ocamldep-omake
|
||||
%{_bindir}/omake
|
||||
%{_bindir}/osh
|
||||
%{_bindir}/cvs_realclean
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Apr 23 2008 Richard W.M. Jones <rjones@redhat.com> - 0.9.8.5-2
|
||||
- Added stdin/stdout fix patch from Debian.
|
||||
|
||||
* Wed Apr 23 2008 Richard W.M. Jones <rjones@redhat.com> - 0.9.8.5-1
|
||||
- Initial RPM release.
|
Loading…
Reference in New Issue
Block a user