Add -autoconf patch for autoconf 2.71 (bz 1943043).

This commit is contained in:
Jerry James 2021-03-29 14:23:20 -06:00
parent 290f58b4dc
commit fa9b80e568
2 changed files with 31 additions and 1 deletions

View File

@ -0,0 +1,25 @@
--- configure.in.orig 2017-08-23 06:49:52.000000000 -0600
+++ configure.in 2021-03-29 14:18:01.847530174 -0600
@@ -29,9 +29,13 @@
# OCAMLWIN32 "yes"/"no" depending on Sys.os_type = "Win32"
# EXE ".exe" if OCAMLWIN32=yes, "" otherwise
+m4_define([ocplib_simplex_VERSION],
+ m4_esyscmd([sed -rn 's/^version:[[:blank:]]*"([^"]*)"/\1/p' opam]))
+AC_INIT([ocplib-simplex], m4_defn([ocplib_simplex_VERSION]))
+
# check for one particular file of the sources
# ADAPT THE FOLLOWING LINE TO YOUR SOURCES!
-AC_INIT(src/core.ml)
+AC_CONFIG_SRCDIR([src/core.ml])
# Check for Ocaml compilers
@@ -137,5 +141,6 @@ AC_SUBST(OCAMLWIN32)
AC_SUBST(EXE)
# Finally create the Makefile.configurable from Makefile.configurable.in
-AC_OUTPUT(Makefile)
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT
chmod a-w Makefile

View File

@ -6,7 +6,7 @@
Name: ocaml-%{pkgname}
Version: 0.4
Release: 21%{?dist}
Release: 22%{?dist}
Summary: Simplex algorithm for solving systems of linear inequalities
# The same exception to clause 6 as provided by ocaml applies to this package.
@ -17,6 +17,8 @@ Source0: %{url}/archive/v%{version}/%{pkgname}-%{version}.tar.gz
Patch0: %{name}-tests.patch
# Upstream patch to fix DESTDIR
Patch1: %{name}-destdir.patch
# Update configure.in for autoconf 2.71
Patch2: %{name}-autoconf.patch
BuildRequires: autoconf
BuildRequires: make
@ -81,6 +83,9 @@ make local-tests
%{_libdir}/ocaml/*/*.mli
%changelog
* Mon Mar 29 2021 Jerry James <loganjerry@gmail.com> - 0.4-22
- Add -autoconf patch for autoconf 2.71 (bz 1943043)
* Mon Mar 1 16:58:01 GMT 2021 Richard W.M. Jones <rjones@redhat.com> - 0.4-21
- OCaml 4.12.0 build