New upstream version 3.5.1.
Rebuild for OCaml 4.00.0.
This commit is contained in:
parent
c9324bd6ba
commit
f11ed3c2a1
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
ocamlnet-2.2.9.tar.gz
|
||||
/ocamlnet-3.4.tar.gz
|
||||
/ocamlnet-3.4.1.tar.gz
|
||||
/ocamlnet-3.5.1.tar.gz
|
||||
|
@ -5,8 +5,8 @@
|
||||
%define __strip /bin/true
|
||||
|
||||
Name: ocaml-ocamlnet
|
||||
Version: 3.4.1
|
||||
Release: 3%{?dist}
|
||||
Version: 3.5.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Network protocols for OCaml
|
||||
|
||||
Group: Development/Libraries
|
||||
@ -28,6 +28,9 @@ BuildRequires: ocaml-labltk-devel
|
||||
|
||||
%global __ocaml_requires_opts -i Asttypes -i Outcometree -i Parsetree
|
||||
|
||||
Patch0: ocamlnet-ocaml-4.patch
|
||||
|
||||
|
||||
%description
|
||||
Ocamlnet is an ongoing effort to collect modules, classes and
|
||||
functions that are useful to implement network protocols. Since
|
||||
@ -106,6 +109,10 @@ files for developing applications that use %{name}-nethttpd.
|
||||
%prep
|
||||
%setup -q -n ocamlnet-%{version}
|
||||
|
||||
%patch0 -p1
|
||||
|
||||
|
||||
%build
|
||||
./configure -enable-tcl -with-nethttpd \
|
||||
-bindir %{_bindir} \
|
||||
-datadir %{_datadir}/%{name} \
|
||||
@ -117,8 +124,6 @@ files for developing applications that use %{name}-nethttpd.
|
||||
# In future:
|
||||
# -with-rpc-auth-dh (requires cryptgps)
|
||||
|
||||
|
||||
%build
|
||||
make all
|
||||
%if %opt
|
||||
make opt
|
||||
@ -224,6 +229,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Jun 09 2012 Richard W.M. Jones <rjones@redhat.com> - 3.5.1-1
|
||||
- New upstream version 3.5.1.
|
||||
- Rebuild for OCaml 4.00.0, plus small patch.
|
||||
- Move configure into build (not prep).
|
||||
|
||||
* Sat Apr 28 2012 Richard W.M. Jones <rjones@redhat.com> - 3.4.1-3
|
||||
- Bump and rebuild against new OCaml compiler in ARM.
|
||||
|
||||
|
24
ocamlnet-ocaml-4.patch
Normal file
24
ocamlnet-ocaml-4.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -ur ocamlnet-3.5.1.old/src/netstring/Makefile.def ocamlnet-3.5.1/src/netstring/Makefile.def
|
||||
--- ocamlnet-3.5.1.old/src/netstring/Makefile.def 2012-02-29 18:02:52.000000000 +0000
|
||||
+++ ocamlnet-3.5.1/src/netstring/Makefile.def 2012-06-09 15:43:13.893064261 +0100
|
||||
@@ -13,7 +13,7 @@
|
||||
PKGNAME = netstring
|
||||
|
||||
REQUIRES = $(REGEXP_PROVIDER) bigarray
|
||||
-INCLUDES += $(INC_NETSYS)
|
||||
+INCLUDES += $(INC_NETSYS) -I +compiler-libs
|
||||
|
||||
ISO_MAPPINGS = mappings/iso*.unimap
|
||||
JP_MAPPINGS = mappings/jis*.*map
|
||||
diff -ur ocamlnet-3.5.1.old/src/netsys/netsys_posix.ml ocamlnet-3.5.1/src/netsys/netsys_posix.ml
|
||||
--- ocamlnet-3.5.1.old/src/netsys/netsys_posix.ml 2012-02-29 18:02:52.000000000 +0000
|
||||
+++ ocamlnet-3.5.1/src/netsys/netsys_posix.ml 2012-06-09 15:40:03.404669934 +0100
|
||||
@@ -704,7 +704,7 @@
|
||||
(* The stubs assume these type definitions: *)
|
||||
type open_flag1 = Unix.open_flag =
|
||||
O_RDONLY | O_WRONLY | O_RDWR | O_NONBLOCK | O_APPEND | O_CREAT | O_TRUNC
|
||||
- | O_EXCL | O_NOCTTY | O_DSYNC | O_SYNC | O_RSYNC
|
||||
+ | O_EXCL | O_NOCTTY | O_DSYNC | O_SYNC | O_RSYNC | O_SHARE_DELETE
|
||||
|
||||
type access_permission1 = Unix.access_permission =
|
||||
R_OK | W_OK | X_OK | F_OK
|
Loading…
Reference in New Issue
Block a user