New upstream version 3.7.3.

- Rebuild for OCaml 4.01.0.
- Enable debuginfo.
- Do not strip binaries, remove anti-prelink protection.
This commit is contained in:
Richard W.M. Jones 2013-09-14 09:27:35 +01:00
parent 063664e449
commit 2ce2932a81
4 changed files with 13 additions and 56 deletions

1
.gitignore vendored
View File

@ -2,3 +2,4 @@ ocamlnet-2.2.9.tar.gz
/ocamlnet-3.4.tar.gz
/ocamlnet-3.4.1.tar.gz
/ocamlnet-3.5.1.tar.gz
/ocamlnet-3.7.3.tar.gz

View File

@ -1,20 +1,14 @@
%define opt %(test -x %{_bindir}/ocamlopt && echo 1 || echo 0)
%define debug_package %{nil}
# Prevent RPM from stripping the binaries.
%define __strip /bin/true
%global opt %(test -x %{_bindir}/ocamlopt && echo 1 || echo 0)
Name: ocaml-ocamlnet
Version: 3.5.1
Release: 6%{?dist}
Version: 3.7.3
Release: 1%{?dist}
Summary: Network protocols for OCaml
Group: Development/Libraries
License: BSD
URL: http://projects.camlcity.org/projects/ocamlnet.html
Source0: http://download.camlcity.org/download/ocamlnet-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
ExcludeArch: sparc64 s390 s390x
BuildRequires: ocaml >= 3.12.1-3
@ -28,8 +22,6 @@ BuildRequires: ocaml-labltk-devel
%global __ocaml_requires_opts -i Asttypes -i Outcometree -i Parsetree
Patch0: ocamlnet-ocaml-4.patch
%description
Ocamlnet is an ongoing effort to collect modules, classes and
@ -65,7 +57,7 @@ In detail, the following features are available:
* netshm provides shared memory for IPC purposes.
* netsys contains bindings for system functions missing in core O'Caml.
* netsys contains bindings for system functions missing in core OCaml.
* smtp and pop are two further client implementations for the SMTP
and POP3 protocols.
@ -109,8 +101,6 @@ files for developing applications that use %{name}-nethttpd.
%prep
%setup -q -n ocamlnet-%{version}
%patch0 -p1
%build
./configure -enable-tcl -with-nethttpd \
@ -130,7 +120,6 @@ make opt
%endif
%install
rm -rf $RPM_BUILD_ROOT
export DESTDIR=$RPM_BUILD_ROOT
export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
mkdir -p $OCAMLFIND_DESTDIR
@ -141,22 +130,8 @@ make install
# be deleted safely. This avoids an rpmlint warning.
rm -f $RPM_BUILD_ROOT%{_libdir}/ocaml/rpc-generator/dummy.mli
# Strip libraries.
strip $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/*.so
# NB. Do NOT strip the binaries and prevent prelink from stripping them too.
# (https://bugzilla.redhat.com/show_bug.cgi?id=435559)
mkdir -p $RPM_BUILD_ROOT/etc/prelink.conf.d
echo -e '-b /usr/bin/netplex-admin\n-b /usr/bin/ocamlrpcgen' \
> $RPM_BUILD_ROOT/etc/prelink.conf.d/ocaml-ocamlnet.conf
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%doc ChangeLog RELNOTES
%{_libdir}/ocaml/equeue
%{_libdir}/ocaml/equeue-gtk2
@ -191,7 +166,6 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/%{name}/
%{_bindir}/netplex-admin
%{_bindir}/ocamlrpcgen
%config(noreplace) /etc/prelink.conf.d/ocaml-ocamlnet.conf
%files devel
@ -229,6 +203,12 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Sat Sep 14 2013 Richard W.M. Jones <rjones@redhat.com> - 3.7.3-1
- New upstream version 3.7.3.
- Rebuild for OCaml 4.01.0.
- Enable debuginfo.
- Do not strip binaries, remove anti-prelink protection.
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.5.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

View File

@ -1,24 +0,0 @@
diff -ur ocamlnet-3.5.1.old/src/netstring/Makefile.def ocamlnet-3.5.1/src/netstring/Makefile.def
--- ocamlnet-3.5.1.old/src/netstring/Makefile.def 2012-02-29 18:02:52.000000000 +0000
+++ ocamlnet-3.5.1/src/netstring/Makefile.def 2012-06-09 15:43:13.893064261 +0100
@@ -13,7 +13,7 @@
PKGNAME = netstring
REQUIRES = $(REGEXP_PROVIDER) bigarray
-INCLUDES += $(INC_NETSYS)
+INCLUDES += $(INC_NETSYS) -I +compiler-libs
ISO_MAPPINGS = mappings/iso*.unimap
JP_MAPPINGS = mappings/jis*.*map
diff -ur ocamlnet-3.5.1.old/src/netsys/netsys_posix.ml ocamlnet-3.5.1/src/netsys/netsys_posix.ml
--- ocamlnet-3.5.1.old/src/netsys/netsys_posix.ml 2012-02-29 18:02:52.000000000 +0000
+++ ocamlnet-3.5.1/src/netsys/netsys_posix.ml 2012-06-09 15:40:03.404669934 +0100
@@ -704,7 +704,7 @@
(* The stubs assume these type definitions: *)
type open_flag1 = Unix.open_flag =
O_RDONLY | O_WRONLY | O_RDWR | O_NONBLOCK | O_APPEND | O_CREAT | O_TRUNC
- | O_EXCL | O_NOCTTY | O_DSYNC | O_SYNC | O_RSYNC
+ | O_EXCL | O_NOCTTY | O_DSYNC | O_SYNC | O_RSYNC | O_SHARE_DELETE
type access_permission1 = Unix.access_permission =
R_OK | W_OK | X_OK | F_OK

View File

@ -1 +1 @@
9f4f474bfe88496220079e06791ff31c ocamlnet-3.5.1.tar.gz
245c7a79474875d3fc7af54b6d963429 ocamlnet-3.7.3.tar.gz