ocaml-num/0001-install-Use-DESTDIR.patch

29 lines
778 B
Diff

From 07639e9179347779ee723cffe50ba3dc7217b65e Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Wed, 8 Nov 2017 22:10:09 +0000
Subject: [PATCH 1/3] install: Use DESTDIR.
---
src/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/Makefile b/src/Makefile
index 97dc074..cff37f8 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -84,9 +84,9 @@ TOINSTALL_STUBS=dllnums.$(SO)
install:
$(OCAMLFIND) install num META
- $(INSTALL_DATA) $(TOINSTALL) $(STDLIBDIR)
+ $(INSTALL_DATA) $(TOINSTALL) $(DESTDIR)$(STDLIBDIR)
ifeq "$(SUPPORTS_SHARED_LIBRARIES)" "true"
- $(INSTALL_DLL) $(TOINSTALL_STUBS) $(STDLIBDIR)/stublibs
+ $(INSTALL_DLL) $(TOINSTALL_STUBS) $(DESTDIR)$(STDLIBDIR)/stublibs
endif
uninstall:
--
2.13.1