New upstream version.

This commit is contained in:
Jerry James 2015-09-19 11:15:49 -06:00
parent aa7abc6fa4
commit c3d85adc4c
4 changed files with 13 additions and 54 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/menhir-20141215.tar.gz
/menhir-20150914.tar.gz

View File

@ -1,33 +0,0 @@
--- a/demos/calc-param/Makefile 2014-12-15 08:25:48.000000000 -0700
+++ b/demos/calc-param/Makefile 2015-01-05 09:31:35.269645018 -0700
@@ -7,7 +7,7 @@ PGFLAGS := --infer
GENERATED := parser.ml parser.mli lexer.ml tokens.ml tokens.mli
MODULES := parser lexer calc
EXECUTABLE := calc
-OCAMLDEPWRAPPER := ../ocamldep.wrapper
+OCAMLDEPWRAPPER := /usr/bin/menhir-ocamldep
include ../Makefile.shared
$(eval $(call menhir_monomodule,tokens,--only-tokens))
$(eval $(call menhir_multimodule,parser,tokens.mly parser.mly,--external-tokens Tokens))
--- a/demos/calc-two/Makefile 2014-12-15 08:25:48.000000000 -0700
+++ b/demos/calc-two/Makefile 2015-01-05 09:31:14.749651303 -0700
@@ -7,7 +7,7 @@ PGFLAGS := --infer
GENERATED := tokens.ml tokens.mli algebraic.ml algebraic.mli reverse.ml reverse.mli lexer.ml
MODULES := algebraic reverse lexer calc
EXECUTABLE := calc
-OCAMLDEPWRAPPER := ../ocamldep.wrapper
+OCAMLDEPWRAPPER := /usr/bin/menhir-ocamldep
include ../Makefile.shared
$(eval $(call menhir_monomodule,tokens,--only-tokens))
$(eval $(call menhir_multimodule,algebraic,tokens.mly algebraic.mly common.mly,--external-tokens Tokens))
--- a/demos/Makefile.shared 2014-12-15 08:25:48.000000000 -0700
+++ b/demos/Makefile.shared 2015-01-05 09:32:05.653628941 -0700
@@ -119,7 +119,7 @@ ifndef OCAMLDEP
endif
ifndef OCAMLDEPWRAPPER
- OCAMLDEPWRAPPER:= ./ocamldep.wrapper
+ OCAMLDEPWRAPPER:= /usr/bin/menhir-ocamldep
endif
ifndef OCAMLLEX

View File

@ -7,16 +7,14 @@
%endif
Name: ocaml-menhir
Version: 20141215
Release: 5%{?dist}
Version: 20150914
Release: 1%{?dist}
Summary: LR(1) parser generator for OCaml
# The generator is QPL, with an exception granted to clause 6c.
License: QPL with exceptions
URL: http://gallium.inria.fr/~fpottier/menhir/
Source0: http://gallium.inria.fr/~fpottier/menhir/menhir-%{version}.tar.gz
# Patch from Scott Tsai to allow demos to build outside of source tree
Patch0: 0001-Makfile-use-menhir-ocamldep-instead-of-ocamldep.wra.patch
BuildRequires: ocaml
BuildRequires: ocaml-findlib
@ -39,7 +37,6 @@ for developing applications that use %{name}.
%prep
%setup -q -n menhir-%{version}
%patch0 -p1
# Fix encodings
for f in AUTHORS menhir.1 src/standard.mly src/*.ml src/*.mli; do
@ -48,35 +45,26 @@ for f in AUTHORS menhir.1 src/standard.mly src/*.ml src/*.mli; do
mv -f $f.fixed $f
done
# Fix a dependency
sed -i.orig "s|/usr/bin/env ocaml|/usr/bin/ocaml|" demos/ocamldep.wrapper
touch -r demos/ocamldep.wrapper.orig demos/ocamldep.wrapper
rm -f demos/ocamldep.wrapper.orig
chmod a+x demos/ocamldep.wrapper
# Enable debuginfo
sed -i 's/-j 0/-cflag -g -lflag -g &/' src/Makefile
# Don't ship version control files
find demos -name .gitignore\* | xargs rm -f
# Do not ship the obsolete demos
rm -fr demos/obsolete
%build
make PREFIX=%{_prefix} TARGET=%{target}
make -C demos clean
%install
export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
export OCAMLFIND_DESTDIR=%{buildroot}%{_libdir}/ocaml
mkdir -p $OCAMLFIND_DESTDIR
make install PREFIX=$RPM_BUILD_ROOT%{_prefix} TARGET=%{target}
rm -fr $RPM_BUILD_ROOT%{_docdir}/menhir
# Install the ocamldep wrapper
mv demos/ocamldep.wrapper $RPM_BUILD_ROOT%{_bindir}/menhir-ocamldep
make install PREFIX=%{buildroot}%{_prefix} TARGET=%{target}
rm -fr %{buildroot}%{_docdir}/menhir
%files
%doc AUTHORS CHANGES manual.pdf demos
%license LICENSE
%{_bindir}/menhir*
%{_bindir}/menhir
%{_mandir}/man1/menhir.1*
%{_datadir}/menhir/
@ -84,6 +72,9 @@ mv demos/ocamldep.wrapper $RPM_BUILD_ROOT%{_bindir}/menhir-ocamldep
%{_libdir}/ocaml/menhirLib/
%changelog
* Sat Sep 19 2015 Jerry James <loganjerry@gmail.com> - 20150914-1
- New upstream version
* Tue Jul 28 2015 Richard W.M. Jones <rjones@redhat.com> - 20141215-5
- OCaml 4.02.3 rebuild.

View File

@ -1 +1 @@
5e1d1ac11364adcfe445cd6e3cbf7fc3 menhir-20141215.tar.gz
a75eb8cef581ea25d1299bc4f59dc348 menhir-20150914.tar.gz