rebuild for ocaml 3.09.3
This commit is contained in:
parent
74acf3bbf9
commit
df3374a7de
@ -1,11 +0,0 @@
|
||||
--- lablgtk-2.4.0/src/ml_panel.c.gcc4 2005-05-10 06:05:10.000000000 -0400
|
||||
+++ lablgtk-2.4.0/src/ml_panel.c 2005-05-10 06:07:36.000000000 -0400
|
||||
@@ -128,7 +128,7 @@
|
||||
static void weak_notify(gpointer data, GObject *applet)
|
||||
{
|
||||
value *glob_root = data;
|
||||
- Pointer_val(*glob_root) = NULL;
|
||||
+ Field(*glob_root, 1) = (long)NULL;
|
||||
ml_global_root_destroy(glob_root);
|
||||
}
|
||||
|
13
lablgtk.spec
13
lablgtk.spec
@ -1,6 +1,8 @@
|
||||
%define ocaml_version 3.09.3
|
||||
|
||||
Name: lablgtk
|
||||
Version: 2.6.0
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
|
||||
Summary: Objective Caml interface to gtk+
|
||||
|
||||
@ -8,9 +10,9 @@ Group: System Environment/Libraries
|
||||
License: LGPL
|
||||
URL: http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgtk.html
|
||||
Source: http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/lablgtk-2.6.0.tar.gz
|
||||
#Patch0: lablgtk-gcc4.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: ocaml >= 3.09.1, camlp4 >= 3.09.1
|
||||
BuildRequires: ocaml = %ocaml_version
|
||||
BuildRequires: camlp4 = %ocaml_version
|
||||
# lablgtk can generate quite extensive documentation.
|
||||
# Probably should enable this and create a subpackage for it.
|
||||
BuildRequires: ocaml-ocamldoc
|
||||
@ -27,7 +29,7 @@ BuildRequires: gtkspell-devel
|
||||
BuildRequires: libXmu-devel
|
||||
BuildRequires: ncurses-devel
|
||||
|
||||
Requires: ocaml >= 3.09.1
|
||||
Requires: ocaml = %ocaml_version
|
||||
Requires: lablgl >= 1.02
|
||||
|
||||
|
||||
@ -96,6 +98,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Dec 2 2006 Gerard Milmeister <gemi@bluewin.ch> - 2.6.0-7
|
||||
- Rebuild for ocaml 3.09.3
|
||||
|
||||
* Tue Aug 29 2006 Gerard Milmeister <gemi@bluewin.ch> - 2.6.0-6
|
||||
- added BR: ncurses-devel
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user