ocaml-dose3/dose-2c1b8df-ounit2.patch

32 lines
1.3 KiB
Diff

diff -ur dose-2c1b8df.old/configure.ac dose-2c1b8df.new/configure.ac
--- dose-2c1b8df.old/configure.ac 2018-04-21 16:28:19.000000000 +0100
+++ dose-2c1b8df.new/configure.ac 2020-02-27 09:42:45.695468700 +0000
@@ -203,11 +203,11 @@
HAS_OUNIT=no)
AC_SUBST(HAS_OUNIT)
if test "$HAS_OUNIT" = "yes" ; then
- AC_CHECK_OCAML_PKG([oUnit])
- if test "$OCAML_PKG_oUnit" = "no"; then
- AC_MSG_ERROR([Please install OCaml findlib module 'oUnit'.])
+ AC_CHECK_OCAML_PKG([ounit2])
+ if test "$OCAML_PKG_ounit2" = "no"; then
+ AC_MSG_ERROR([Please install OCaml findlib module 'ounit2'.])
fi
- PKG_OUNIT="pkg_oUnit"
+ PKG_OUNIT="pkg_ounit2"
fi
AC_ARG_WITH(benchmark,
diff -ur dose-2c1b8df.old/_tags.in dose-2c1b8df.new/_tags.in
--- dose-2c1b8df.old/_tags.in 2018-04-21 16:28:19.000000000 +0100
+++ dose-2c1b8df.new/_tags.in 2020-02-27 09:45:38.324001379 +0000
@@ -11,7 +11,7 @@
<*/*.ml{i,}>: pp(cppo)
<*/*.ml{i,}>: package(extlib), @PKG_CUDF@, package(re.pcre)
-<*/tests.*>: package(oUnit), package(extlib), @PKG_CUDF@, package(re.pcre), package(zip), package(bz2), package(ocamlgraph)
+<*/tests.*>: package(ounit2), package(extlib), @PKG_CUDF@, package(re.pcre), package(zip), package(bz2), package(ocamlgraph)
<common/tests.*>: use_common
<algo/tests.*>: use_common