ocaml-cil/cil-1.3.7-output-obj.patch

15 lines
597 B
Diff

diff -ur cil-1.3.7.orig/Makefile.in cil-1.3.7/Makefile.in
--- cil-1.3.7.orig/Makefile.in 2009-04-24 19:50:33.000000000 +0100
+++ cil-1.3.7/Makefile.in 2009-05-26 15:46:02.932947721 +0100
@@ -287,7 +287,9 @@
ifeq ($(NATIVECAML),1)
$(OBJDIR)/libcil.o: $(OCAML_CIL_LIB_CMODULES:%=$(OBJDIR)/lib%.a) \
$(OCAML_CIL_LIB_MODULES:%=$(OBJDIR)/%.$(CMO))
- ocamlopt -output-obj -o $@ $(CILLY_LIBS:%=%.cmxa) $^
+ ocamlopt -output-obj -o tmpcil.o $(CILLY_LIBS:%=%.cmxa) $^
+ ar rcs $@ tmpcil.o
+ rm -f tmpcil.o
else
$(OBJDIR)/libcil.o:
@echo "Can only build $@ when NATIVECAML is 1."