Patch to fix stricter -output-obj checks in OCaml 3.11.0.

This commit is contained in:
Richard W.M. Jones 2008-12-05 17:14:25 +00:00
parent 5d71221a53
commit ba170b71d9
2 changed files with 20 additions and 1 deletions

View File

@ -0,0 +1,13 @@
--- cil.orig/Makefile.in 2007-02-05 21:10:29.000000000 +0000
+++ cil/Makefile.in 2008-12-05 17:03:59.000000000 +0000
@@ -273,7 +273,9 @@
ifeq ($(NATIVECAML),1)
$(OBJDIR)/libcil.a: $(OCAML_CIL_LIB_CMODULES:%=$(OBJDIR)/lib%.a) \
$(OCAML_CIL_LIB_MODULES:%=$(OBJDIR)/%.$(CMO))
- ocamlopt -output-obj -o $@ $(CILLY_LIBS:%=%.cmxa) $^
+ ocamlopt -output-obj -o tmpcil.o $(CILLY_LIBS:%=%.cmxa) $^
+ ar rcs $@ tmpcil.o
+ rm -f tmpcil.o
else
$(OBJDIR)/libcil.a:
@echo "Can only build $@ when NATIVECAML is 1."

View File

@ -6,7 +6,7 @@
Name: ocaml-cil
Version: 1.3.6
Release: 8%{?dist}
Release: 9%{?dist}
Summary: CIL - Infrastructure for C Program Analysis and Transformation
Group: Development/Libraries
@ -17,6 +17,8 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
ExcludeArch: ppc64
ExcludeArch: ppc
Patch0: cil-1.3.6-output-obj.patch
BuildRequires: ocaml, ocaml-findlib-devel, ocaml-ocamldoc
%define _use_internal_dependency_generator 0
@ -87,6 +89,7 @@ for gcc.
%prep
%setup -q -n cil
%patch0 -p1
./configure --libdir=%{_libdir}
@ -190,6 +193,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Fri Dec 5 2008 Richard W.M. Jones <rjones@redhat.com> - 1.3.6-9
- Patch to fix stricter -output-obj checks in OCaml 3.11.0.
* Wed Nov 19 2008 Richard W.M. Jones <rjones@redhat.com> - 1.3.6-8
- Rebuild for OCaml 3.11.0