New upstream version 8.00.

This commit is contained in:
Richard W.M. Jones 2021-02-28 22:36:18 +00:00
parent 5fcfb0274d
commit 979f8b676d
6 changed files with 70 additions and 32 deletions

1
.gitignore vendored
View File

@ -9,3 +9,4 @@
/rel710.tar.gz
/rel711.tar.gz
/rel712.tar.gz
/rel8.00.tar.gz

View File

@ -0,0 +1,36 @@
From 2865ecfe5e02f8895c555396993b49b3b08a3550 Mon Sep 17 00:00:00 2001
From: Chet Murthy <chetsky@gmail.com>
Date: Fri, 15 Jan 2021 12:35:50 -0800
Subject: [PATCH] fix META file generation (DESTDIR) issue; Fix #75
---
Makefile | 2 +-
etc/Makefile | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index c9adcc46..7748ddd6 100644
--- a/Makefile
+++ b/Makefile
@@ -51,7 +51,7 @@ depend:
local-install::
$(RM) -rf local-install && mkdir -p local-install/lib/ocaml
- $(MAKE) DESTDIR=`pwd`/local-install/ LIBDIR=lib BINDIR=bin MANDIR=man install
+ $(MAKE) DESTDIR= LIBDIR=`pwd`/local-install/lib BINDIR=`pwd`/local-install/bin MANDIR=man install
install:
$(NOVERBOSE) if test -z "$(LIBDIR)"; then \
diff --git a/etc/Makefile b/etc/Makefile
index ef4593cc..f8913866 100644
--- a/etc/Makefile
+++ b/etc/Makefile
@@ -106,7 +106,7 @@ install:
-$(MKDIR) "$(DESTDIR)$(LIBDIR)/$(CAMLP5N)" "$(DESTDIR)$(BINDIR)"
$(RM) -f "$(DESTDIR)$(LIBDIR)/$(CAMLP5N)/pa_lex.cmo"
cp $(OBJS) $(INSTALL_CMI) "$(DESTDIR)$(LIBDIR)/$(CAMLP5N)/."
- sed -e "s|@VERSION@|$(VERSION)|" -e "s|@CAMLP5DIR@|$(DESTDIR)$(LIBDIR)/$(CAMLP5N)|" META.tpl > META
+ sed -e "s|@VERSION@|$(VERSION)|" -e "s|@CAMLP5DIR@|$(LIBDIR)/$(CAMLP5N)|" META.tpl > META
cp META "$(DESTDIR)$(LIBDIR)/$(CAMLP5N)/."
cp lib.sml "$(DESTDIR)$(LIBDIR)/$(CAMLP5N)/."
cp $(CAMLP5N)o$(EXE) $(CAMLP5N)sch$(EXE) "$(DESTDIR)$(BINDIR)/."

View File

@ -1,15 +0,0 @@
--- camlp5-6.11/configure.old 2014-08-24 09:49:01.887731189 +0100
+++ camlp5-6.11/configure 2014-08-24 09:50:19.043742759 +0100
@@ -246,11 +246,7 @@
OCAMLC_W_Y=""
fi
-if [ "$($ocamlc -warn-error A 2>&1)" = "" ]; then
- WARNERR="-warn-error A"
-else
- WARNERR=""
-fi
+WARNERR=""
if make -f config/Makefile.check --no-print-directory >/dev/null 2>&1; then
NO_PR_DIR=--no-print-directory

View File

@ -0,0 +1,15 @@
--- camlp5-rel8.00.old/configure 2020-12-27 22:26:24.000000000 +0000
+++ camlp5-rel8.00/configure 2021-02-28 22:38:08.341646880 +0000
@@ -243,11 +243,7 @@
OCAMLC_W_Y=""
fi
-if [ "$($ocamlc -warn-error +A-11 2>&1)" = "" ]; then
- WARNERR="-warn-error +A-11"
-else
- WARNERR=""
-fi
+WARNERR=""
if make -f config/Makefile.check --no-print-directory >/dev/null 2>&1; then
NO_PR_DIR=--no-print-directory

View File

@ -3,21 +3,25 @@
%global debug_package %{nil}
%endif
%global major 7
%global minor 12
%global major 8
%global minor 00
Name: ocaml-camlp5
Version: %{major}.%{minor}
Release: 11%{?dist}
Release: 1%{?dist}
Summary: Classical version of camlp4 OCaml preprocessor
License: BSD
URL: https://camlp5.github.io/
Source0: https://github.com/camlp5/camlp5/archive/rel%{major}%{minor}.tar.gz
Source0: https://github.com/camlp5/camlp5/archive/rel%{major}.%{minor}.tar.gz
# Kill -warn-error A
Patch0: camlp5-6.11-kill-warn-error.patch
Patch0: camlp5-8.00-kill-warn-error.patch
# https://github.com/camlp5/camlp5/issues/75
# Upstream in > 8.00.
Patch1: 2865ecfe5e02f8895c555396993b49b3b08a3550.patch
BuildRequires: make
BuildRequires: ocaml
@ -47,18 +51,10 @@ developing applications that use %{name}.
%prep
%setup -q -n camlp5-rel%{major}%{minor}
%setup -q -n camlp5-rel%{major}.%{minor}
%autopatch -p1
find . -name .gitignore -delete
# Fix to build with 4.11.1.
pushd ocaml_stuff
ln -s 4.11.0 4.11.1
popd
pushd ocaml_src/lib/versdep
ln -s 4.11.0.ml 4.11.1.ml
popd
# Build with debug information
sed -i 's,WARNERR="",WARNERR="-g",' configure
sed -i 's,-linkall,& -g,g' top/Makefile
@ -79,7 +75,6 @@ make %{_smp_mflags} world.opt
%else
make %{_smp_mflags} world
%endif
make -C doc/htmlp -j1
%install
mkdir -p $RPM_BUILD_ROOT%{_libdir}/ocaml
@ -91,6 +86,10 @@ mkdir -p $RPM_BUILD_ROOT%{_mandir}
make install DESTDIR=$RPM_BUILD_ROOT
cp -p etc/META $RPM_BUILD_ROOT%{_libdir}/ocaml/camlp5
rm -f doc/htmlp/{*.sh,Makefile,html2*}
pushd $RPM_BUILD_ROOT%{_libdir}/ocaml
mv ocaml/topfind.camlp5 .
rmdir ocaml
popd
%files
@ -103,6 +102,7 @@ rm -f doc/htmlp/{*.sh,Makefile,html2*}
%exclude %{_libdir}/ocaml/camlp5/*.cmx
%endif
%exclude %{_libdir}/ocaml/camlp5/*.mli
%{_libdir}/ocaml/topfind.camlp5
%files devel
@ -120,7 +120,8 @@ rm -f doc/htmlp/{*.sh,Makefile,html2*}
%changelog
* Sun Feb 28 22:24:15 GMT 2021 Richard W.M. Jones <rjones@redhat.com> - 7.12-11
* Sun Feb 28 22:24:15 GMT 2021 Richard W.M. Jones <rjones@redhat.com> - 8.00-1
- New upstream version 8.00.
- OCaml 4.12.0 build
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 7.12-10

View File

@ -1 +1 @@
SHA512 (rel712.tar.gz) = 233d973b0a968a7812b977e8a37da8e8daa0f3ef81ca7c473d83c1602380dae6c14f94daffb6bb799f8d90fab121238a46e89a233202cd6f622b0da2f728c0c0
SHA512 (rel8.00.tar.gz) = 6a0d19ced4d94cd3afebfbc373d344229c5faf088e8910dea32ed4dfa841dd9844c72849f8a6281e2bce55295665eae90391cf29d062a44b083761a9e04bce93