New upstream version 1.08.

This commit is contained in:
Richard W.M. Jones 2020-05-20 11:41:04 +01:00
parent a7f3cbd864
commit 6887343913
7 changed files with 117 additions and 172 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
camlidl-1.05.doc.pdf
camlidl-1.05.tar.gz
/camlidl108.tar.gz

View File

@ -0,0 +1,66 @@
From 6b8f1390855e3591a74c4716a06a070a23bae150 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Wed, 20 May 2020 11:31:24 +0100
Subject: [PATCH 1/2] Allow destdir installs.
make DESTDIR=/tmp/foo install
You still need to create the directory structure under the destdir, so
this is not quite a true destdir install, but good enough for Fedora
builds.
---
compiler/Makefile | 2 +-
lib/Makefile | 4 ++--
runtime/Makefile.unix | 8 ++++----
3 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/compiler/Makefile b/compiler/Makefile
index d756fba..2e402bc 100644
--- a/compiler/Makefile
+++ b/compiler/Makefile
@@ -82,7 +82,7 @@ beforedepend:: linenum.ml
# Install
install:
- cp $(PROG) $(BINDIR)
+ cp $(PROG) $(DESTDIR)$(BINDIR)
# Clean up
clean::
diff --git a/lib/Makefile b/lib/Makefile
index 5048be6..181be01 100644
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -29,8 +29,8 @@ $(NATIVELIB): $(NATIVEOBJS)
$(OCAMLOPT) -a -o $(NATIVELIB) -cclib -lcamlidl $(NATIVEOBJS)
install:
- cp $(INTERFACES) $(BYTELIB) $(NATIVELIB) $(NATIVELIB:.cmxa=.$(LIBEXT)) $(OCAMLLIB)
- cd $(OCAMLLIB); $(RANLIB) $(NATIVELIB:.cmxa=.$(LIBEXT))
+ cp $(INTERFACES) $(BYTELIB) $(NATIVELIB) $(NATIVELIB:.cmxa=.$(LIBEXT)) $(DESTDIR)$(OCAMLLIB)
+ cd $(DESTDIR)$(OCAMLLIB); $(RANLIB) $(NATIVELIB:.cmxa=.$(LIBEXT))
.SUFFIXES: .mli .ml .cmi .cmo .cmx
diff --git a/runtime/Makefile.unix b/runtime/Makefile.unix
index d51d6bb..6ee4812 100644
--- a/runtime/Makefile.unix
+++ b/runtime/Makefile.unix
@@ -26,10 +26,10 @@ dllcamlidl.so libcamlidl.a: $(OBJS)
# $(RANLIB) $@
install:
- cp camlidlruntime.h $(OCAMLLIB)/caml/camlidlruntime.h
- cp libcamlidl.a $(OCAMLLIB)/libcamlidl.a
- cp dllcamlidl.so $(OCAMLLIB)/stublibs/dllcamlidl.so
- cd $(OCAMLLIB); $(RANLIB) libcamlidl.a
+ cp camlidlruntime.h $(DESTDIR)$(OCAMLLIB)/caml/camlidlruntime.h
+ cp libcamlidl.a $(DESTDIR)$(OCAMLLIB)/libcamlidl.a
+ cp dllcamlidl.so $(DESTDIR)$(OCAMLLIB)/stublibs/dllcamlidl.so
+ cd $(DESTDIR)$(OCAMLLIB); $(RANLIB) libcamlidl.a
clean:
rm -f *.a *.o *.so
--
2.26.2

View File

@ -0,0 +1,25 @@
From be04b106f9af418fc623f44477569e74d61cf6a7 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Wed, 20 May 2020 11:32:50 +0100
Subject: [PATCH 2/2] Pass -g option to ocamlmklib.
---
runtime/Makefile.unix | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/runtime/Makefile.unix b/runtime/Makefile.unix
index 6ee4812..039e085 100644
--- a/runtime/Makefile.unix
+++ b/runtime/Makefile.unix
@@ -18,7 +18,7 @@ all: dllcamlidl.so libcamlidl.a
dllcamlidl.so libcamlidl.a: $(OBJS)
- rm -f $@
- ocamlmklib -o camlidl $(OBJS)
+ ocamlmklib -g -o camlidl $(OBJS)
#libcamlidl.a: $(OBJS)
# - rm -f $@
--
2.26.2

View File

@ -1,109 +0,0 @@
diff -ur camlidl-1.05.old/compiler/Makefile camlidl-1.05.byte/compiler/Makefile
--- camlidl-1.05.old/compiler/Makefile 2015-07-20 15:16:31.848993427 +0100
+++ camlidl-1.05.byte/compiler/Makefile 2015-07-20 15:22:59.352428185 +0100
@@ -32,6 +32,9 @@
$(PROG): $(XOBJS)
$(OCAMLOPT) -o $(PROG) $(XOBJS)
+byte: $(OBJS)
+ $(OCAMLC) -o $(PROG) $(OBJS)
+
clean::
rm -f $(PROG)
@@ -85,6 +88,8 @@
install:
cp $(PROG) $(BINDIR)
+install-byte: install
+
# Clean up
clean::
rm -f *.cm[iox] *~
diff -ur camlidl-1.05.old/lib/Makefile camlidl-1.05.byte/lib/Makefile
--- camlidl-1.05.old/lib/Makefile 2002-04-22 12:50:47.000000000 +0100
+++ camlidl-1.05.byte/lib/Makefile 2015-07-20 15:32:15.716052397 +0100
@@ -22,6 +22,8 @@
all: $(BYTELIB) $(NATIVELIB)
+byte: $(BYTELIB)
+
$(BYTELIB): $(BYTEOBJS)
$(OCAMLC) -a -o $(BYTELIB) $(BYTEOBJS)
@@ -32,6 +34,9 @@
cp $(INTERFACES) $(BYTELIB) $(NATIVELIB) $(NATIVELIB:.cmxa=.$(LIBEXT)) $(OCAMLLIB)
cd $(OCAMLLIB); $(RANLIB) $(NATIVELIB:.cmxa=.$(LIBEXT))
+install-byte:
+ cp $(INTERFACES) $(BYTELIB) $(OCAMLLIB)
+
.SUFFIXES: .mli .ml .cmi .cmo .cmx
.mli.cmi:
diff -ur camlidl-1.05.old/Makefile camlidl-1.05.byte/Makefile
--- camlidl-1.05.old/Makefile 2000-08-19 12:04:55.000000000 +0100
+++ camlidl-1.05.byte/Makefile 2015-07-20 15:24:37.154537915 +0100
@@ -20,12 +20,24 @@
cd lib; $(MAKE) all
cd tools; $(MAKE) all
+byte:
+ cd compiler; $(MAKE) byte
+ cd runtime; $(MAKE) byte
+ cd lib; $(MAKE) byte
+ cd tools; $(MAKE) byte
+
install:
cd compiler; $(MAKE) install
cd runtime; $(MAKE) install
cd lib; $(MAKE) install
cd tools; $(MAKE) install
+install-byte:
+ cd compiler; $(MAKE) install-byte
+ cd runtime; $(MAKE) install-byte
+ cd lib; $(MAKE) install-byte
+ cd tools; $(MAKE) install-byte
+
clean:
cd compiler; $(MAKE) clean
cd runtime; $(MAKE) clean
diff -ur camlidl-1.05.old/runtime/Makefile.unix camlidl-1.05.byte/runtime/Makefile.unix
--- camlidl-1.05.old/runtime/Makefile.unix 2000-08-19 12:05:00.000000000 +0100
+++ camlidl-1.05.byte/runtime/Makefile.unix 2015-07-20 15:26:23.065656741 +0100
@@ -16,6 +16,8 @@
all: libcamlidl.a
+byte: all
+
libcamlidl.a: $(OBJS)
- rm -f $@
ar rc $@ $(OBJS)
@@ -26,6 +28,8 @@
cp libcamlidl.a $(OCAMLLIB)/libcamlidl.a
cd $(OCAMLLIB); $(RANLIB) libcamlidl.a
+install-byte: install
+
clean:
rm -f *.a *.o
diff -ur camlidl-1.05.old/tools/Makefile.unix camlidl-1.05.byte/tools/Makefile.unix
--- camlidl-1.05.old/tools/Makefile.unix 2000-08-19 12:05:00.000000000 +0100
+++ camlidl-1.05.byte/tools/Makefile.unix 2015-07-20 15:26:01.051632043 +0100
@@ -14,8 +14,12 @@
all:
+byte:
+
install:
+install-byte:
+
clean:
depend:

View File

@ -1,19 +0,0 @@
--- camlidl-1.05/compiler/Makefile.old 2013-09-14 14:32:50.438355603 +0100
+++ camlidl-1.05/compiler/Makefile 2013-09-14 14:33:08.542375602 +0100
@@ -23,13 +23,14 @@
linenum.cmo parse_aux.cmo parser_midl.cmo lexer_midl.cmo parse.cmo \
fixlabels.cmo normalize.cmo \
main.cmo
+XOBJS=$(OBJS:.cmo=.cmx)
PROG=camlidl$(EXE)
all: $(PROG)
-$(PROG): $(OBJS)
- $(OCAMLC) -o $(PROG) $(OBJS)
+$(PROG): $(XOBJS)
+ $(OCAMLOPT) -o $(PROG) $(XOBJS)
clean::
rm -f $(PROG)

View File

@ -1,25 +1,26 @@
%global opt %(test -x %{_bindir}/ocamlopt && echo 1 || echo 0)
%if ! %opt
%global debug_package %{nil}
%endif
%global shortversion 108
Name: ocaml-camlidl
Version: 1.05
Release: 64%{?dist}
Version: 1.08
Release: 1%{?dist}
Summary: Stub code generator and COM binding for Objective Caml
License: QPL and LGPLv2 with exceptions
URL: http://caml.inria.fr/pub/old_caml_site/camlidl/
Source0: http://caml.inria.fr/pub/old_caml_site/distrib/bazar-ocaml/camlidl-%{version}.tar.gz
Source1: http://caml.inria.fr/pub/old_caml_site/distrib/bazar-ocaml/camlidl-%{version}.doc.pdf
Source0: https://github.com/xavierleroy/camlidl/archive/camlidl%{shortversion}.tar.gz
# This is the latest prebuilt documentation available.
# Actually building the documentation requires many TeX tools.
Source1: http://caml.inria.fr/pub/old_caml_site/distrib/bazar-ocaml/camlidl-1.05.doc.pdf
# META file from Debian (RHBZ#1026991).
Source2: META.camlidl.in
# Build the compiler into a native code program using ocamlopt.
Patch1: camlidl-1.05-use-ocamlopt-for-compiler.patch
# Add 'make byte' and 'make install-byte' targets.
Patch2: camlidl-1.05-bytecode.patch
# Both patches sent upstream on 2020-05-20.
# Allow destdir installs.
Patch1: 0001-Allow-destdir-installs.patch
# Pass -g option to ocamlmklib.
Patch2: 0002-Pass-g-option-to-ocamlmklib.patch
BuildRequires: ocaml
BuildRequires: ocaml-ocamldoc
@ -53,13 +54,11 @@ developing applications that use %{name}.
%prep
%setup -q -n camlidl-%{version}
%patch1 -p1
%patch2 -p1
%autosetup -n camlidl-camlidl%{shortversion} -p1
sed -e 's|^OCAMLLIB=.*|OCAMLLIB=%{_libdir}/ocaml|' \
-e 's|^BINDIR=.*|BINDIR=%{_bindir}|' \
-e 's|^CFLAGS=.*|CFLAGS=%{optflags}|' \
%if %opt
-e 's|^OCAMLC=.*|OCAMLC=ocamlc.opt -g|' \
-e 's|^OCAMLOPT=.*|OCAMLOPT=ocamlopt.opt -g|' \
@ -67,28 +66,12 @@ sed -e 's|^OCAMLLIB=.*|OCAMLLIB=%{_libdir}/ocaml|' \
< config/Makefile.unix \
> config/Makefile
%if %opt
# compiler/ contains a module called 'Array' which conflicts with the
# OCaml stdlib module (although only when using ocamlopt for some
# reason).
mv compiler/array.ml compiler/idlarray.ml
mv compiler/array.mli compiler/idlarray.mli
perl -pi.bak -e 's/array/idlarray/g' \
compiler/Makefile compiler/.depend
perl -pi.bak -e 's/Array(?!\d)/Idlarray/g' \
compiler/*.ml
%endif
cp %{SOURCE1} .
%build
%if %opt
make all
%else
make byte
%endif
# Parallel builds will fail.
make
%install
@ -100,13 +83,7 @@ mkdir -p $RPM_BUILD_ROOT/%{_bindir}
# Install META file (RHBZ#1026991).
sed 's/@VERSION@/%{version}/' < %{SOURCE2} > $RPM_BUILD_ROOT/%{_libdir}/ocaml/META.camlidl
make OCAMLLIB=$RPM_BUILD_ROOT/%{_libdir}/ocaml \
BINDIR=$RPM_BUILD_ROOT/%{_bindir} \
%if %opt
install
%else
install-byte
%endif
make DESTDIR=$RPM_BUILD_ROOT install
%files
@ -116,11 +93,12 @@ make OCAMLLIB=$RPM_BUILD_ROOT/%{_libdir}/ocaml \
%exclude %{_libdir}/ocaml/*.a
%exclude %{_libdir}/ocaml/*.cmxa
%endif
%{_libdir}/ocaml/stublibs/*.so
%{_bindir}/camlidl
%files devel
%doc LICENSE README Changes camlidl-%{version}.doc.pdf tests
%doc LICENSE README Changes camlidl-1.05.doc.pdf tests
%if %opt
%{_libdir}/ocaml/*.a
%{_libdir}/ocaml/*.cmxa
@ -129,6 +107,9 @@ make OCAMLLIB=$RPM_BUILD_ROOT/%{_libdir}/ocaml \
%changelog
* Wed May 20 2020 Richard W.M. Jones <rjones@redhat.com> - 1.08-1
- New upstream version 1.08.
* Mon May 04 2020 Richard W.M. Jones <rjones@redhat.com> - 1.05-64
- OCaml 4.11.0+dev2-2020-04-22 rebuild

View File

@ -1,2 +1,2 @@
38cfda1efdab331acdb980d204e60268 camlidl-1.05.doc.pdf
4cfb863bc3cbdc1af2502042c45cc675 camlidl-1.05.tar.gz
SHA512 (camlidl108.tar.gz) = 1d63789d7ce36633632690b8cebc86accac422eec2ea6f85efd1968be7f5f695b17ce86c63d2ae77e4bf19a8b9300073f2ec94ca033d3ddc792af0e76f84a80f
SHA512 (camlidl-1.05.doc.pdf) = 4748c8c538271247a893337b8d336741f11d74cbbbfbdc57510dfb2cf4986e8e5fb34b0e2e2fc04de87819c34b37e079fd5efe58cc01c8240c2af775500a0679