Rebuild for OCaml 4.01.0.

- Enable debuginfo.
- Modernize the spec file.
This commit is contained in:
Richard W.M. Jones 2013-09-14 14:49:01 +01:00
parent 8aa4eddc90
commit 4f909ea2f2
2 changed files with 24 additions and 17 deletions

View File

@ -0,0 +1,14 @@
--- ocaml-cairo-1.2.0/Makefile.rules~ 2011-09-11 16:09:06.000000000 +0100
+++ ocaml-cairo-1.2.0/Makefile.rules 2013-09-14 14:51:18.682632883 +0100
@@ -1,8 +1,8 @@
%.cmo : %.ml
- $(OCAMLC) -c $(INCFLAGS) $<
+ $(OCAMLC) -g -c $(INCFLAGS) $<
%.cmx : %.ml
- $(OCAMLOPT) -c $(INCFLAGS) $<
+ $(OCAMLOPT) -g -c $(INCFLAGS) $<
%.cmi : %.mli
- $(OCAMLC) $(INCFLAGS) $<
+ $(OCAMLC) -g $(INCFLAGS) $<
%.o : %.c
$(OCAMLC) -ccopt "$(CPPFLAGS)" $<

View File

@ -1,5 +1,4 @@
%global opt %(test -x %{_bindir}/ocamlopt && echo 1 || echo 0)
%global debug_package %{nil}
# Important note! There are at least two quite separate OCaml cairo
# projects. This one is: http://cairographics.org/cairo-ocaml/
@ -17,19 +16,19 @@
Name: ocaml-cairo
Epoch: 1
Version: 1.2.0
Release: 0.10.git%{commit}%{?dist}
Release: 0.11.git%{commit}%{?dist}
Summary: OCaml library for accessing cairo graphics
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
ExcludeArch: sparc64 s390 s390x
Group: Development/Libraries
License: LGPLv2
URL: http://cairographics.org/cairo-ocaml/
Source0: ocaml-cairo-%{version}-git%{commit}.tar.gz
Source1: ocaml-cairo-META
Patch1: ocaml-cairo-1.2.0-enable-ocamlopt-debug.patch
BuildRequires: ocaml >= 3.10.0
BuildRequires: ocaml-findlib-devel
BuildRequires: ocaml-ocamldoc
@ -39,10 +38,6 @@ BuildRequires: automake
BuildRequires: gtk2-devel
BuildRequires: chrpath
%define _use_internal_dependency_generator 0
%define __find_requires /usr/lib/rpm/ocaml-find-requires.sh
%define __find_provides /usr/lib/rpm/ocaml-find-provides.sh
%description
Cairo is a multi-platform library providing anti-aliased vector-based
@ -61,7 +56,6 @@ PDF 1.4.
%package devel
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name} = %{epoch}:%{version}-%{release}
Requires: ocaml-lablgtk-devel
@ -74,6 +68,8 @@ developing applications that use %{name}.
%prep
%setup -q
%patch1 -p1
aclocal -I support
autoconf
./configure --libdir=%{_libdir}
@ -86,23 +82,16 @@ make doc
%install
rm -rf $RPM_BUILD_ROOT
export DESTDIR=$RPM_BUILD_ROOT
export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
mkdir -p $OCAMLFIND_DESTDIR $OCAMLFIND_DESTDIR/stublibs
ocamlfind install cairo src/{*.mli,*.cmi,*.cma,*.a,*.cmxa,*.cmx,dll*.so} META
strip $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dll*.so
chrpath --delete $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dll*.so
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%doc COPYING
%{_libdir}/ocaml/cairo
%if %opt
@ -116,7 +105,6 @@ rm -rf $RPM_BUILD_ROOT
%files devel
%defattr(-,root,root,-)
%doc COPYING ChangeLog README doc/html
%if %opt
%{_libdir}/ocaml/cairo/*.a
@ -127,6 +115,11 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Sat Sep 14 2013 Richard W.M. Jones <rjones@redhat.com> - 1:1.2.0-0.11.git08b40192975
- Rebuild for OCaml 4.01.0.
- Enable debuginfo.
- Modernize the spec file.
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.2.0-0.10.git08b40192975
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild