nuspell/nuspell-dllver.patch
2022-09-13 10:56:07 +02:00

30 lines
1.0 KiB
Diff

diff -rupN --no-dereference nuspell-5.1.1/src/nuspell/CMakeLists.txt nuspell-5.1.1-new/src/nuspell/CMakeLists.txt
--- nuspell-5.1.1/src/nuspell/CMakeLists.txt 2022-09-09 16:03:49.000000000 +0200
+++ nuspell-5.1.1-new/src/nuspell/CMakeLists.txt 2022-09-13 10:47:19.390834569 +0200
@@ -22,6 +22,10 @@ set_target_properties(nuspell PROPERTIES
SOVERSION ${PROJECT_VERSION_MAJOR}
CXX_VISIBILITY_PRESET hidden)
+if(MINGW)
+ set_target_properties(nuspell PROPERTIES SUFFIX "-${PROJECT_VERSION_MAJOR}${CMAKE_SHARED_LIBRARY_SUFFIX}")
+endif(MINGW)
+
target_compile_features(nuspell PUBLIC cxx_std_17)
target_include_directories(nuspell
diff -rupN --no-dereference nuspell-5.1.1/tests/suggestiontest/Makefile.orig nuspell-5.1.1-new/tests/suggestiontest/Makefile.orig
--- nuspell-5.1.1/tests/suggestiontest/Makefile.orig 2022-09-09 16:03:49.000000000 +0200
+++ nuspell-5.1.1-new/tests/suggestiontest/Makefile.orig 1970-01-01 01:00:00.000000000 +0100
@@ -1,11 +0,0 @@
-all:
- ./prepare
- ./test
-
-single:
- ./prepare2
- ./test
-
-clean:
- rm *.[1-5] result.*
-