Update to latest version.
This commit is contained in:
parent
b663cd224a
commit
a8d8b77e87
1
.gitignore
vendored
1
.gitignore
vendored
@ -56,3 +56,4 @@ numpy-1.4.1.tar.gz
|
|||||||
/numpy-html-1.14.5.zip
|
/numpy-html-1.14.5.zip
|
||||||
/numpy-1.15.0.tar.gz
|
/numpy-1.15.0.tar.gz
|
||||||
/numpy-html-1.15.0.zip
|
/numpy-html-1.15.0.zip
|
||||||
|
/numpy-1.15.1.tar.gz
|
||||||
|
@ -1,40 +0,0 @@
|
|||||||
From ec843c7008b3d89e6f6023b88ac0f1d02e39be17 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
|
||||||
Date: Sat, 11 Aug 2018 02:45:01 -0400
|
|
||||||
Subject: [PATCH] BUG: Fix undefined functions on big-endian systems.
|
|
||||||
|
|
||||||
Both these functions are used by `Dragon4_PrintFloat_IEEE_binary128`,
|
|
||||||
which was recently made available on big-endian systems without these
|
|
||||||
in #11568.
|
|
||||||
|
|
||||||
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
|
||||||
---
|
|
||||||
numpy/core/src/multiarray/dragon4.c | 5 +++--
|
|
||||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/numpy/core/src/multiarray/dragon4.c b/numpy/core/src/multiarray/dragon4.c
|
|
||||||
index abbf05220..2e599136e 100644
|
|
||||||
--- a/numpy/core/src/multiarray/dragon4.c
|
|
||||||
+++ b/numpy/core/src/multiarray/dragon4.c
|
|
||||||
@@ -114,7 +114,7 @@ LogBase2_64(npy_uint64 val)
|
|
||||||
return LogBase2_32((npy_uint32)val);
|
|
||||||
}
|
|
||||||
|
|
||||||
-#if defined(HAVE_LDOUBLE_IEEE_QUAD_LE)
|
|
||||||
+#if defined(HAVE_LDOUBLE_IEEE_QUAD_LE) || defined(HAVE_LDOUBLE_IEEE_QUAD_BE)
|
|
||||||
static npy_uint32
|
|
||||||
LogBase2_128(npy_uint64 hi, npy_uint64 lo)
|
|
||||||
{
|
|
||||||
@@ -217,7 +217,8 @@ BigInt_Set_uint64(BigInt *i, npy_uint64 val)
|
|
||||||
|
|
||||||
#if (defined(HAVE_LDOUBLE_IBM_DOUBLE_DOUBLE_LE) || \
|
|
||||||
defined(HAVE_LDOUBLE_IBM_DOUBLE_DOUBLE_BE) || \
|
|
||||||
- defined(HAVE_LDOUBLE_IEEE_QUAD_LE))
|
|
||||||
+ defined(HAVE_LDOUBLE_IEEE_QUAD_LE) || \
|
|
||||||
+ defined(HAVE_LDOUBLE_IEEE_QUAD_BE))
|
|
||||||
static void
|
|
||||||
BigInt_Set_2x_uint64(BigInt *i, npy_uint64 hi, npy_uint64 lo)
|
|
||||||
{
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
13
numpy.spec
13
numpy.spec
@ -10,8 +10,8 @@
|
|||||||
%global modname numpy
|
%global modname numpy
|
||||||
|
|
||||||
Name: numpy
|
Name: numpy
|
||||||
Version: 1.15.0
|
Version: 1.15.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Summary: A fast multidimensional array facility for Python
|
Summary: A fast multidimensional array facility for Python
|
||||||
|
|
||||||
@ -20,8 +20,6 @@ License: BSD and Python
|
|||||||
URL: http://www.numpy.org/
|
URL: http://www.numpy.org/
|
||||||
Source0: https://github.com/%{name}/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.gz
|
Source0: https://github.com/%{name}/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.gz
|
||||||
Source1: https://docs.scipy.org/doc/numpy/numpy-html-1.15.0.zip
|
Source1: https://docs.scipy.org/doc/numpy/numpy-html-1.15.0.zip
|
||||||
# https://github.com/numpy/numpy/pull/11711
|
|
||||||
Patch0001: 0001-BUG-Fix-undefined-functions-on-big-endian-systems.patch
|
|
||||||
|
|
||||||
BuildRequires: python2-devel lapack-devel python2-setuptools gcc-gfortran python2-nose
|
BuildRequires: python2-devel lapack-devel python2-setuptools gcc-gfortran python2-nose
|
||||||
BuildRequires: Cython python2-pytest
|
BuildRequires: Cython python2-pytest
|
||||||
@ -224,7 +222,7 @@ env ATLAS=%{_libdir} \
|
|||||||
pushd %{buildroot}%{_bindir} &> /dev/null
|
pushd %{buildroot}%{_bindir} &> /dev/null
|
||||||
# symlink for anyone who was using f2py.numpy
|
# symlink for anyone who was using f2py.numpy
|
||||||
ln -s f2py2 f2py.numpy
|
ln -s f2py2 f2py.numpy
|
||||||
#ln -s f2py2 f2py
|
ln -s f2py2 f2py
|
||||||
popd &> /dev/null
|
popd &> /dev/null
|
||||||
#install -D -p -m 0644 docs/f2py/f2py.1 %{buildroot}%{_mandir}/man1/f2py.1
|
#install -D -p -m 0644 docs/f2py/f2py.1 %{buildroot}%{_mandir}/man1/f2py.1
|
||||||
|
|
||||||
@ -270,8 +268,6 @@ popd &> /dev/null
|
|||||||
%{python2_sitearch}/%{name}-*.egg-info
|
%{python2_sitearch}/%{name}-*.egg-info
|
||||||
%{_includedir}/numpy
|
%{_includedir}/numpy
|
||||||
%exclude %{python2_sitearch}/%{name}/LICENSE.txt
|
%exclude %{python2_sitearch}/%{name}/LICENSE.txt
|
||||||
%{_bindir}/conv-template
|
|
||||||
%{_bindir}/from-template
|
|
||||||
|
|
||||||
%files -n python2-numpy-f2py
|
%files -n python2-numpy-f2py
|
||||||
%doc docs/f2py/*.html
|
%doc docs/f2py/*.html
|
||||||
@ -318,6 +314,9 @@ popd &> /dev/null
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 22 2018 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1:1.15.1-1
|
||||||
|
- Update to latest version
|
||||||
|
|
||||||
* Sat Aug 11 2018 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1:1.15.0-2
|
* Sat Aug 11 2018 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1:1.15.0-2
|
||||||
- Fix broken build on s390x
|
- Fix broken build on s390x
|
||||||
- Remove bytecode produced by pytest
|
- Remove bytecode produced by pytest
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (numpy-1.15.0.tar.gz) = a1f0f2a2227ee2ea0a7c2c6676be1d50f1b67cc58f409b3b1094de50390294c23509f88a394a390c57d03c2d5785256c12d8534ad87f6719f0ec4ea574de7ed6
|
SHA512 (numpy-1.15.1.tar.gz) = 76271923bcbbd602af3995e9c9de6e657bdaa289f59129b44e367bfa60d9210df13885ca33726a7d0c06d4cd0f7add394dd100c36b3a52f6050846a5c51a2268
|
||||||
SHA512 (numpy-html-1.15.0.zip) = 7d8968f64ddceb864ef0744140d10279b7dbb1f5c7e21a6ced01c6079ea633eca0b087e7158e8cd4bd106ccb4c575f27a74207b7399324591cf5e9bfa3c01fb8
|
SHA512 (numpy-html-1.15.0.zip) = 7d8968f64ddceb864ef0744140d10279b7dbb1f5c7e21a6ced01c6079ea633eca0b087e7158e8cd4bd106ccb4c575f27a74207b7399324591cf5e9bfa3c01fb8
|
||||||
|
Loading…
Reference in New Issue
Block a user