Bump to new upstream release 1.0.1

This commit is contained in:
Jarod Wilson 2006-12-13 18:12:41 +00:00
parent aed89e004f
commit a3f8c00778
4 changed files with 18 additions and 38 deletions

View File

@ -1,3 +1,4 @@
numpy-0.9.6.tar.gz
numpy-0.9.8.tar.gz
numpy-1.0.tar.gz
numpy-1.0.1.tar.gz

View File

@ -1,21 +0,0 @@
diff -ur numpy-0.9.8.orig/numpy/distutils/fcompiler/gnu.py numpy-0.9.8/numpy/distutils/fcompiler/gnu.py
--- numpy-0.9.8.orig/numpy/distutils/fcompiler/gnu.py 2006-04-10 03:21:26.000000000 -0400
+++ numpy-0.9.8/numpy/distutils/fcompiler/gnu.py 2006-09-05 11:54:22.000000000 -0400
@@ -30,7 +30,7 @@
'compiler_f77' : [fc_exe,"-Wall","-fno-second-underscore"],
'compiler_f90' : None,
'compiler_fix' : None,
- 'linker_so' : [fc_exe,"-Wall"],
+ 'linker_so' : [fc_exe,"-shared", "-Wall"],
'archiver' : ["ar", "-cr"],
'ranlib' : ["ranlib"],
'linker_exe' : [fc_exe,"-Wall"]
@@ -237,7 +237,7 @@
'compiler_f77' : [fc_exe,"-Wall","-ffixed-form","-fno-second-underscore"],
'compiler_f90' : [fc_exe,"-Wall","-fno-second-underscore"],
'compiler_fix' : [fc_exe,"-Wall","-ffixed-form","-fno-second-underscore"],
- 'linker_so' : [fc_exe,"-Wall"],
+ 'linker_so' : [fc_exe,"-shared", "-Wall"],
'archiver' : ["ar", "-cr"],
'ranlib' : ["ranlib"],
'linker_exe' : [fc_exe,"-Wall"]

View File

@ -3,8 +3,8 @@
%{!?python_version: %define python_version %(%{__python} -c 'import sys; print sys.version.split(" ")[0]' || echo "2.3")}
Name: numpy
Version: 1.0
Release: 3%{?dist}
Version: 1.0.1
Release: 1%{?dist}
Summary: A fast multidimensional array facility for Python
Group: Development/Languages
@ -18,16 +18,16 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: python-devel atlas-devel blas-devel lapack-devel python-setuptools gcc-gfortran
%description
The Numeric Python extensions is a set of extensions to the Python programming
language which allows Python programmers to efficiently manipulate large sets
of objects organized in grid-like fashion. These sets of objects are called
arrays, and they can have any number of dimensions: one dimensional arrays are
similar to standard Python sequences, two-dimensional arrays are similar to
matrices from linear algebra. Note that one-dimensional arrays are also
different from any other Python sequence, and that two-dimensional matrices
are also different from the matrices of linear algebra.
NumPy is a general-purpose array-processing package designed to
efficiently manipulate large multi-dimensional arrays of arbitrary
records without sacrificing too much speed for small multi-dimensional
arrays. NumPy is built on the Numeric code base and adds features
introduced by numarray as well as an extended C-API and the ability to
create arrays of arbitrary type.
This package also contains a version of f2py that works properly with it.
There are also basic facilities for discrete fourier transform,
basic linear algebra and random number generation. Also included in
this package is a version of f2py that works properly with NumPy.
%prep
%setup -q
@ -35,15 +35,15 @@ This package also contains a version of f2py that works properly with it.
%patch1 -p1 -b .gfortran
%build
ATLAS=%{_libdir} FFTW=%{_libdir} BLAS=%{_libdir} \
env ATLAS=%{_libdir} FFTW=%{_libdir} BLAS=%{_libdir} \
LAPACK=%{_libdir} CFLAGS="$RPM_OPT_FLAGS" \
%{__python} setup.py build --without-pydebug
%{__python} setup.py build
%install
rm -rf $RPM_BUILD_ROOT
#%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
# skip-build currently broken, this works around it for now
ATLAS=%{_libdir} FFTW=%{_libdir} BLAS=%{_libdir} \
env ATLAS=%{_libdir} FFTW=%{_libdir} BLAS=%{_libdir} \
LAPACK=%{_libdir} CFLAGS="$RPM_OPT_FLAGS" \
%{__python} setup.py install --root $RPM_BUILD_ROOT
rm -rf docs-f2py ; mv $RPM_BUILD_ROOT%{python_sitearch}/%{name}/f2py/docs docs-f2py
@ -70,8 +70,8 @@ rm -rf $RPM_BUILD_ROOT
%{python_sitearch}/%{name}
%changelog
* Wed Dec 12 2006 Jarod Wilson <jwilson@redhat.com> 1.0-3
- Disable pydebug, build against python 2.5 fails otherwise
* Wed Dec 13 2006 Jarod Wilson <jwilson@redhat.com> 1.0.1-1
- New upstream release (yay, it even builds w/python 2.5)
* Tue Dec 12 2006 Jarod Wilson <jwilson@redhat.com> 1.0-2
- Rebuild for python 2.5

View File

@ -1 +1 @@
47dd0daa82e7b3f0fe74b969b388d7b3 numpy-1.0.tar.gz
13a29244cbe03e0d45e56d8d90ecb55d numpy-1.0.1.tar.gz