Update to 1.6.0b2

Drop import patch fixed upstream
This commit is contained in:
Orion Poplawski 2011-04-04 15:29:35 -06:00
parent 81d563effe
commit 5c2daceb50
4 changed files with 8 additions and 57 deletions

1
.gitignore vendored
View File

@ -2,3 +2,4 @@ numpy-1.4.1.tar.gz
/numpy-1.5.1rc1.tar.gz /numpy-1.5.1rc1.tar.gz
/numpy-1.5.1.tar.gz /numpy-1.5.1.tar.gz
/numpy-1.6.0b1.tar.gz /numpy-1.6.0b1.tar.gz
/numpy-1.6.0b2.tar.gz

View File

@ -1,47 +0,0 @@
diff --git a/setup.py b/setup.py
index 14e2d6f..74add2e 100755
--- a/setup.py
+++ b/setup.py
@@ -94,19 +94,11 @@ if os.path.exists('MANIFEST'): os.remove('MANIFEST')
# a lot more robust than what was previously being used.
builtins.__NUMPY_SETUP__ = True
-# Construct full version info. Needs to be in setup.py namespace, otherwise it
-# can't be accessed from pavement.py at build time.
+# Full version info needs to be in setup.py namespace, otherwise it
+# can't be accessed from pavement.py at build time. Adding the git rev number
+# needs to be done inside write_version_py() however, otherwise the import of
+# numpy.version messes up the build under Python 3.
FULLVERSION = VERSION
-if os.path.exists('.git'):
- GIT_REVISION = git_version()
-elif os.path.exists('numpy/version.py'):
- # must be a source distribution, use existing version file
- from numpy.version import git_revision as GIT_REVISION
-else:
- GIT_REVISION = "Unknown"
-
-if not ISRELEASED:
- FULLVERSION += '.dev-' + GIT_REVISION[:7]
def write_version_py(filename='numpy/version.py'):
cnt = """
@@ -120,6 +112,18 @@ release = %(isrelease)s
if not release:
version = full_version
"""
+ FULLVERSION = VERSION
+ if os.path.exists('.git'):
+ GIT_REVISION = git_version()
+ elif os.path.exists('numpy/version.py'):
+ # must be a source distribution, use existing version file
+ from numpy.version import git_revision as GIT_REVISION
+ else:
+ GIT_REVISION = "Unknown"
+
+ if not ISRELEASED:
+ FULLVERSION += '.dev-' + GIT_REVISION[:7]
+
a = open(filename, 'w')
try:
a.write(cnt % {'version': VERSION,

View File

@ -5,11 +5,11 @@
%endif %endif
#uncomment next line for a release candidate or a beta #uncomment next line for a release candidate or a beta
%global relc b1 %global relc b2
Name: numpy Name: numpy
Version: 1.6.0 Version: 1.6.0
Release: 0.1.b1%{?dist} Release: 0.2.%{relc}%{?dist}
Epoch: 1 Epoch: 1
Summary: A fast multidimensional array facility for Python Summary: A fast multidimensional array facility for Python
@ -17,9 +17,6 @@ Group: Development/Languages
License: BSD License: BSD
URL: http://numeric.scipy.org/ URL: http://numeric.scipy.org/
Source0: http://downloads.sourceforge.net/numpy/%{name}-%{version}%{?relc}.tar.gz Source0: http://downloads.sourceforge.net/numpy/%{name}-%{version}%{?relc}.tar.gz
# Patch https://github.com/rgommers/numpy/commit/a9fb1be2 to fix import errors
Patch0: numpy-1.6.0b1-import.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: python2-devel lapack-devel python-setuptools gcc-gfortran atlas-devel python-nose BuildRequires: python2-devel lapack-devel python-setuptools gcc-gfortran atlas-devel python-nose
@ -85,7 +82,6 @@ This package includes a version of f2py that works properly with NumPy.
%prep %prep
%setup -q -n %{name}-%{version}%{?relc} %setup -q -n %{name}-%{version}%{?relc}
%patch0 -p1 -b .import
%if 0%{?with_python3} %if 0%{?with_python3}
rm -rf %{py3dir} rm -rf %{py3dir}
@ -161,9 +157,6 @@ rm -f %{buildroot}%{python_sitearch}/%{name}/README.txt
rm -f %{buildroot}%{python_sitearch}/%{name}/THANKS.txt rm -f %{buildroot}%{python_sitearch}/%{name}/THANKS.txt
rm -f %{buildroot}%{python_sitearch}/%{name}/site.cfg.example rm -f %{buildroot}%{python_sitearch}/%{name}/site.cfg.example
# Incorrectly installs some docs here
rm -r %{buildroot}%{python_sitearch}/doc
%check %check
# doc/io.py conflicts with the regular io module causing # doc/io.py conflicts with the regular io module causing
# AttributeError: 'module' object has no attribute 'BufferedIOBase' in tests # AttributeError: 'module' object has no attribute 'BufferedIOBase' in tests
@ -254,6 +247,10 @@ rm -rf %{buildroot}
%changelog %changelog
* Mon Apr 4 2011 Orion Poplawski <orion@cora.nwra.com> - 1:1.6.0-0.2.b2
- Update to 1.6.0b2
- Drop import patch fixed upstream
* Thu Mar 31 2011 Orion Poplawski <orion@cora.nwra.com> - 1:1.6.0-0.1.b1 * Thu Mar 31 2011 Orion Poplawski <orion@cora.nwra.com> - 1:1.6.0-0.1.b1
- Update to 1.6.0b1 - Update to 1.6.0b1
- Build python3 module with python3 - Build python3 module with python3

View File

@ -1 +1 @@
aeab5881974aac595b87a848c0c6344a numpy-1.6.0b1.tar.gz 52b627e008548bc5f2d62d461a654fd6 numpy-1.6.0b2.tar.gz