This commit is contained in:
Gwyn Ciesla 2019-12-30 10:36:06 -06:00
parent 64b04844e9
commit 42c7dee616
4 changed files with 10 additions and 59 deletions

1
.gitignore vendored
View File

@ -70,3 +70,4 @@ numpy-1.4.1.tar.gz
/numpy-1.17.2.tar.gz
/numpy-1.17.3.tar.gz
/numpy-1.17.4.tar.gz
/numpy-1.18.0.tar.gz

View File

@ -1,51 +0,0 @@
From af36784b2b38577a87208003d6827d02dc0c0fc2 Mon Sep 17 00:00:00 2001
From: Michael Hudson-Doyle <michael.hudson@canonical.com>
Date: Thu, 24 Oct 2019 21:46:00 +1300
Subject: [PATCH] BUG: fix integer size confusion in handling array's ndmin
argument
The ndmin local variable was changed from an "int" to an "npy_intp" but
&ndmin is passed to PyArg_ParseTupleAndKeywords against a "i" argument
spec, but these integers have different sizes (well on an LP64 platform
anyway). This actually works on a little endian system but fails
on a big endian one. Fix this by converting the local back to an int,
and being a little careful before assigning the result of PyLong_AsLong to
it.
Fixes #14767
---
numpy/core/src/multiarray/multiarraymodule.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/numpy/core/src/multiarray/multiarraymodule.c b/numpy/core/src/multiarray/multiarraymodule.c
index 44156704996..9693275e74d 100644
--- a/numpy/core/src/multiarray/multiarraymodule.c
+++ b/numpy/core/src/multiarray/multiarraymodule.c
@@ -1562,8 +1562,7 @@ _array_fromobject(PyObject *NPY_UNUSED(ignored), PyObject *args, PyObject *kws)
PyArrayObject *oparr = NULL, *ret = NULL;
npy_bool subok = NPY_FALSE;
npy_bool copy = NPY_TRUE;
- int nd;
- npy_intp ndmin = 0;
+ int ndmin = 0, nd;
PyArray_Descr *type = NULL;
PyArray_Descr *oldtype = NULL;
NPY_ORDER order = NPY_KEEPORDER;
@@ -1625,13 +1624,14 @@ _array_fromobject(PyObject *NPY_UNUSED(ignored), PyObject *args, PyObject *kws)
ndmin_obj = PyDict_GetItem(kws, npy_ma_str_ndmin);
if (ndmin_obj) {
- ndmin = PyLong_AsLong(ndmin_obj);
- if (error_converting(ndmin)) {
+ long t = PyLong_AsLong(ndmin_obj);
+ if (error_converting(t)) {
goto clean_type;
}
- else if (ndmin > NPY_MAXDIMS) {
+ else if (t > NPY_MAXDIMS) {
goto full_path;
}
+ ndmin = t;
}
/* copy=False with default dtype, order (any is OK) and ndim */

View File

@ -1,5 +1,5 @@
#uncomment next line for a release candidate or a beta
#%%global relc rc1
##%global relc rc1
# Simple way to disable tests
%bcond_without tests
@ -7,8 +7,8 @@
%global modname numpy
Name: numpy
Version: 1.17.4
Release: 2%{?dist}
Version: 1.18.0
Release: 1%{?dist}.%relc
Epoch: 1
Summary: A fast multidimensional array facility for Python
@ -17,8 +17,6 @@ License: BSD and Python and ASL 2.0
URL: http://www.numpy.org/
Source0: https://github.com/%{name}/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.gz
Source1: https://docs.scipy.org/doc/numpy/numpy-html-1.17.0.zip
# https://github.com/numpy/numpy/issues/14767
Patch0001: https://github.com/numpy/numpy/pull/14769.patch
%description
@ -49,6 +47,7 @@ BuildRequires: gcc-gfortran gcc
BuildRequires: lapack-devel
%if %{with tests}
BuildRequires: python3-pytest
BuildRequires: python3-test
%endif
%ifarch %{openblas_arches}
BuildRequires: openblas-devel
@ -89,7 +88,7 @@ This package provides the complete documentation for NumPy.
%prep
%autosetup -n %{name}-%{version}%{?relc} -p1
%autosetup -n %{name}-%{version} -p1
# Force re-cythonization (ifed for PKG-INFO presence in setup.py)
rm PKG-INFO
@ -195,6 +194,9 @@ python3 runtests.py
%changelog
* Mon Dec 30 2019 Gwyn Ciesla <gwync@protonmail.com> - 1:1.18.0-1
- 1.18.0
* Mon Nov 11 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1:1.17.4-2
- Backport patch for s390x failures
- Enable non-broken tests on ppc64le

View File

@ -1,2 +1 @@
SHA512 (numpy-1.17.4.tar.gz) = ba1ff6a8884ab1b674f3acd9a349abfa96dd4275949511359c5923afaf5e38d00c36e56ae05e42a17cc1ef88cb66692e0788fe30ddd786a448e498723de0254a
SHA512 (numpy-html-1.17.0.zip) = 83b0a780d87d1dbf2c32a5359a8b2251d4636d35f7398cb5f72159317943906684cfb7fc26f95a26872f0216ee1b66772ce83674f87a7a6faa4d5829c5e5cfe7
SHA512 (numpy-1.18.0.tar.gz) = 4b08c9e64b98c71a8f8323af702baefb742097df645d925f536fc9009cec57bcc450e1f3bd2f445729751142d55f607f954f810bca747b4d12182c3d705fcb79