Update to 1.9.0rc1

This commit is contained in:
Orion Poplawski 2014-08-27 16:32:19 -06:00
parent f02b37f29b
commit 12d46bb2f5
4 changed files with 12 additions and 153 deletions

1
.gitignore vendored
View File

@ -18,3 +18,4 @@ numpy-1.4.1.tar.gz
/numpy-1.8.0.tar.gz
/numpy-1.8.1.tar.gz
/numpy-1.8.2.tar.gz
/numpy-1.9.0rc1.tar.gz

View File

@ -1,131 +0,0 @@
@@ -, +, @@
---
doc/release/1.8.1-notes.rst | 4 ++++
numpy/core/include/numpy/npy_cpu.h | 3 +++
numpy/core/include/numpy/npy_endian.h | 3 ++-
numpy/core/setup.py | 2 +-
numpy/core/setup_common.py | 4 ++++
numpy/core/src/npymath/ieee754.c.src | 3 ++-
numpy/core/src/npymath/npy_math_private.h | 3 ++-
numpy/core/src/private/npy_fpmath.h | 5 ++++-
8 files changed, 22 insertions(+), 5 deletions(-)
--- numpy-1.8.1/numpy/core/setup_common.py
+++ numpy-1.8.1/numpy/core/setup_common.py
@@ -256,6 +256,8 @@ _IEEE_QUAD_PREC_BE = ['300', '031', '326
_IEEE_QUAD_PREC_LE = _IEEE_QUAD_PREC_BE[::-1]
_DOUBLE_DOUBLE_BE = ['301', '235', '157', '064', '124', '000', '000', '000'] + \
['000'] * 8
+_DOUBLE_DOUBLE_LE = ['000', '000', '000', '124', '064', '157', '235', '301'] + \
+ ['000'] * 8
def long_double_representation(lines):
"""Given a binary dump as given by GNU od -b, look for long double
@@ -295,6 +297,8 @@ def long_double_representation(lines):
return 'IEEE_QUAD_LE'
elif read[8:-8] == _DOUBLE_DOUBLE_BE:
return 'DOUBLE_DOUBLE_BE'
+ elif read[8:-8] == _DOUBLE_DOUBLE_LE:
+ return 'DOUBLE_DOUBLE_LE'
elif read[:16] == _BEFORE_SEQ:
if read[16:-8] == _IEEE_DOUBLE_LE:
return 'IEEE_DOUBLE_LE'
--- numpy-1.8.1/numpy/core/include/numpy/npy_cpu.h
+++ numpy-1.8.1/numpy/core/include/numpy/npy_cpu.h
@@ -5,6 +5,7 @@
* NPY_CPU_AMD64
* NPY_CPU_PPC
* NPY_CPU_PPC64
+ * NPY_CPU_PPC64LE
* NPY_CPU_SPARC
* NPY_CPU_S390
* NPY_CPU_IA64
@@ -41,6 +42,8 @@
* _ARCH_PPC is used by at least gcc on AIX
*/
#define NPY_CPU_PPC
+#elif defined(__ppc64le__)
+ #define NPY_CPU_PPC64LE
#elif defined(__ppc64__)
#define NPY_CPU_PPC64
#elif defined(__sparc__) || defined(__sparc)
--- numpy-1.8.1/numpy/core/include/numpy/npy_endian.h
+++ numpy-1.8.1/numpy/core/include/numpy/npy_endian.h
@@ -27,7 +27,8 @@
|| defined(NPY_CPU_ARMEL) \
|| defined(NPY_CPU_AARCH64) \
|| defined(NPY_CPU_SH_LE) \
- || defined(NPY_CPU_MIPSEL)
+ || defined(NPY_CPU_MIPSEL) \
+ || defined(NPY_CPU_PPC64LE)
#define NPY_BYTE_ORDER NPY_LITTLE_ENDIAN
#elif defined(NPY_CPU_PPC) \
|| defined(NPY_CPU_SPARC) \
--- numpy-1.8.1/numpy/core/setup.py
+++ numpy-1.8.1/numpy/core/setup.py
@@ -466,7 +466,7 @@ def configuration(parent_package='',top_
'MOTOROLA_EXTENDED_12_BYTES_BE',
'IEEE_QUAD_LE', 'IEEE_QUAD_BE',
'IEEE_DOUBLE_LE', 'IEEE_DOUBLE_BE',
- 'DOUBLE_DOUBLE_BE']:
+ 'DOUBLE_DOUBLE_BE', 'DOUBLE_DOUBLE_LE']:
moredefs.append(('HAVE_LDOUBLE_%s' % rep, 1))
else:
raise ValueError("Unrecognized long double format: %s" % rep)
--- numpy-1.8.1/numpy/core/src/npymath/ieee754.c.src
+++ numpy-1.8.1/numpy/core/src/npymath/ieee754.c.src
@@ -133,7 +133,8 @@ float _nextf(float x, int p)
return x;
}
-#ifdef HAVE_LDOUBLE_DOUBLE_DOUBLE_BE
+#if defined(HAVE_LDOUBLE_DOUBLE_DOUBLE_BE) || \
+ defined(HAVE_LDOUBLE_DOUBLE_DOUBLE_LE)
/*
* FIXME: this is ugly and untested. The asm part only works with gcc, and we
--- numpy-1.8.1/numpy/core/src/npymath/npy_math_private.h
+++ numpy-1.8.1/numpy/core/src/npymath/npy_math_private.h
@@ -435,7 +435,8 @@ do {
typedef npy_uint32 ldouble_sign_t;
#endif
-#ifndef HAVE_LDOUBLE_DOUBLE_DOUBLE_BE
+#if !defined(HAVE_LDOUBLE_DOUBLE_DOUBLE_BE) && \
+ !defined(HAVE_LDOUBLE_DOUBLE_DOUBLE_LE)
/* Get the sign bit of x. x should be of type IEEEl2bitsrep */
#define GET_LDOUBLE_SIGN(x) \
(((x).a[LDBL_SIGN_INDEX] & LDBL_SIGN_MASK) >> LDBL_SIGN_SHIFT)
--- numpy-1.8.1/numpy/core/src/private/npy_fpmath.h
+++ numpy-1.8.1/numpy/core/src/private/npy_fpmath.h
@@ -29,6 +29,8 @@
#define HAVE_LDOUBLE_INTEL_EXTENDED_16_BYTES_LE
#elif defined(NPY_CPU_PPC) || defined(NPY_CPU_PPC64)
#define HAVE_LDOUBLE_IEEE_DOUBLE_16_BYTES_BE
+ #elif defined(NPY_CPU_PPC64LE)
+ #define HAVE_LDOUBLE_IEEE_DOUBLE_16_BYTES_LE
#endif
#endif
#endif
@@ -41,7 +43,8 @@
defined(HAVE_LDOUBLE_INTEL_EXTENDED_16_BYTES_LE) || \
defined(HAVE_LDOUBLE_INTEL_EXTENDED_12_BYTES_LE) || \
defined(HAVE_LDOUBLE_MOTOROLA_EXTENDED_12_BYTES_BE) || \
- defined(HAVE_LDOUBLE_DOUBLE_DOUBLE_BE))
+ defined(HAVE_LDOUBLE_DOUBLE_DOUBLE_BE) || \
+ defined(HAVE_LDOUBLE_DOUBLE_DOUBLE_LE))
#error No long double representation defined
#endif
--- numpy-1.8.1/doc/release/1.8.1-notes.rst
+++ numpy-1.8.1/doc/release/1.8.1-notes.rst
@@ -81,6 +81,10 @@ calls to ``numpy.distutils.system_info.g
print anything on the output. This is mostly for other packages using
numpy.distutils.
+Build system
+~~~~~~~~~~~~
+Added experimental support for the ppc64le architecture.
+
Deprecations
============

View File

@ -5,11 +5,11 @@
%endif
#uncomment next line for a release candidate or a beta
%global relc %{nil}
%global relc rc1
Name: numpy
Version: 1.8.2
Release: 2%{?dist}
Version: 1.9.0
Release: 0.1.rc1%{?dist}
Epoch: 1
Summary: A fast multidimensional array facility for Python
@ -19,8 +19,6 @@ License: BSD and Python
URL: http://www.numpy.org/
Source0: http://downloads.sourceforge.net/numpy/%{name}-%{version}%{?relc}.tar.gz
Patch0: numpy-1.8.1.ppc64le.patch
BuildRequires: python2-devel lapack-devel python-setuptools gcc-gfortran atlas-devel python-nose
Requires: python-nose
%if 0%{?with_python3}
@ -86,8 +84,6 @@ This package includes a version of f2py that works properly with NumPy.
%prep
%setup -q -n %{name}-%{version}%{?relc}
%patch0 -p1
# workaround for rhbz#849713
# http://mail.scipy.org/pipermail/numpy-discussion/2012-July/063530.html
rm numpy/distutils/command/__init__.py && touch numpy/distutils/command/__init__.py
@ -128,9 +124,6 @@ pushd %{py3dir}
env ATLAS=%{_libdir} FFTW=%{_libdir} BLAS=%{_libdir} \
LAPACK=%{_libdir} CFLAGS="%{optflags}" \
%{__python3} setup.py install --root %{buildroot}
rm -rf docs-f2py ; mv %{buildroot}%{python3_sitearch}/%{name}/f2py/docs docs-f2py
mv -f %{buildroot}%{python3_sitearch}/%{name}/f2py/f2py.1 f2py.1
install -D -p -m 0644 f2py.1 %{buildroot}%{_mandir}/man1/f2py.1
pushd %{buildroot}%{_bindir} &> /dev/null
popd &> /dev/null
@ -142,13 +135,11 @@ popd
env ATLAS=%{_libdir} FFTW=%{_libdir} BLAS=%{_libdir} \
LAPACK=%{_libdir} CFLAGS="%{optflags}" \
%{__python} setup.py install --root %{buildroot}
rm -rf docs-f2py ; mv %{buildroot}%{python_sitearch}/%{name}/f2py/docs docs-f2py
mv -f %{buildroot}%{python_sitearch}/%{name}/f2py/f2py.1 f2py.1
install -D -p -m 0644 f2py.1 %{buildroot}%{_mandir}/man1/f2py.1
pushd %{buildroot}%{_bindir} &> /dev/null
# symlink for anyone who was using f2py.numpy
ln -s f2py f2py.numpy
popd &> /dev/null
install -D -p -m 0644 doc/f2py/f2py.1 %{buildroot}%{_mandir}/man1/f2py.1
#symlink for includes, BZ 185079
mkdir -p %{buildroot}/usr/include
@ -178,7 +169,7 @@ popd &> /dev/null
%files
%doc doc/cython LICENSE.txt README.txt THANKS.txt DEV_README.txt COMPATIBILITY site.cfg.example
%doc LICENSE.txt README.txt THANKS.txt DEV_README.txt COMPATIBILITY site.cfg.example
%dir %{python_sitearch}/%{name}
%{python_sitearch}/%{name}/*.py*
%{python_sitearch}/%{name}/core
@ -188,8 +179,6 @@ popd &> /dev/null
%{python_sitearch}/%{name}/lib
%{python_sitearch}/%{name}/linalg
%{python_sitearch}/%{name}/ma
%{python_sitearch}/%{name}/numarray
%{python_sitearch}/%{name}/oldnumeric
%{python_sitearch}/%{name}/random
%{python_sitearch}/%{name}/testing
%{python_sitearch}/%{name}/tests
@ -200,7 +189,7 @@ popd &> /dev/null
%{_includedir}/numpy
%files f2py
%doc docs-f2py
%doc doc/f2py/*.txt
%{_mandir}/man*/*
%{_bindir}/f2py
%{_bindir}/f2py.numpy
@ -208,7 +197,7 @@ popd &> /dev/null
%if 0%{?with_python3}
%files -n python3-numpy
%doc doc/cython LICENSE.txt README.txt THANKS.txt DEV_README.txt COMPATIBILITY site.cfg.example
%doc LICENSE.txt README.txt THANKS.txt DEV_README.txt COMPATIBILITY site.cfg.example
%{python3_sitearch}/%{name}/__pycache__
%dir %{python3_sitearch}/%{name}
%{python3_sitearch}/%{name}/*.py*
@ -219,8 +208,6 @@ popd &> /dev/null
%{python3_sitearch}/%{name}/lib
%{python3_sitearch}/%{name}/linalg
%{python3_sitearch}/%{name}/ma
%{python3_sitearch}/%{name}/numarray
%{python3_sitearch}/%{name}/oldnumeric
%{python3_sitearch}/%{name}/random
%{python3_sitearch}/%{name}/testing
%{python3_sitearch}/%{name}/tests
@ -230,13 +217,15 @@ popd &> /dev/null
%{python3_sitearch}/%{name}-*.egg-info
%files -n python3-numpy-f2py
%doc docs-f2py
%{_bindir}/f2py3
%{python3_sitearch}/%{name}/f2py
%endif # with_python3
%changelog
* Wed Aug 27 2014 Orion Poplawski <orion@nwra.com> - 1:1.9.0-0.1.rc1
- Update to 1.9.0rc1
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.8.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild

View File

@ -1 +1 @@
dd8eece8f6fda3a13836de4adbafb0cb numpy-1.8.2.tar.gz
fe4a2b5415c3826d7fd8f849c6f67929 numpy-1.9.0rc1.tar.gz