Update to 1.10.2rc1
- Drop opt-flags patch applied upstream
This commit is contained in:
parent
aeda5a10f3
commit
047983c7b9
1
.gitignore
vendored
1
.gitignore
vendored
@ -25,3 +25,4 @@ numpy-1.4.1.tar.gz
|
|||||||
/numpy-1.10.0b1.tar.gz
|
/numpy-1.10.0b1.tar.gz
|
||||||
/numpy-1.10.0.tar.gz
|
/numpy-1.10.0.tar.gz
|
||||||
/numpy-1.10.1.tar.gz
|
/numpy-1.10.1.tar.gz
|
||||||
|
/numpy-1.10.2rc1.tar.gz
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- numpy-1.10.1/numpy/distutils/fcompiler/gnu.py 2015-10-14 21:43:39.834732663 +0200
|
|
||||||
+++ numpy-1.10.1/numpy/distutils/fcompiler/gnu.py.orig 2015-10-14 21:42:31.346540506 +0200
|
|
||||||
@@ -218,7 +218,7 @@
|
|
||||||
opt = ['-O2 -march=core2 -mtune=generic -mfpmath=sse -msse2 '
|
|
||||||
'-mincoming-stack-boundary=2']
|
|
||||||
else:
|
|
||||||
- opt = ['-O2']
|
|
||||||
+ opt = ['-O2 -march=x86-64 -DMS_WIN64 -mtune=generic -msse2']
|
|
||||||
else:
|
|
||||||
opt = ['-O2']
|
|
||||||
|
|
13
numpy.spec
13
numpy.spec
@ -5,14 +5,13 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
#uncomment next line for a release candidate or a beta
|
#uncomment next line for a release candidate or a beta
|
||||||
#%%global relc %%{nil}
|
%global relc rc1
|
||||||
#%%global relc b1
|
|
||||||
|
|
||||||
%global modname numpy
|
%global modname numpy
|
||||||
|
|
||||||
Name: numpy
|
Name: numpy
|
||||||
Version: 1.10.1
|
Version: 1.10.2
|
||||||
Release: 6%{?relc}%{?dist}
|
Release: 0.1%{?relc}%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Summary: A fast multidimensional array facility for Python
|
Summary: A fast multidimensional array facility for Python
|
||||||
|
|
||||||
@ -21,7 +20,6 @@ Group: Development/Languages
|
|||||||
License: BSD and Python
|
License: BSD and Python
|
||||||
URL: http://www.numpy.org/
|
URL: http://www.numpy.org/
|
||||||
Source0: http://downloads.sourceforge.net/numpy/%{name}-%{version}%{?relc}.tar.gz
|
Source0: http://downloads.sourceforge.net/numpy/%{name}-%{version}%{?relc}.tar.gz
|
||||||
Patch0: numpy-1.10.1-remove-opt-flags.patch
|
|
||||||
|
|
||||||
BuildRequires: python2-devel lapack-devel python-setuptools gcc-gfortran atlas-devel python-nose
|
BuildRequires: python2-devel lapack-devel python-setuptools gcc-gfortran atlas-devel python-nose
|
||||||
BuildRequires: Cython
|
BuildRequires: Cython
|
||||||
@ -112,7 +110,6 @@ This package includes a version of f2py that works properly with NumPy.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}%{?relc}
|
%setup -q -n %{name}-%{version}%{?relc}
|
||||||
%patch0 -R -p1
|
|
||||||
|
|
||||||
# workaround for rhbz#849713
|
# workaround for rhbz#849713
|
||||||
# http://mail.scipy.org/pipermail/numpy-discussion/2012-July/063530.html
|
# http://mail.scipy.org/pipermail/numpy-discussion/2012-July/063530.html
|
||||||
@ -255,6 +252,10 @@ popd &> /dev/null
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 13 2015 Orion Poplawski <orion@cora.nwra.com> - 1:1.10.2-0.1.rc1
|
||||||
|
- Update to 1.10.2rc1
|
||||||
|
- Drop opt-flags patch applied upstream
|
||||||
|
|
||||||
* Fri Nov 13 2015 Kalev Lember <klember@redhat.com> - 1:1.10.1-6
|
* Fri Nov 13 2015 Kalev Lember <klember@redhat.com> - 1:1.10.1-6
|
||||||
- Add provides to satisfy numpy%%{_isa} requires in other packages
|
- Add provides to satisfy numpy%%{_isa} requires in other packages
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user