cf4a750103
- Enable the iquote.patch to access newly introduced types - New types and constants added to sslprot.h, sslerr.h, and sslt.h require thhe in-tree headers to be picked up first
39 lines
1.6 KiB
Diff
39 lines
1.6 KiB
Diff
diff -up nss/cmd/bltest/Makefile.iquote nss/cmd/bltest/Makefile
|
|
--- nss/cmd/bltest/Makefile.iquote 2013-06-27 10:58:08.000000000 -0700
|
|
+++ nss/cmd/bltest/Makefile 2013-07-02 15:02:26.656643246 -0700
|
|
@@ -45,6 +45,7 @@ include $(CORE_DEPTH)/coreconf/rules.mk
|
|
# (6) Execute "component" rules. (OPTIONAL) #
|
|
#######################################################################
|
|
|
|
+INCLUDES += -iquote $(DIST)/../private/nss
|
|
|
|
|
|
#######################################################################
|
|
diff -up nss/cmd/lib/Makefile.iquote nss/cmd/lib/Makefile
|
|
--- nss/cmd/lib/Makefile.iquote 2013-07-02 15:07:47.260622471 -0700
|
|
+++ nss/cmd/lib/Makefile 2013-07-02 15:08:47.219179157 -0700
|
|
@@ -38,7 +38,8 @@ include $(CORE_DEPTH)/coreconf/rules.mk
|
|
# (6) Execute "component" rules. (OPTIONAL) #
|
|
#######################################################################
|
|
|
|
-
|
|
+INCLUDES += -iquote $(DIST)/../private/nss
|
|
+INCLUDES += -iquote $(DIST)/../public/nss
|
|
|
|
#######################################################################
|
|
# (7) Execute "local" rules. (OPTIONAL). #
|
|
diff -up nss/coreconf/location.mk.iquote nss/coreconf/location.mk
|
|
--- nss/coreconf/location.mk.iquote 2013-06-27 10:58:08.000000000 -0700
|
|
+++ nss/coreconf/location.mk 2013-07-02 15:02:26.656643246 -0700
|
|
@@ -45,6 +45,10 @@ endif
|
|
|
|
ifdef NSS_INCLUDE_DIR
|
|
INCLUDES += -I$(NSS_INCLUDE_DIR)
|
|
+ ifdef IN_TREE_FREEBL_HEADERS_FIRST
|
|
+ INCLUDES += -iquote $(DIST)/../public/nss
|
|
+ INCLUDES += -iquote $(DIST)/../private/nss
|
|
+ endif
|
|
endif
|
|
|
|
ifndef NSS_LIB_DIR
|