2a8c1318ea
- Update spec file, patches, and helper scripts on account of a shallower source tree - Update the pem sources also to adjust to the sallower source for nss
17 lines
433 B
Diff
17 lines
433 B
Diff
diff -up nss/coreconf/Linux.mk.relro nss/coreconf/Linux.mk
|
|
--- nss/coreconf/Linux.mk.relro 2013-04-09 14:29:45.943228682 -0700
|
|
+++ nss/coreconf/Linux.mk 2013-04-09 14:31:26.194953927 -0700
|
|
@@ -174,6 +174,12 @@ endif
|
|
endif
|
|
endif
|
|
|
|
+# harden DSOs/executables a bit against exploits
|
|
+ifeq (2.6,$(firstword $(sort 2.6 $(OS_RELEASE))))
|
|
+DSO_LDOPTS+=-Wl,-z,relro
|
|
+LDFLAGS += -Wl,-z,relro
|
|
+endif
|
|
+
|
|
USE_SYSTEM_ZLIB = 1
|
|
ZLIB_LIBS = -lz
|
|
|