Update to 3.12.7
Delete nss-nolocalsql.patch and rely on an NSS_USE_SYSTEM_SQL variable instead. Added BuildRequires on available versions of the development pacakges Added some comments explaing lack of version on nss-sysinit provides
This commit is contained in:
parent
e7079bbf54
commit
fdefa43e4d
@ -1,52 +0,0 @@
|
|||||||
diff -up ./mozilla/security/nss/lib/Makefile.nolocalsql ./mozilla/security/nss/lib/Makefile
|
|
||||||
--- ./mozilla/security/nss/lib/Makefile.nolocalsql 2010-02-27 16:40:25.891777537 -0800
|
|
||||||
+++ ./mozilla/security/nss/lib/Makefile 2010-02-27 16:41:59.175902327 -0800
|
|
||||||
@@ -62,11 +62,11 @@ ifndef USE_SYSTEM_ZLIB
|
|
||||||
ZLIB_SRCDIR = zlib # Add the zlib directory to DIRS.
|
|
||||||
endif
|
|
||||||
|
|
||||||
-ifndef MOZILLA_CLIENT
|
|
||||||
-ifndef NSS_USE_SYSTEM_SQLITE
|
|
||||||
-SQLITE_SRCDIR = sqlite # Add the sqlite directory to DIRS.
|
|
||||||
-endif
|
|
||||||
-endif
|
|
||||||
+#ifndef MOZILLA_CLIENT
|
|
||||||
+#ifndef NSS_USE_SYSTEM_SQLITE
|
|
||||||
+#SQLITE_SRCDIR = sqlite # Add the sqlite directory to DIRS.
|
|
||||||
+#endif
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
ifndef MOZILLA_CLIENT
|
|
||||||
ifeq ($(OS_ARCH),Linux)
|
|
||||||
diff -up ./mozilla/security/nss/lib/softoken/legacydb/manifest.mn.nolocalsql ./mozilla/security/nss/lib/softoken/legacydb/manifest.mn
|
|
||||||
--- ./mozilla/security/nss/lib/softoken/legacydb/manifest.mn.nolocalsql 2010-02-27 16:44:24.998777709 -0800
|
|
||||||
+++ ./mozilla/security/nss/lib/softoken/legacydb/manifest.mn 2010-02-27 16:45:08.533803472 -0800
|
|
||||||
@@ -46,9 +46,9 @@ MAPFILE = $(OBJDIR)/nssdbm.def
|
|
||||||
|
|
||||||
DEFINES += -DSHLIB_SUFFIX=\"$(DLL_SUFFIX)\" -DSHLIB_PREFIX=\"$(DLL_PREFIX)\" -DSOFTOKEN_LIB_NAME=\"$(notdir $(SHARED_LIBRARY))\"
|
|
||||||
|
|
||||||
-ifdef MOZILLA_CLIENT
|
|
||||||
-INCLUDES += -I$(DIST)/include/sqlite3
|
|
||||||
-endif
|
|
||||||
+#ifdef MOZILLA_CLIENT
|
|
||||||
+#INCLUDES += -I$(DIST)/include/sqlite3
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
CSRCS = \
|
|
||||||
dbmshim.c \
|
|
||||||
diff -up ./mozilla/security/nss/lib/softoken/manifest.mn.nolocalsql ./mozilla/security/nss/lib/softoken/manifest.mn
|
|
||||||
--- ./mozilla/security/nss/lib/softoken/manifest.mn.nolocalsql 2010-02-27 16:42:52.213902231 -0800
|
|
||||||
+++ ./mozilla/security/nss/lib/softoken/manifest.mn 2010-02-27 16:43:34.040776788 -0800
|
|
||||||
@@ -47,9 +47,9 @@ MAPFILE = $(OBJDIR)/softokn.def
|
|
||||||
|
|
||||||
DEFINES += -DSHLIB_SUFFIX=\"$(DLL_SUFFIX)\" -DSHLIB_PREFIX=\"$(DLL_PREFIX)\" -DSOFTOKEN_LIB_NAME=\"$(notdir $(SHARED_LIBRARY))\" -DSHLIB_VERSION=\"$(LIBRARY_VERSION)\"
|
|
||||||
|
|
||||||
-ifdef MOZILLA_CLIENT
|
|
||||||
-INCLUDES += -I$(DIST)/include/sqlite3
|
|
||||||
-endif
|
|
||||||
+#ifdef MOZILLA_CLIENT
|
|
||||||
+#INCLUDES += -I$(DIST)/include/sqlite3
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
EXPORTS = \
|
|
||||||
secmodt.h \
|
|
Loading…
Reference in New Issue
Block a user