- Fix the missing CERTDB_TERMINAL_RECORD symbol problem

- Removed unwanted /usr/include/nss3 in front of the normal cflags include path
- Removed ugly and unnecessary patch dealing with CERTDB_TERMINAL_RECORD
This commit is contained in:
Elio Maldonado 2011-12-05 15:51:15 -08:00
parent 321e446e77
commit f67889f49c
3 changed files with 6 additions and 100 deletions

View File

@ -7,7 +7,7 @@
Summary: Network Security Services
Name: nss
Version: 3.13.1
Release: 5%{?dist}
Release: 6%{?dist}
License: MPLv1.1 or GPLv2+ or LGPLv2+
URL: http://www.mozilla.org/projects/security/pki/nss/
Group: System Environment/Libraries
@ -160,7 +160,6 @@ low level services.
%patch25 -p0 -b .systemfreebl
%patch26 -p0 -b .nofipstest
%patch27 -p0 -b .nosha224
%patch28 -p0 -b .terminalrecord
%build
@ -192,10 +191,6 @@ NSPR_LIB_DIR=%{_libdir}
export NSPR_INCLUDE_DIR
export NSPR_LIB_DIR
NSS_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nss-util | sed 's/-I//'`
export NSSUTIL_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nss-util | sed 's/-I//'`
export NSSUTIL_LIB_DIR=%{_libdir}
export FREEBL_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nss-softokn | sed 's/-I//'`
export FREEBL_LIB_DIR=%{_libdir}
export USE_SYSTEM_FREEBL=1
@ -581,6 +576,10 @@ rm -rf $RPM_BUILD_ROOT/%{_includedir}/nss3/nsslowhash.h
%changelog
* Mon Dec 05 2011 Elio Maldonado Batiz <emaldona@redhat.com> - 3.13.1-6
- Removed unwanted /usr/include/nss3 in front of the normal cflags include path
- Removed unnecessary patch dealing with CERTDB_TERMINAL_RECORD, it's visible
* Sun Dec 04 2011 Elio Maldonado <emaldona@redhat.com> - 3.13.1-5
- Statically link the pem module against system freebl found in buildroot
- Disabling sha224-related powerup selftest until we update softokn

View File

@ -1,13 +1,10 @@
diff -up ./mozilla/security/coreconf/Linux.mk.sytemfreebl ./mozilla/security/coreconf/Linux.mk
--- ./mozilla/security/coreconf/Linux.mk.sytemfreebl 2011-12-03 22:07:23.924156119 -0800
+++ ./mozilla/security/coreconf/Linux.mk 2011-12-03 22:08:28.322328345 -0800
@@ -182,6 +182,12 @@ endif
@@ -182,6 +182,9 @@ endif
USE_SYSTEM_ZLIB = 1
ZLIB_LIBS = -lz
+USE_SYSTEM_NSSUTIL = 1
+NSSUTIL_LIBS = -lnssutil3
+
+USE_SYSTEM_FREEBL = 1
+FREEBL_LIBS = -lfreebl3
+

View File

@ -1,90 +0,0 @@
diff -up ./mozilla/security/nss/cmd/addbuiltin/addbuiltin.c.terminalrecord ./mozilla/security/nss/cmd/addbuiltin/addbuiltin.c
--- ./mozilla/security/nss/cmd/addbuiltin/addbuiltin.c.terminalrecord 2011-12-04 21:15:47.660672521 -0800
+++ ./mozilla/security/nss/cmd/addbuiltin/addbuiltin.c 2011-12-04 21:16:39.491674974 -0800
@@ -52,6 +52,14 @@
#include <io.h>
#endif
+/* Defined in ./mozilla/dist/public/nss/certdb.h which was included
+ * and also in ./mozilla/security/nss/lib/softoken/legacydb/pcertt.h
+ * but invisible here for some reason
+ */
+#ifndef CERTDB_TERMINAL_RECORD
+#define CERTDB_TERMINAL_RECORD (1<<0)
+#endif
+
void dumpbytes(unsigned char *buf, int len)
{
int i;
diff -up ./mozilla/security/nss/lib/certhigh/certvfy.c.terminalrecord ./mozilla/security/nss/lib/certhigh/certvfy.c
--- ./mozilla/security/nss/lib/certhigh/certvfy.c.terminalrecord 2011-09-13 17:28:47.000000000 -0700
+++ ./mozilla/security/nss/lib/certhigh/certvfy.c 2011-12-04 21:14:01.683678605 -0800
@@ -56,6 +56,14 @@
#include "pki3hack.h"
#include "base.h"
+/* Defined in ./mozilla/dist/public/nss/certdb.h which was included
+ * and also in ./mozilla/security/nss/lib/softoken/legacydb/pcertt.h
+ * but invisible here for some reason
+ */
+#ifndef CERTDB_TERMINAL_RECORD
+#define CERTDB_TERMINAL_RECORD (1<<0)
+#endif
+
/*
* Check the validity times of a certificate
*/
diff -up ./mozilla/security/nss/lib/libpkix/pkix_pl_nss/pki/pkix_pl_cert.c.terminalrecord ./mozilla/security/nss/lib/libpkix/pkix_pl_nss/pki/pkix_pl_cert.c
--- ./mozilla/security/nss/lib/libpkix/pkix_pl_nss/pki/pkix_pl_cert.c.terminalrecord 2011-09-14 16:16:16.000000000 -0700
+++ ./mozilla/security/nss/lib/libpkix/pkix_pl_nss/pki/pkix_pl_cert.c 2011-12-04 21:14:01.684678605 -0800
@@ -43,6 +43,14 @@
#include "pkix_pl_cert.h"
+/* Defined in ./mozilla/dist/public/nss/certdb.h which was included
+ * and also in ./mozilla/security/nss/lib/softoken/legacydb/pcertt.h
+ * but invisible here for some reason
+ */
+#ifndef CERTDB_TERMINAL_RECORD
+#define CERTDB_TERMINAL_RECORD (1<<0)
+#endif
+
extern PKIX_PL_HashTable *cachedCertSigTable;
/* --Private-Cert-Functions------------------------------------- */
diff -up ./mozilla/security/nss/lib/pk11wrap/pk11nobj.c.terminalrecord ./mozilla/security/nss/lib/pk11wrap/pk11nobj.c
--- ./mozilla/security/nss/lib/pk11wrap/pk11nobj.c.terminalrecord 2011-04-12 17:10:26.000000000 -0700
+++ ./mozilla/security/nss/lib/pk11wrap/pk11nobj.c 2011-12-04 21:14:01.685678605 -0800
@@ -62,6 +62,14 @@
#include "pki.h"
#include "pkim.h"
+/* Defined in ./mozilla/dist/public/nss/certdb.h which was included
+ * and also in ./mozilla/security/nss/lib/softoken/legacydb/pcertt.h
+ * but invisible here for some reason
+ */
+#ifndef CERTDB_TERMINAL_RECORD
+#define CERTDB_TERMINAL_RECORD (1<<0)
+#endif
+
extern const NSSError NSS_ERROR_NOT_FOUND;
CK_TRUST
diff -up ./mozilla/security/nss/lib/pki/pki3hack.c.terminalrecord ./mozilla/security/nss/lib/pki/pki3hack.c
--- ./mozilla/security/nss/lib/pki/pki3hack.c.terminalrecord 2011-04-12 17:10:26.000000000 -0700
+++ ./mozilla/security/nss/lib/pki/pki3hack.c 2011-12-04 21:14:01.686678605 -0800
@@ -76,6 +76,14 @@ static const char CVS_ID[] = "@(#) $RCSf
#include "secmod.h"
#include "nssrwlk.h"
+/* Defined in ./mozilla/dist/public/nss/certdb.h which was included
+ * and also in ./mozilla/security/nss/lib/softoken/legacydb/pcertt.h
+ * but invisible here for some reason
+ */
+#ifndef CERTDB_TERMINAL_RECORD
+#define CERTDB_TERMINAL_RECORD (1<<0)
+#endif
+
NSSTrustDomain *g_default_trust_domain = NULL;
NSSCryptoContext *g_default_crypto_context = NULL;