Removed some left-over fprintf lines from patch
This commit is contained in:
parent
4edf8a9398
commit
e10b9063cb
41
546221.patch
41
546221.patch
@ -1,16 +1,16 @@
|
|||||||
diff -up nss-3.12.5/mozilla/security/nss/lib/sysinit/nsssysinit.c.546221 nss-3.12.5/mozilla/security/nss/lib/sysinit/nsssysinit.c
|
diff -up nss-3.12.5/mozilla/security/nss/lib/sysinit/nsssysinit.c.546221 nss-3.12.5/mozilla/security/nss/lib/sysinit/nsssysinit.c
|
||||||
--- nss-3.12.5/mozilla/security/nss/lib/sysinit/nsssysinit.c.546221 2009-12-18 10:48:35.969726219 -0800
|
--- nss-3.12.5/mozilla/security/nss/lib/sysinit/nsssysinit.c.546221 2009-12-19 21:11:06.590930221 -0800
|
||||||
+++ nss-3.12.5/mozilla/security/nss/lib/sysinit/nsssysinit.c 2009-12-18 10:51:05.866851066 -0800
|
+++ nss-3.12.5/mozilla/security/nss/lib/sysinit/nsssysinit.c 2009-12-19 21:17:29.019931181 -0800
|
||||||
@@ -54,6 +54,8 @@
|
@@ -37,8 +37,6 @@
|
||||||
#ifdef XP_UNIX
|
#include "prio.h"
|
||||||
#include <sys/stat.h>
|
#include "prprf.h"
|
||||||
#include <sys/types.h>
|
|
||||||
+#include <stdio.h>
|
|
||||||
+#include <stdarg.h>
|
|
||||||
|
|
||||||
static int
|
-
|
||||||
testdir(char *dir)
|
-
|
||||||
@@ -208,8 +210,8 @@ askpw=any timeout=30 ] } ";
|
/*
|
||||||
|
* The following provides a default example for operating systems to set up
|
||||||
|
* and manage applications loading NSS on their OS globally.
|
||||||
|
@@ -208,8 +206,8 @@ askpw=any timeout=30 ] } ";
|
||||||
static char **
|
static char **
|
||||||
get_list(char *filename, char *stripped_parameters)
|
get_list(char *filename, char *stripped_parameters)
|
||||||
{
|
{
|
||||||
@ -21,7 +21,7 @@ diff -up nss-3.12.5/mozilla/security/nss/lib/sysinit/nsssysinit.c.546221 nss-3.1
|
|||||||
int isFIPS = getFIPSMode();
|
int isFIPS = getFIPSMode();
|
||||||
const char *nssflags = isFIPS ? nssDefaultFIPSFlags : nssDefaultFlags;
|
const char *nssflags = isFIPS ? nssDefaultFIPSFlags : nssDefaultFlags;
|
||||||
int next = 0;
|
int next = 0;
|
||||||
@@ -219,17 +221,25 @@ get_list(char *filename, char *stripped_
|
@@ -219,13 +217,20 @@ get_list(char *filename, char *stripped_
|
||||||
return NULL;
|
return NULL;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -44,18 +44,13 @@ diff -up nss-3.12.5/mozilla/security/nss/lib/sysinit/nsssysinit.c.546221 nss-3.1
|
|||||||
"NSS=\"%sflags=internal%s\"",
|
"NSS=\"%sflags=internal%s\"",
|
||||||
userdb, stripped_parameters, nssflags,
|
userdb, stripped_parameters, nssflags,
|
||||||
isFIPS ? ",FIPS" : "");
|
isFIPS ? ",FIPS" : "");
|
||||||
|
@@ -238,19 +243,32 @@ get_list(char *filename, char *stripped_
|
||||||
+/* fprintf(stderr, "%s\n\n", module_list[next-1]); */
|
|
||||||
/* now open the user's defined PKCS #11 modules */
|
|
||||||
/* skip the local user DB entry */
|
|
||||||
module_list[next++] = PR_smprintf(
|
|
||||||
@@ -238,19 +248,35 @@ get_list(char *filename, char *stripped_
|
|
||||||
"parameters=\"configdir='sql:%s' %s\" "
|
"parameters=\"configdir='sql:%s' %s\" "
|
||||||
"NSS=\"flags=internal,moduleDBOnly,defaultModDB,skipFirst\"",
|
"NSS=\"flags=internal,moduleDBOnly,defaultModDB,skipFirst\"",
|
||||||
userdb, stripped_parameters);
|
userdb, stripped_parameters);
|
||||||
+/* fprintf(stderr, "%s\n\n", module_list[next-1]); */
|
- }
|
||||||
}
|
+ }
|
||||||
|
+
|
||||||
+ if (filename && 0 /* This doesn't actually work. If we register
|
+ if (filename && 0 /* This doesn't actually work. If we register
|
||||||
+ both this and the sysdb (in either order)
|
+ both this and the sysdb (in either order)
|
||||||
+ then only one of them actually shows up */) {
|
+ then only one of them actually shows up */) {
|
||||||
@ -64,9 +59,8 @@ diff -up nss-3.12.5/mozilla/security/nss/lib/sysinit/nsssysinit.c.546221 nss-3.1
|
|||||||
+ "module=\"NSS database\" "
|
+ "module=\"NSS database\" "
|
||||||
+ "parameters=\"configdir='sql:%s' tokenDescription='NSS database sql:%s'\" "
|
+ "parameters=\"configdir='sql:%s' tokenDescription='NSS database sql:%s'\" "
|
||||||
+ "NSS=\"%sflags=internal\"",filename, filename, nssflags);
|
+ "NSS=\"%sflags=internal\"",filename, filename, nssflags);
|
||||||
+ fprintf(stderr, "%s\n\n", module_list[next-1]);
|
|
||||||
+ }
|
+ }
|
||||||
+
|
|
||||||
/* now the system database (always read only) */
|
/* now the system database (always read only) */
|
||||||
- module_list[next++] = PR_smprintf(
|
- module_list[next++] = PR_smprintf(
|
||||||
- "library= "
|
- "library= "
|
||||||
@ -79,7 +73,6 @@ diff -up nss-3.12.5/mozilla/security/nss/lib/sysinit/nsssysinit.c.546221 nss-3.1
|
|||||||
+ "module=\"NSS system database\" "
|
+ "module=\"NSS system database\" "
|
||||||
+ "parameters=\"configdir='sql:%s' tokenDescription='NSS system database' flags=readonly\" "
|
+ "parameters=\"configdir='sql:%s' tokenDescription='NSS system database' flags=readonly\" "
|
||||||
+ "NSS=\"%sflags=internal,critical\"",sysdb, nssflags);
|
+ "NSS=\"%sflags=internal,critical\"",sysdb, nssflags);
|
||||||
+ fprintf(stderr, "%s\n\n", module_list[next-1]);
|
|
||||||
+ }
|
+ }
|
||||||
|
|
||||||
/* that was the last module */
|
/* that was the last module */
|
||||||
|
11
nss.spec
11
nss.spec
@ -7,7 +7,7 @@
|
|||||||
Summary: Network Security Services
|
Summary: Network Security Services
|
||||||
Name: nss
|
Name: nss
|
||||||
Version: 3.12.5
|
Version: 3.12.5
|
||||||
Release: 1%{?dist}.7
|
Release: 1%{?dist}.9
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
URL: http://www.mozilla.org/projects/security/pki/nss/
|
URL: http://www.mozilla.org/projects/security/pki/nss/
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -115,7 +115,7 @@ low level services.
|
|||||||
%patch7 -p0 -b .533125
|
%patch7 -p0 -b .533125
|
||||||
%patch8 -p0 -b .sysinit
|
%patch8 -p0 -b .sysinit
|
||||||
%patch9 -p1 -b .540387
|
%patch9 -p1 -b .540387
|
||||||
%patch10 -p0 -b .nsssyinit
|
%patch10 -p0 -b .545779
|
||||||
%patch11 -p1 -b .546221
|
%patch11 -p1 -b .546221
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -478,13 +478,16 @@ rm -rf $RPM_BUILD_ROOT/%{_includedir}/nss3/nsslowhash.h
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Dec 19 2009 Elio maldonado<emaldona@redhat.com> - 3.12.5-1.9
|
||||||
|
- Remove left over trace statements from nsssysinit patching
|
||||||
|
|
||||||
* Fri Dec 18 2009 Elio Maldonado<emaldona@redhat.com> - 3.12.5-2.7
|
* Fri Dec 18 2009 Elio Maldonado<emaldona@redhat.com> - 3.12.5-2.7
|
||||||
- Fix a misconstructed patch
|
- Fix a misconstructed patch
|
||||||
|
|
||||||
* Thu Dec 17 2009 Elio Maldonado<emaldona@redhat.com> - 3.12.5-1.6
|
* Thu Dec 17 2009 Elio Maldonado<emaldona@redhat.com> - 3.12.5-1.6
|
||||||
- Fix nsssysinit to enable applications to use the system database (#546221)
|
- Fix nsssysinit to enable apps to use system cert store, patch contributed by David Woodhouse (#546221)
|
||||||
- Fix spec so sysinit requires coreutils for post install scriplet (#547067)
|
- Fix spec so sysinit requires coreutils for post install scriplet (#547067)
|
||||||
- Fix segmentation fault when listing keys or certs in the database (#540387)
|
- Fix segmentation fault when listing keys or certs in the database, patch contributed by Kamil Dudka (#540387)
|
||||||
|
|
||||||
* Thu Dec 10 2009 Elio Maldonado<emaldona@redhat.com> - 3.12.5-1.5
|
* Thu Dec 10 2009 Elio Maldonado<emaldona@redhat.com> - 3.12.5-1.5
|
||||||
- Fix nsssysinit to set the default flags on the crypto module (#545779)
|
- Fix nsssysinit to set the default flags on the crypto module (#545779)
|
||||||
|
Loading…
Reference in New Issue
Block a user