- Update to NSS_3_12_11_RTM
This commit is contained in:
parent
a7fb38e80b
commit
d7c5a94ba8
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,4 +1,4 @@
|
|||||||
nss-3.12.10-stripped.tar.bz2
|
nss-3.12.11-stripped.tar.bz2
|
||||||
nss-pem-20101125.tar.bz2
|
nss-pem-20101125.tar.bz2
|
||||||
blank-cert8.db
|
blank-cert8.db
|
||||||
blank-key3.db
|
blank-key3.db
|
||||||
|
@ -1,47 +0,0 @@
|
|||||||
Index: mozilla/security/nss/lib/crmf/crmfi.h
|
|
||||||
===================================================================
|
|
||||||
RCS file: /cvsroot/mozilla/security/nss/lib/crmf/crmfi.h,v
|
|
||||||
retrieving revision 1.4
|
|
||||||
diff -u -u -r1.4 crmfi.h
|
|
||||||
--- mozilla/security/nss/lib/crmf/crmfi.h 15 Jan 2011 19:47:11 -0000 1.4
|
|
||||||
+++ mozilla/security/nss/lib/crmf/crmfi.h 11 May 2011 20:06:26 -0000
|
|
||||||
@@ -46,10 +46,38 @@
|
|
||||||
#include "secasn1.h"
|
|
||||||
#include "crmfit.h"
|
|
||||||
#include "secerr.h"
|
|
||||||
+#include "blapit.h"
|
|
||||||
|
|
||||||
#define CRMF_DEFAULT_ARENA_SIZE 1024
|
|
||||||
-#define MAX_WRAPPED_KEY_LEN 2048
|
|
||||||
|
|
||||||
+/*
|
|
||||||
+ * Explanation for the definition of MAX_WRAPPED_KEY_LEN:
|
|
||||||
+ *
|
|
||||||
+ * It's used for internal buffers to transport a wrapped private key.
|
|
||||||
+ * The value is in BYTES.
|
|
||||||
+ * We want to define a reasonable upper bound for this value.
|
|
||||||
+ * Ideally this could be calculated, but in order to simplify the code
|
|
||||||
+ * we want to estimate the maximum requires size.
|
|
||||||
+ * See also mozilla bug 655850 for the full explanation.
|
|
||||||
+ *
|
|
||||||
+ * We know the largest wrapped keys are RSA keys.
|
|
||||||
+ * We'll estimate the maximum size needed for wrapped RSA keys,
|
|
||||||
+ * and assume it's sufficient for wrapped keys of any type we support.
|
|
||||||
+ *
|
|
||||||
+ * The maximum size of RSA keys in bits is defined elsewhere as
|
|
||||||
+ * RSA_MAX_MODULUS_BITS
|
|
||||||
+ *
|
|
||||||
+ * The idea is to define MAX_WRAPPED_KEY_LEN based on the above.
|
|
||||||
+ *
|
|
||||||
+ * A wrapped RSA key requires about
|
|
||||||
+ * ( ( RSA_MAX_MODULUS_BITS / 8 ) * 5.5) + 65
|
|
||||||
+ * bytes.
|
|
||||||
+ *
|
|
||||||
+ * Therefore, a safe upper bound is:
|
|
||||||
+ * ( ( RSA_MAX_MODULUS_BITS / 8 ) *8 ) = RSA_MAX_MODULUS_BITS
|
|
||||||
+ *
|
|
||||||
+ */
|
|
||||||
+#define MAX_WRAPPED_KEY_LEN RSA_MAX_MODULUS_BITS
|
|
||||||
|
|
||||||
#define CRMF_BITS_TO_BYTES(bits) (((bits)+7)/8)
|
|
||||||
#define CRMF_BYTES_TO_BITS(bytes) ((bytes)*8)
|
|
15
nss.spec
15
nss.spec
@ -1,12 +1,12 @@
|
|||||||
%global nspr_version 4.8.8
|
%global nspr_version 4.8.8
|
||||||
%global nss_util_version 3.12.10
|
%global nss_util_version 3.12.11
|
||||||
%global nss_softokn_version 3.12.10
|
%global nss_softokn_version 3.12.11
|
||||||
%global unsupported_tools_directory %{_libdir}/nss/unsupported-tools
|
%global unsupported_tools_directory %{_libdir}/nss/unsupported-tools
|
||||||
|
|
||||||
Summary: Network Security Services
|
Summary: Network Security Services
|
||||||
Name: nss
|
Name: nss
|
||||||
Version: 3.12.10
|
Version: 3.12.11
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
URL: http://www.mozilla.org/projects/security/pki/nss/
|
URL: http://www.mozilla.org/projects/security/pki/nss/
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -55,7 +55,7 @@ Patch6: nss-enable-pem.patch
|
|||||||
Patch7: nsspem-642433.patch
|
Patch7: nsspem-642433.patch
|
||||||
Patch8: 0001-Bug-695011-PEM-logging.patch
|
Patch8: 0001-Bug-695011-PEM-logging.patch
|
||||||
Patch16: nss-539183.patch
|
Patch16: nss-539183.patch
|
||||||
Patch17: nss-703658.patch
|
#Patch17: nss-703658.patch
|
||||||
Patch18: nss-646045.patch
|
Patch18: nss-646045.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -132,7 +132,7 @@ low level services.
|
|||||||
%patch7 -p0 -b .642433
|
%patch7 -p0 -b .642433
|
||||||
%patch8 -p1 -b .695011
|
%patch8 -p1 -b .695011
|
||||||
%patch16 -p0 -b .539183
|
%patch16 -p0 -b .539183
|
||||||
%patch17 -p0 -b .703658
|
#%patch17 -p0 -b .703658
|
||||||
%patch18 -p0 -b .646045
|
%patch18 -p0 -b .646045
|
||||||
|
|
||||||
|
|
||||||
@ -544,6 +544,9 @@ rm -rf $RPM_BUILD_ROOT/%{_includedir}/nss3/nsslowhash.h
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 09 2011 Elio Maldonado <emaldona@redhat.com> - 3.12.11-1
|
||||||
|
- Update to NSS_3_12_11_RTM
|
||||||
|
|
||||||
* Sat Jul 23 2011 Elio Maldonado <emaldona@redhat.com> - 3.12.10-6
|
* Sat Jul 23 2011 Elio Maldonado <emaldona@redhat.com> - 3.12.10-6
|
||||||
- Indicate the provenance of stripped source tarball (#688015)
|
- Indicate the provenance of stripped source tarball (#688015)
|
||||||
|
|
||||||
|
1
sources
1
sources
@ -1,4 +1,3 @@
|
|||||||
05ccaacf0146ef7b74f100e9d2141633 nss-3.12.10-stripped.tar.bz2
|
|
||||||
e63cddf74c07f0d818d1052ecc6fbb1f nss-pem-20101125.tar.bz2
|
e63cddf74c07f0d818d1052ecc6fbb1f nss-pem-20101125.tar.bz2
|
||||||
a5ae49867124ac75f029a9a33af31bad blank-cert8.db
|
a5ae49867124ac75f029a9a33af31bad blank-cert8.db
|
||||||
9315689bbd9f28ceebd47894f99fccbd blank-key3.db
|
9315689bbd9f28ceebd47894f99fccbd blank-key3.db
|
||||||
|
Loading…
Reference in New Issue
Block a user