Merge remote-tracking branch 'up/main' into main-riscv64
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
commit
c419e78a7c
2
.gitignore
vendored
2
.gitignore
vendored
@ -73,3 +73,5 @@ TestUser51.cert
|
|||||||
/nss-3.79.tar.gz
|
/nss-3.79.tar.gz
|
||||||
/nspr-4.34.tar.gz
|
/nspr-4.34.tar.gz
|
||||||
/nss-3.81.tar.gz
|
/nss-3.81.tar.gz
|
||||||
|
/nss-3.83.tar.gz
|
||||||
|
/nspr-4.35.tar.gz
|
||||||
|
@ -1,12 +1,7 @@
|
|||||||
diff --git a/pr/include/md/_linux.h b/pr/include/md/_linux.h
|
diff -up ./pr/include/md/_linux.h.gcc-atomics ./pr/include/md/_linux.h
|
||||||
--- a/pr/include/md/_linux.h
|
--- ./pr/include/md/_linux.h.gcc-atomics 2022-09-20 11:23:22.008942926 -0700
|
||||||
+++ b/pr/include/md/_linux.h
|
+++ ./pr/include/md/_linux.h 2022-09-20 11:34:45.536751340 -0700
|
||||||
@@ -82,53 +82,73 @@
|
@@ -105,6 +105,15 @@
|
||||||
#define NO_DLOPEN_NULL
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#if defined(__FreeBSD_kernel__) || defined(__GNU__)
|
|
||||||
#define _PR_HAVE_SOCKADDR_LEN
|
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
#if defined(__i386__)
|
#if defined(__i386__)
|
||||||
@ -22,11 +17,7 @@ diff --git a/pr/include/md/_linux.h b/pr/include/md/_linux.h
|
|||||||
#define _PR_HAVE_ATOMIC_OPS
|
#define _PR_HAVE_ATOMIC_OPS
|
||||||
#define _MD_INIT_ATOMIC()
|
#define _MD_INIT_ATOMIC()
|
||||||
extern PRInt32 _PR_x86_AtomicIncrement(PRInt32 *val);
|
extern PRInt32 _PR_x86_AtomicIncrement(PRInt32 *val);
|
||||||
#define _MD_ATOMIC_INCREMENT _PR_x86_AtomicIncrement
|
@@ -116,6 +125,7 @@ extern PRInt32 _PR_x86_AtomicAdd(PRInt32
|
||||||
extern PRInt32 _PR_x86_AtomicDecrement(PRInt32 *val);
|
|
||||||
#define _MD_ATOMIC_DECREMENT _PR_x86_AtomicDecrement
|
|
||||||
extern PRInt32 _PR_x86_AtomicAdd(PRInt32 *ptr, PRInt32 val);
|
|
||||||
#define _MD_ATOMIC_ADD _PR_x86_AtomicAdd
|
|
||||||
extern PRInt32 _PR_x86_AtomicSet(PRInt32 *val, PRInt32 newval);
|
extern PRInt32 _PR_x86_AtomicSet(PRInt32 *val, PRInt32 newval);
|
||||||
#define _MD_ATOMIC_SET _PR_x86_AtomicSet
|
#define _MD_ATOMIC_SET _PR_x86_AtomicSet
|
||||||
#endif
|
#endif
|
||||||
@ -34,15 +25,7 @@ diff --git a/pr/include/md/_linux.h b/pr/include/md/_linux.h
|
|||||||
|
|
||||||
#if defined(__ia64__)
|
#if defined(__ia64__)
|
||||||
#define _PR_HAVE_ATOMIC_OPS
|
#define _PR_HAVE_ATOMIC_OPS
|
||||||
#define _MD_INIT_ATOMIC()
|
@@ -131,6 +141,15 @@ extern PRInt32 _PR_ia64_AtomicSet(PRInt3
|
||||||
extern PRInt32 _PR_ia64_AtomicIncrement(PRInt32 *val);
|
|
||||||
#define _MD_ATOMIC_INCREMENT _PR_ia64_AtomicIncrement
|
|
||||||
extern PRInt32 _PR_ia64_AtomicDecrement(PRInt32 *val);
|
|
||||||
#define _MD_ATOMIC_DECREMENT _PR_ia64_AtomicDecrement
|
|
||||||
extern PRInt32 _PR_ia64_AtomicAdd(PRInt32 *ptr, PRInt32 val);
|
|
||||||
#define _MD_ATOMIC_ADD _PR_ia64_AtomicAdd
|
|
||||||
extern PRInt32 _PR_ia64_AtomicSet(PRInt32 *val, PRInt32 newval);
|
|
||||||
#define _MD_ATOMIC_SET _PR_ia64_AtomicSet
|
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
#if defined(__x86_64__)
|
#if defined(__x86_64__)
|
||||||
@ -58,20 +41,11 @@ diff --git a/pr/include/md/_linux.h b/pr/include/md/_linux.h
|
|||||||
#define _PR_HAVE_ATOMIC_OPS
|
#define _PR_HAVE_ATOMIC_OPS
|
||||||
#define _MD_INIT_ATOMIC()
|
#define _MD_INIT_ATOMIC()
|
||||||
extern PRInt32 _PR_x86_64_AtomicIncrement(PRInt32 *val);
|
extern PRInt32 _PR_x86_64_AtomicIncrement(PRInt32 *val);
|
||||||
#define _MD_ATOMIC_INCREMENT _PR_x86_64_AtomicIncrement
|
@@ -142,6 +161,7 @@ extern PRInt32 _PR_x86_64_AtomicAdd(PRIn
|
||||||
extern PRInt32 _PR_x86_64_AtomicDecrement(PRInt32 *val);
|
|
||||||
#define _MD_ATOMIC_DECREMENT _PR_x86_64_AtomicDecrement
|
|
||||||
extern PRInt32 _PR_x86_64_AtomicAdd(PRInt32 *ptr, PRInt32 val);
|
|
||||||
#define _MD_ATOMIC_ADD _PR_x86_64_AtomicAdd
|
|
||||||
extern PRInt32 _PR_x86_64_AtomicSet(PRInt32 *val, PRInt32 newval);
|
extern PRInt32 _PR_x86_64_AtomicSet(PRInt32 *val, PRInt32 newval);
|
||||||
#define _MD_ATOMIC_SET _PR_x86_64_AtomicSet
|
#define _MD_ATOMIC_SET _PR_x86_64_AtomicSet
|
||||||
#endif
|
#endif
|
||||||
+#endif
|
+#endif
|
||||||
|
|
||||||
#if defined(__or1k__)
|
#if defined(__loongarch__)
|
||||||
#if defined(__GNUC__)
|
#if defined(__GNUC__)
|
||||||
/* Use GCC built-in functions */
|
|
||||||
#define _PR_HAVE_ATOMIC_OPS
|
|
||||||
#define _MD_INIT_ATOMIC()
|
|
||||||
#define _MD_ATOMIC_INCREMENT(ptr) __sync_add_and_fetch(ptr, 1)
|
|
||||||
#define _MD_ATOMIC_DECREMENT(ptr) __sync_sub_and_fetch(ptr, 1)
|
|
||||||
|
3411
nss-3.79-dbtool.patch
Normal file
3411
nss-3.79-dbtool.patch
Normal file
File diff suppressed because it is too large
Load Diff
22
nss.spec
22
nss.spec
@ -1,5 +1,5 @@
|
|||||||
%global nspr_version 4.34.0
|
%global nspr_version 4.35.0
|
||||||
%global nss_version 3.81.0
|
%global nss_version 3.83.0
|
||||||
# NOTE: To avoid NVR clashes of nspr* packages:
|
# NOTE: To avoid NVR clashes of nspr* packages:
|
||||||
# - reset %%{nspr_release} to 1, when updating %%{nspr_version}
|
# - reset %%{nspr_release} to 1, when updating %%{nspr_version}
|
||||||
# - increment %%{nspr_version}, when updating the NSS part only
|
# - increment %%{nspr_version}, when updating the NSS part only
|
||||||
@ -7,7 +7,7 @@
|
|||||||
%global nss_release %baserelease
|
%global nss_release %baserelease
|
||||||
# use "%%global nspr_release %%[%%baserelease+n]" to handle offsets when
|
# use "%%global nspr_release %%[%%baserelease+n]" to handle offsets when
|
||||||
# release number between nss and nspr are different.
|
# release number between nss and nspr are different.
|
||||||
%global nspr_release %[%baserelease+2]
|
%global nspr_release %baserelease
|
||||||
# only need to update this as we added new
|
# only need to update this as we added new
|
||||||
# algorithms under nss policy control
|
# algorithms under nss policy control
|
||||||
%global crypto_policies_version 20210118
|
%global crypto_policies_version 20210118
|
||||||
@ -137,6 +137,8 @@ Patch40: nss-no-dbm-man-page.patch
|
|||||||
|
|
||||||
# upstream bug https://bugzilla.mozilla.org/show_bug.cgi?id=1774654
|
# upstream bug https://bugzilla.mozilla.org/show_bug.cgi?id=1774654
|
||||||
Patch50: nss-3.79-fix-client-cert-crash.patch
|
Patch50: nss-3.79-fix-client-cert-crash.patch
|
||||||
|
# https://bugzilla.mozilla.org/show_bug.cgi?id=1774659
|
||||||
|
Patch51: nss-3.79-dbtool.patch
|
||||||
|
|
||||||
Patch100: nspr-config-pc.patch
|
Patch100: nspr-config-pc.patch
|
||||||
Patch101: nspr-gcc-atomics.patch
|
Patch101: nspr-gcc-atomics.patch
|
||||||
@ -737,7 +739,7 @@ do
|
|||||||
done
|
done
|
||||||
|
|
||||||
# Copy the binaries we ship as unsupported
|
# Copy the binaries we ship as unsupported
|
||||||
for file in bltest ecperf fbectest fipstest shlibsign atob btoa derdump listsuites ocspclnt pp selfserv signtool strsclnt symkeyutil tstclnt vfyserv vfychain
|
for file in bltest dbtool ecperf fbectest fipstest shlibsign atob btoa derdump listsuites ocspclnt pp selfserv signtool strsclnt symkeyutil tstclnt vfyserv vfychain
|
||||||
do
|
do
|
||||||
install -p -m 755 dist/${LOBJDIR}/bin/$file $RPM_BUILD_ROOT/%{unsupported_tools_directory}
|
install -p -m 755 dist/${LOBJDIR}/bin/$file $RPM_BUILD_ROOT/%{unsupported_tools_directory}
|
||||||
done
|
done
|
||||||
@ -1034,6 +1036,7 @@ update-crypto-policies &> /dev/null || :
|
|||||||
%dir %{saved_files_dir}
|
%dir %{saved_files_dir}
|
||||||
%dir %{unsupported_tools_directory}
|
%dir %{unsupported_tools_directory}
|
||||||
%{unsupported_tools_directory}/bltest
|
%{unsupported_tools_directory}/bltest
|
||||||
|
%{unsupported_tools_directory}/dbtool
|
||||||
%{unsupported_tools_directory}/ecperf
|
%{unsupported_tools_directory}/ecperf
|
||||||
%{unsupported_tools_directory}/fbectest
|
%{unsupported_tools_directory}/fbectest
|
||||||
%{unsupported_tools_directory}/fipstest
|
%{unsupported_tools_directory}/fipstest
|
||||||
@ -1094,10 +1097,17 @@ update-crypto-policies &> /dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Sat Sep 03 2022 David Abdurachmanov <davidlt@rivosinc.com> - 3.81.0-1.0.riscv64
|
* Sun Oct 2 2022 David Abdurachmanov <davidlt@rivosinc.com> - 3.83.0-1.0.riscv64
|
||||||
- Disable tests on riscv64
|
- Disable tests on riscv64
|
||||||
|
|
||||||
* Thu Jun 21 2022 Bob Relyea <rrelyea@redhat.com> - 3.81.0-1
|
* Fri Sep 9 2022 Bob Relyea <rrelyea@redhat.com> - 3.83.0-1
|
||||||
|
- update to NSS 3.83
|
||||||
|
- update to NSPR 4.35
|
||||||
|
|
||||||
|
* Fri Sep 9 2022 Bob Relyea <rrelyea@redhat.com> - 3.81.0-2
|
||||||
|
- add dbtool
|
||||||
|
|
||||||
|
* Thu Jul 21 2022 Bob Relyea <rrelyea@redhat.com> - 3.81.0-1
|
||||||
- udpate to NSS 3.81
|
- udpate to NSS 3.81
|
||||||
|
|
||||||
* Thu Jun 16 2022 Bob Relyea <rrelyea@redhat.com> - 3.79.0-2
|
* Thu Jun 16 2022 Bob Relyea <rrelyea@redhat.com> - 3.79.0-2
|
||||||
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
|||||||
SHA512 (blank-cert9.db) = 2f8eab4c0612210ee47db8a3a80c1b58a0b43849551af78c7da403fda3e3d4e7757838061ae56ccf5aac335cb54f254f0a9e6e9c0dd5920b4155a39264525b06
|
SHA512 (blank-cert9.db) = 2f8eab4c0612210ee47db8a3a80c1b58a0b43849551af78c7da403fda3e3d4e7757838061ae56ccf5aac335cb54f254f0a9e6e9c0dd5920b4155a39264525b06
|
||||||
SHA512 (blank-key4.db) = 8fedae93af7163da23fe9492ea8e785a44c291604fa98e58438448efb69c85d3253fc22b926d5c3209c62e58a86038fd4d78a1c4c068bc00600a7f3e5382ebe7
|
SHA512 (blank-key4.db) = 8fedae93af7163da23fe9492ea8e785a44c291604fa98e58438448efb69c85d3253fc22b926d5c3209c62e58a86038fd4d78a1c4c068bc00600a7f3e5382ebe7
|
||||||
SHA512 (nspr-4.34.tar.gz) = 4cfac886c14cf7df4c4b79fa1c3bc92e1b14260c9c3018fa2562060d62fecb4e66c0b4e8f7edf4f4823def784a919d99dde88a89674f0cd8a644310b0569ead4
|
SHA512 (nss-3.83.tar.gz) = 550cf1116e39e58041feaa67913f570d791e8153cc0522ba7ae02e27a61e0a4e6a25224be0f25d51a842dc11c70d600263450ebff0a9fdaa2840bafa3fc9ddd5
|
||||||
SHA512 (nss-3.81.tar.gz) = 206faa29ff9fc9c70f85cbb86690b55bd11003a1a5b1d49f5f3731fdd1221690f957a17d912ee5272505afb938968327f4532ae8f5d2d77e6e13370768229747
|
SHA512 (nspr-4.35.tar.gz) = 502815833116e25f79ddf71d1526484908aa92fbc55f8a892729cb404a4daafcc0470a89854cd080d2d20299fdb7d9662507c5362c7ae661cbacf308ac56ef7f
|
||||||
|
Loading…
Reference in New Issue
Block a user