Merge remote-tracking branch 'up/main' into main-riscv64
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
commit
c1e55a1927
1
.gitignore
vendored
1
.gitignore
vendored
@ -93,3 +93,4 @@ TestUser51.cert
|
||||
/nss-3.99-with-nspr-4.35.tar.gz
|
||||
/nss-3.100-with-nspr-4.35.tar.gz
|
||||
/nss-3.101-with-nspr-4.35.tar.gz
|
||||
/nss-3.103-with-nspr-4.35.tar.gz
|
||||
|
17
nss-3.103-unused-cipherwrap2.patch
Normal file
17
nss-3.103-unused-cipherwrap2.patch
Normal file
@ -0,0 +1,17 @@
|
||||
--- ./lib/softoken/pkcs11c.c.unused 2024-08-05 17:56:10.705414972 +0200
|
||||
+++ ./lib/softoken/pkcs11c.c 2024-08-05 18:09:04.681015706 +0200
|
||||
@@ -165,10 +165,14 @@ SFTKCipherWrap(AESKeyWrapContext, AESKey
|
||||
mmm##_DestroyContext(ctx, freeit); \
|
||||
}
|
||||
|
||||
+#ifndef NSS_DISABLE_DEPRECATED_RC2
|
||||
SFTKCipherWrap2(RC2Context, RC2);
|
||||
+#endif
|
||||
SFTKCipherWrap2(RC4Context, RC4);
|
||||
SFTKCipherWrap2(DESContext, DES);
|
||||
+#ifndef NSS_DISABLE_DEPRECATED_SEED
|
||||
SFTKCipherWrap2(SEEDContext, SEED);
|
||||
+#endif
|
||||
SFTKCipherWrap2(CamelliaContext, Camellia);
|
||||
SFTKCipherWrap2(AESContext, AES);
|
||||
SFTKCipherWrap2(AESKeyWrapContext, AESKeyWrap);
|
14
nss.spec
14
nss.spec
@ -1,13 +1,13 @@
|
||||
%global nspr_version 4.35.0
|
||||
%global nss_version 3.101.0
|
||||
%global nss_version 3.103.0
|
||||
# NOTE: To avoid NVR clashes of nspr* packages:
|
||||
# - reset %%{nspr_release} to 1, when updating %%{nspr_version}
|
||||
# - increment %%{nspr_version}, when updating the NSS part only
|
||||
%global baserelease 4
|
||||
%global baserelease 1
|
||||
%global nss_release %baserelease
|
||||
# use "%%global nspr_release %%[%%baserelease+n]" to handle offsets when
|
||||
# release number between nss and nspr are different.
|
||||
%global nspr_release %[%baserelease+23]
|
||||
%global nspr_release %[%baserelease+27]
|
||||
# only need to update this as we added new
|
||||
# algorithms under nss policy control
|
||||
%global crypto_policies_version 20240521
|
||||
@ -137,6 +137,9 @@ Patch40: nss-no-dbm-man-page.patch
|
||||
# allow crypto policies to enable kyber
|
||||
Patch41: nss-3.101-enable-kyber-policy.patch
|
||||
|
||||
# fix unused variable warnings
|
||||
Patch42: nss-3.103-unused-cipherwrap2.patch
|
||||
|
||||
Patch100: nspr-config-pc.patch
|
||||
Patch101: nspr-gcc-atomics.patch
|
||||
|
||||
@ -1085,9 +1088,12 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Aug 07 2024 David Abdurachmanov <davidlt@rivosinc.com> - 3.101.0-4.0.riscv64
|
||||
* Fri Aug 09 2024 David Abdurachmanov <davidlt@rivosinc.com> - 3.103.0-1.0.riscv64
|
||||
- Disable tests on riscv64 for now
|
||||
|
||||
* Mon Aug 5 2024 Frantisek Krenzelok <krenzelok.frantisek@gmail.com> - 3.103.0-1
|
||||
- Update NSS to 3.103.0
|
||||
|
||||
* Thu Jul 18 2024 Fedora Release Engineering <releng@fedoraproject.org> - 3.101.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (blank-cert9.db) = 2f8eab4c0612210ee47db8a3a80c1b58a0b43849551af78c7da403fda3e3d4e7757838061ae56ccf5aac335cb54f254f0a9e6e9c0dd5920b4155a39264525b06
|
||||
SHA512 (blank-key4.db) = 8fedae93af7163da23fe9492ea8e785a44c291604fa98e58438448efb69c85d3253fc22b926d5c3209c62e58a86038fd4d78a1c4c068bc00600a7f3e5382ebe7
|
||||
SHA512 (nss-3.101-with-nspr-4.35.tar.gz) = 95c8ef1c12e1de7da4d918cebd1d5464b0ff4932083f6d395733345bd9f8598069028793fd1c08f974efcb31129cd84718487fd5326e45a878fba0d8c309bd39
|
||||
SHA512 (nss-3.103-with-nspr-4.35.tar.gz) = 46d0c948da890bd57da0e8026ec5bd1c6de2d34f66836690fa11ffbb256c933e977a1ac1d0599ceaf1b416eafe6f6733609ff1efa51a744b431b9570afe092ff
|
||||
|
Loading…
Reference in New Issue
Block a user